vim: update to 9.0
Remove upstreamed patches: - 001-support-defining-compilation-date-in-SOURCE_DATE_EPOCH.patch ->8f1dde5021
- 020-macos.patch ->5289783e0b
Refresh patches: - 002-remove_helptags_generation.patch Release Notes: https://www.vim.org/vim90.php Add to configure_args: --disable-libsodium Signed-off-by: Nick Hainke <vincent@systemli.org>
This commit is contained in:
parent
d7d39043c3
commit
f1bacdc1dc
4 changed files with 7 additions and 131 deletions
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=vim
|
||||
PKG_VERSION:=8.2
|
||||
PKG_RELEASE:=5
|
||||
VIMVER:=82
|
||||
PKG_VERSION:=9.0
|
||||
PKG_RELEASE:=1
|
||||
VIMVER:=90
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://ftp.vim.org/pub/vim/unix
|
||||
PKG_HASH:=f087f821831b4fece16a0461d574ccd55a8279f64d635510a1e10225966ced3b
|
||||
PKG_HASH:=a6456bc154999d83d0c20d968ac7ba6e7df0d02f3cb6427fb248660bacfb336e
|
||||
PKG_MAINTAINER:=Marko Ratkaj <markoratkaj@gmail.com>
|
||||
PKG_CPE_ID:=cpe:/a:vim:vim
|
||||
|
||||
|
@ -120,6 +120,7 @@ CONFIGURE_ARGS += \
|
|||
--disable-cscope \
|
||||
--disable-gpm \
|
||||
--disable-acl \
|
||||
--disable-libsodium \
|
||||
--disable-selinux \
|
||||
--with-tlib=ncurses \
|
||||
--with-compiledby="non-existent-hostname-compiled"
|
||||
|
|
|
@ -1,83 +0,0 @@
|
|||
From: James McCoy <jamessan@jamessan.com>
|
||||
Date: Thu, 28 Jan 2016 10:55:11 -0500
|
||||
Subject: Support defining compilation date in $SOURCE_DATE_EPOCH
|
||||
|
||||
There is an ongoing effort[0] to make FOSS software reproducibly
|
||||
buildable. In order to make Vim build reproducibly, it is necessary to
|
||||
allow defining the date/time that is part of VIM_VERSION_LONG as part of
|
||||
the build process.
|
||||
|
||||
This commit enables that by adding support for the SOURCE_DATE_EPOCH
|
||||
spec[1]. When the $SOURCE_DATE_EPOCH environment variable is defined,
|
||||
it will be used to populate the BUILD_DATE preprocessor define.
|
||||
|
||||
If BUILD_DATE is not defined, the existing behavior of relying on the
|
||||
preprocessor's __DATE__/__TIME__ symbols will be used.
|
||||
|
||||
[0]: https://reproducible-builds.org/
|
||||
[1]: https://reproducible-builds.org/specs/source-date-epoch/
|
||||
---
|
||||
src/config.h.in | 3 +++
|
||||
src/configure.ac | 10 ++++++++++
|
||||
src/version.c | 8 ++++++++
|
||||
3 files changed, 21 insertions(+)
|
||||
|
||||
--- a/src/config.h.in
|
||||
+++ b/src/config.h.in
|
||||
@@ -30,6 +30,9 @@
|
||||
/* Define when __DATE__ " " __TIME__ can be used */
|
||||
#undef HAVE_DATE_TIME
|
||||
|
||||
+/* Defined as the date of last modification */
|
||||
+#undef BUILD_DATE
|
||||
+
|
||||
/* Define when __attribute__((unused)) can be used */
|
||||
#undef HAVE_ATTRIBUTE_UNUSED
|
||||
|
||||
--- a/src/configure.ac
|
||||
+++ b/src/configure.ac
|
||||
@@ -62,6 +62,16 @@ if test x"$ac_cv_prog_cc_c99" != xno; th
|
||||
fi
|
||||
fi
|
||||
|
||||
+dnl If $SOURCE_DATE_EPOCH is present in the environment, use that as the
|
||||
+dnl "compiled" timestamp in :version's output. Attempt to get the formatted
|
||||
+dnl date using GNU date syntax, BSD date syntax, and finally falling back to
|
||||
+dnl just using the current time.
|
||||
+if test -n "$SOURCE_DATE_EPOCH"; then
|
||||
+ DATE_FMT="%b %d %Y %H:%M:%S"
|
||||
+ BUILD_DATE=$(LC_ALL=C date -u -d "@$SOURCE_DATE_EPOCH" "+$DATE_FMT" 2>/dev/null || LC_ALL=C date -u -r "$SOURCE_DATE_EPOCH" "+$DATE_FMT" 2>/dev/null || LC_ALL=C date -u "+$DATE_FMT")
|
||||
+ AC_DEFINE_UNQUOTED(BUILD_DATE, ["$BUILD_DATE"])
|
||||
+fi
|
||||
+
|
||||
dnl Check for the flag that fails if stuff are missing.
|
||||
|
||||
AC_MSG_CHECKING(--enable-fail-if-missing argument)
|
||||
--- a/src/version.c
|
||||
+++ b/src/version.c
|
||||
@@ -44,9 +44,13 @@ init_longVersion(void)
|
||||
* VAX C can't concatenate strings in the preprocessor.
|
||||
*/
|
||||
strcpy(longVersion, VIM_VERSION_LONG_DATE);
|
||||
+#ifdef BUILD_DATE
|
||||
+ strcat(longVersion, BUILD_DATE);
|
||||
+#else
|
||||
strcat(longVersion, __DATE__);
|
||||
strcat(longVersion, " ");
|
||||
strcat(longVersion, __TIME__);
|
||||
+#endif
|
||||
strcat(longVersion, ")");
|
||||
}
|
||||
|
||||
@@ -54,7 +58,11 @@ init_longVersion(void)
|
||||
void
|
||||
init_longVersion(void)
|
||||
{
|
||||
+#ifdef BUILD_DATE
|
||||
+ char *date_time = BUILD_DATE;
|
||||
+#else
|
||||
char *date_time = __DATE__ " " __TIME__;
|
||||
+#endif
|
||||
char *msg = _("%s (%s, compiled %s)");
|
||||
size_t len = strlen(msg)
|
||||
+ strlen(VIM_VERSION_LONG_ONLY)
|
|
@ -1,13 +1,10 @@
|
|||
--- a/runtime/doc/Makefile
|
||||
+++ b/runtime/doc/Makefile
|
||||
@@ -323,10 +323,6 @@ all: tags vim.man evim.man vimdiff.man v
|
||||
@@ -345,7 +345,6 @@ all: tags vim.man evim.man vimdiff.man v
|
||||
# Use Vim to generate the tags file. Can only be used when Vim has been
|
||||
# compiled and installed. Supports multiple languages.
|
||||
vimtags: $(DOCS)
|
||||
- @if command -v $(VIMEXE); then \
|
||||
- $(VIMEXE) --clean -eX -u doctags.vim >/dev/null && \
|
||||
- echo "help tags updated"; \
|
||||
- else echo "vim executable $(VIMEXE) not found; help tags not updated"; fi
|
||||
- @$(VIMEXE) --clean -esX -V1 -u doctags.vim
|
||||
|
||||
# Use "doctags" to generate the tags file. Only works for English!
|
||||
tags: doctags $(DOCS)
|
||||
|
|
|
@ -1,39 +0,0 @@
|
|||
From 5289783e0b07cfc3f92ee933261ca4c4acdca007 Mon Sep 17 00:00:00 2001
|
||||
From: Bram Moolenaar <Bram@vim.org>
|
||||
Date: Thu, 2 Jul 2020 22:50:37 +0200
|
||||
Subject: [PATCH] patch 8.2.1119: configure fails with Xcode 12 beta
|
||||
|
||||
Problem: Configure fails with Xcode 12 beta.
|
||||
Solution: use "return" instead of "exit()". (Nico Weber, closes #6381)
|
||||
---
|
||||
src/auto/configure | 4 ++--
|
||||
src/configure.ac | 4 ++--
|
||||
src/version.c | 2 ++
|
||||
3 files changed, 6 insertions(+), 4 deletions(-)
|
||||
|
||||
--- a/src/auto/configure
|
||||
+++ b/src/auto/configure
|
||||
@@ -14005,8 +14005,8 @@ else
|
||||
main() {
|
||||
uint32_t nr1 = (uint32_t)-1;
|
||||
uint32_t nr2 = (uint32_t)0xffffffffUL;
|
||||
- if (sizeof(uint32_t) != 4 || nr1 != 0xffffffffUL || nr2 + 1 != 0) exit(1);
|
||||
- exit(0);
|
||||
+ if (sizeof(uint32_t) != 4 || nr1 != 0xffffffffUL || nr2 + 1 != 0) return 1;
|
||||
+ return 0;
|
||||
}
|
||||
_ACEOF
|
||||
if ac_fn_c_try_run "$LINENO"; then :
|
||||
--- a/src/configure.ac
|
||||
+++ b/src/configure.ac
|
||||
@@ -4129,8 +4129,8 @@ AC_TRY_RUN([
|
||||
main() {
|
||||
uint32_t nr1 = (uint32_t)-1;
|
||||
uint32_t nr2 = (uint32_t)0xffffffffUL;
|
||||
- if (sizeof(uint32_t) != 4 || nr1 != 0xffffffffUL || nr2 + 1 != 0) exit(1);
|
||||
- exit(0);
|
||||
+ if (sizeof(uint32_t) != 4 || nr1 != 0xffffffffUL || nr2 + 1 != 0) return 1;
|
||||
+ return 0;
|
||||
}],
|
||||
AC_MSG_RESULT(ok),
|
||||
AC_MSG_ERROR([WRONG! uint32_t not defined correctly.]),
|
Loading…
Reference in a new issue