hplip: Update to 3.18.9
Added patch to fix some glibc-isms. Added PKG_BUILD_PARALLEL for faster compilation. Rearranged slightly for consistency between packages. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
988a9886d4
commit
f1633f3b2b
6 changed files with 46 additions and 23 deletions
|
@ -9,17 +9,19 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=hplip
|
||||
PKG_VERSION:=3.18.6
|
||||
PKG_VERSION:=3.18.9
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/hplip
|
||||
PKG_HASH:=0ecf3e68b09480f602de81798ac00774cf8ffe754692e784bbbe0f9b2e337b7d
|
||||
PKG_HASH:=20093830994de16bb36c049c1fdb688569531525fb994f7e605e66266a2d783c
|
||||
|
||||
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0 GPL-2.0+
|
||||
PKG_LICENSE_FILES:=COPYING LICENSE
|
||||
|
||||
PKG_BUILD_DEPENDS := python libcups
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_DEPENDS:= python libcups
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -28,7 +30,7 @@ define Package/hplip/Default
|
|||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=HP Linux Imaging and Printing
|
||||
URL:=http://sourceforge.net/projects/hplip/
|
||||
URL:=https://sourceforge.net/projects/hplip/
|
||||
endef
|
||||
|
||||
define Package/hplip/Default/description
|
||||
|
@ -66,6 +68,10 @@ CONFIGURE_ARGS += \
|
|||
--disable-pp-build \
|
||||
--disable-doc-build \
|
||||
--disable-dbus-build \
|
||||
--disable-hpijs-only-build \
|
||||
--disable-hpcups-install \
|
||||
--disable-hpps-install \
|
||||
--disable-cups-drv-install \
|
||||
--enable-lite-build
|
||||
|
||||
define Package/hplip-common/install
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -595,6 +595,10 @@ if test "$class_driver" = "no" && test "
|
||||
@@ -598,6 +598,10 @@ if test "$class_driver" = "no" && test "$hpijs_only_build" = "no" && test "$hpcu
|
||||
else
|
||||
AC_CHECK_LIB([usb-1.0], [libusb_init], [LIBS="$LIBS"], [AC_MSG_ERROR([cannot find libusb 1.0 support], 2)])
|
||||
AC_CHECK_HEADERS(libusb-1.0/libusb.h, ,[AC_MSG_ERROR([cannot find libusb-1.0-devel support], 11)])
|
||||
|
|
|
@ -1,3 +1,14 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -71,7 +71,7 @@ else
|
||||
libsane_hpaio_la_LDFLAGS = -version-info 1:0:0
|
||||
endif
|
||||
# The following is a interlibrary dependency that must be compiled first.
|
||||
-libsane_hpaio_la_LIBADD = libhpip.la libhpmud.la libhpipp.la $(DBUS_LIBS) -lcups -ldl
|
||||
+libsane_hpaio_la_LIBADD = libhpip.la libhpmud.la libhpipp.la $(DBUS_LIBS) -ldl
|
||||
#libsane_hpaio_la_CFLAGS = -DWITH_NONAMESPACES -DSOAP_DEBUG
|
||||
libsane_hpaio_la_CFLAGS = $(DBUS_CFLAGS) -Iprotocol
|
||||
|
||||
--- a/scan/sane/hpaio.c
|
||||
+++ b/scan/sane/hpaio.c
|
||||
@@ -34,7 +34,6 @@
|
||||
|
@ -6,9 +17,9 @@
|
|||
#include <string.h>
|
||||
-#include <cups/cups.h>
|
||||
#include "hpmud.h"
|
||||
#include "hpip.h"
|
||||
#include "hp_ipp.h"
|
||||
@@ -144,98 +143,6 @@ static int GetUriLine(char *buf, char *u
|
||||
#include "soap.h"
|
||||
@@ -145,98 +144,6 @@ static int GetUriLine(char *buf, char *uri, char **tail)
|
||||
return i;
|
||||
}
|
||||
|
||||
|
@ -107,7 +118,7 @@
|
|||
static int AddDevice(char *uri)
|
||||
{
|
||||
struct hpmud_model_attributes ma;
|
||||
@@ -264,7 +171,6 @@ static int DevDiscovery(int localOnly)
|
||||
@@ -289,7 +196,6 @@ static int DevDiscovery(int localOnly)
|
||||
char uri[HPMUD_LINE_SIZE];
|
||||
char *tail = message;
|
||||
int i, scan_type, cnt=0, total=0, bytes_read;
|
||||
|
@ -115,7 +126,7 @@
|
|||
char* token = NULL;
|
||||
enum HPMUD_RESULT stat;
|
||||
|
||||
@@ -279,34 +185,6 @@ static int DevDiscovery(int localOnly)
|
||||
@@ -304,34 +210,6 @@ static int DevDiscovery(int localOnly)
|
||||
total += AddDevice(uri);
|
||||
}
|
||||
|
||||
|
@ -150,14 +161,3 @@
|
|||
bugout:
|
||||
return total;
|
||||
}
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -67,7 +67,7 @@ else
|
||||
libsane_hpaio_la_LDFLAGS = -version-info 1:0:0
|
||||
endif
|
||||
# The following is a interlibrary dependency that must be compiled first.
|
||||
-libsane_hpaio_la_LIBADD = libhpip.la libhpmud.la libhpipp.la $(DBUS_LIBS) -lcups -ldl
|
||||
+libsane_hpaio_la_LIBADD = libhpip.la libhpmud.la libhpipp.la $(DBUS_LIBS) -ldl
|
||||
#libsane_hpaio_la_CFLAGS = -DWITH_NONAMESPACES -DSOAP_DEBUG
|
||||
libsane_hpaio_la_CFLAGS = $(DBUS_CFLAGS) -Iprotocol
|
||||
|
||||
|
|
|
@ -4,7 +4,7 @@ memcpy should never be used with overlapping memory regions
|
|||
|
||||
--- a/io/hpmud/musb.c
|
||||
+++ b/io/hpmud/musb.c
|
||||
@@ -775,7 +775,7 @@ static int device_id(int fd, unsigned ch
|
||||
@@ -775,7 +775,7 @@ static int device_id(int fd, unsigned char *buffer, int size)
|
||||
len = size-1; /* leave byte for zero termination */
|
||||
if (len > 2)
|
||||
len -= 2;
|
||||
|
|
|
@ -11,7 +11,7 @@ https://bugs.launchpad.net/hplip/+bug/1778626
|
|||
|
||||
/*
|
||||
********************************************* Helper Routines **************************
|
||||
@@ -343,7 +343,7 @@ bool PCLmGenerator::addKids(sint32 kidOb
|
||||
@@ -343,7 +343,7 @@ bool PCLmGenerator::addKids(sint32 kidObj)
|
||||
return(true);
|
||||
}
|
||||
|
||||
|
@ -20,7 +20,7 @@ https://bugs.launchpad.net/hplip/+bug/1778626
|
|||
{
|
||||
FILE *outputFile;
|
||||
char outFileName[MAX_FILE_PATH_LEN];
|
||||
@@ -1074,7 +1074,7 @@ void PCLmGenerator::writePDFGrammarPage(
|
||||
@@ -1074,7 +1074,7 @@ void PCLmGenerator::writePDFGrammarPage(int imageWidth, int imageHeight, int num
|
||||
* Limitations:
|
||||
* -
|
||||
*****************************************************************************************/
|
||||
|
|
17
utils/hplip/patches/050-fix-glibcisms.patch
Normal file
17
utils/hplip/patches/050-fix-glibcisms.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
diff --git a/scan/sane/OrbliteScan/LinuxCommon.h b/scan/sane/OrbliteScan/LinuxCommon.h
|
||||
index 6605dd9..55c7110 100644
|
||||
--- a/scan/sane/OrbliteScan/LinuxCommon.h
|
||||
+++ b/scan/sane/OrbliteScan/LinuxCommon.h
|
||||
@@ -18,10 +18,8 @@ typedef u_int32_t UInt32;
|
||||
typedef int32_t SInt32;
|
||||
//typedef unsigned long UInt32;
|
||||
//typedef signed long SInt32;
|
||||
-typedef __S64_TYPE SInt64;
|
||||
-typedef __U64_TYPE UInt64;
|
||||
-typedef __S64_TYPE int64_t;
|
||||
-typedef __U64_TYPE uint64_t;
|
||||
+typedef int64_t SInt64;
|
||||
+typedef uint64_t UInt64;
|
||||
|
||||
//typedef unsigned long ULONG;
|
||||
//typedef void* LPVOID;
|
Loading…
Reference in a new issue