From f0e12ae71be3ed27e63d6fb2693bbe1dc053396c Mon Sep 17 00:00:00 2001
From: Sebastian Kemper <sebastian_ml@gmx.net>
Date: Mon, 23 Aug 2021 21:13:42 +0200
Subject: [PATCH] mdio-tools: fix buildbot build

On buildbots the build fails because git isn't finding any git repo and
then AC_INIT refuses to run:

fatal: not a git repository (or any parent up to mount point /)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
configure.ac:5: error: AC_INIT should be called with package and version arguments

Address this by substituting the git command with $(PKG_VERSION).

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
---
 net/mdio-tools/Makefile | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/net/mdio-tools/Makefile b/net/mdio-tools/Makefile
index 0fd380c09..cd31fb6cb 100644
--- a/net/mdio-tools/Makefile
+++ b/net/mdio-tools/Makefile
@@ -35,4 +35,9 @@ define Package/mdio-tools/install
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mdio/mdio $(1)/usr/bin/
 endef
 
+define Build/Prepare
+	$(call Build/Prepare/Default)
+	$(SED) 's/m4_esyscmd_s(.*)/$(PKG_VERSION)/' $(PKG_BUILD_DIR)/configure.ac
+endef
+
 $(eval $(call BuildPackage,mdio-tools))