python3: update to version 3.9.6
Refreshed patches. Bumped pip to 21.1.3. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com> (cherry picked from commit 44e009364f5a115172f5825fbfd8c0b3730021a5)
This commit is contained in:
parent
033b04ee70
commit
ef50ed85a5
4 changed files with 8 additions and 8 deletions
|
@ -8,7 +8,7 @@
|
|||
# Note: keep in sync with setuptools & pip
|
||||
PYTHON3_VERSION_MAJOR:=3
|
||||
PYTHON3_VERSION_MINOR:=9
|
||||
PYTHON3_VERSION_MICRO:=5
|
||||
PYTHON3_VERSION_MICRO:=6
|
||||
|
||||
PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
|
||||
|
||||
|
@ -16,4 +16,4 @@ PYTHON3_SETUPTOOLS_PKG_RELEASE:=1
|
|||
PYTHON3_PIP_PKG_RELEASE:=1
|
||||
|
||||
PYTHON3_SETUPTOOLS_VERSION:=56.0.0
|
||||
PYTHON3_PIP_VERSION:=21.1.1
|
||||
PYTHON3_PIP_VERSION:=21.1.3
|
||||
|
|
|
@ -11,12 +11,12 @@ include $(TOPDIR)/rules.mk
|
|||
include ../python3-version.mk
|
||||
|
||||
PKG_NAME:=python3
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
|
||||
|
||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
|
||||
PKG_HASH:=0c5a140665436ec3dbfbb79e2dfb6d192655f26ef4a29aeffcb6d1820d716d83
|
||||
PKG_HASH:=397920af33efc5b97f2e0b57e91923512ef89fc5b3c1d21dbfc8c4828ce0108a
|
||||
|
||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
||||
PKG_LICENSE:=Python/2.0
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -15371,7 +15371,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
|
||||
@@ -15390,7 +15390,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
|
||||
$as_echo "$ABIFLAGS" >&6; }
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking SOABI" >&5
|
||||
$as_echo_n "checking SOABI... " >&6; }
|
||||
|
@ -11,7 +11,7 @@
|
|||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4781,7 +4781,7 @@ AC_SUBST(SOABI)
|
||||
@@ -4800,7 +4800,7 @@ AC_SUBST(SOABI)
|
||||
AC_MSG_CHECKING(ABIFLAGS)
|
||||
AC_MSG_RESULT($ABIFLAGS)
|
||||
AC_MSG_CHECKING(SOABI)
|
||||
|
|
|
@ -49,7 +49,7 @@
|
|||
fi
|
||||
elif test "$cross_compiling" = maybe; then
|
||||
as_fn_error $? "Cross compiling required --host=HOST-TUPLE and --build=ARCH" "$LINENO" 5
|
||||
@@ -15441,7 +15441,7 @@ fi
|
||||
@@ -15460,7 +15460,7 @@ fi
|
||||
|
||||
|
||||
|
||||
|
@ -69,7 +69,7 @@
|
|||
fi
|
||||
elif test "$cross_compiling" = maybe; then
|
||||
AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
|
||||
@@ -4839,7 +4839,7 @@ fi],
|
||||
@@ -4858,7 +4858,7 @@ fi],
|
||||
|
||||
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
||||
AC_SUBST(PY_ENABLE_SHARED)
|
||||
|
|
Loading…
Reference in a new issue