From ee93d38db88b92933d0775d1078f1f00e8c0f96a Mon Sep 17 00:00:00 2001
From: Daniel Dickinson <lede@cshore.thecshore.com>
Date: Fri, 16 Sep 2016 21:49:08 -0400
Subject: [PATCH] mail/msmtp: Separate option to use msmtp as sendmail

Make msmtp as MTA separate from msmtp package proper to
allow msmtp-scripts (to be added) to use msmtp as the
backend while providing the ability to act as the
system MTA without msmtp getting in the way.

Also get rid of symlinking in postinst/postrm as that
is something the trunk devs don't like.  In addition
it allows the -mta package to conflict with any
other package providing sendmail command, as it should
(once the other packages also move postinst/postrm
sendmail symlinks to install section).

Signed-off-by: Daniel Dickinson <lede@cshore.thecshore.com>
---
 mail/msmtp/Makefile | 26 +++++++++++++++++++++-----
 1 file changed, 21 insertions(+), 5 deletions(-)

diff --git a/mail/msmtp/Makefile b/mail/msmtp/Makefile
index 9ea72427b..09bf3c686 100644
--- a/mail/msmtp/Makefile
+++ b/mail/msmtp/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=msmtp
 PKG_VERSION:=1.6.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@SF/msmtp
@@ -71,9 +71,21 @@ $(call Package/msmtp/Default/description)
  This package is built without SSL support.
 endef
 
+define Package/msmtp-mta
+$(call Package/msmtp/Default)
+  TITLE+= (as MTA)
+  DEPENDS+=@(PACKAGE_msmtp||PACAKGE_msmtp-nossl)
+endef
+
+define Package/msmtp-mta/description
+$(call Package/msmtp/Default/description)
+ This package add a link from sendmail to msmtp
+ and is built with SSL support.
+endef
+
 define Package/msmtp-queue
 $(call Package/msmtp/Default)
-  DEPENDS+= +bash
+  DEPENDS+= +bash @(PACKAGE_msmtp||PACKAGE_msmtp-nossl)
   TITLE+= (queue scripts)
 endef
 
@@ -112,13 +124,16 @@ define Package/msmtp/install
 		$(1)/etc/msmtprc
 	$(INSTALL_DIR) $(1)/usr/bin
 	$(CP) $(PKG_INSTALL_DIR)/usr/bin/msmtp $(1)/usr/bin/
-	ln -s ../bin/msmtp $(1)/usr/sbin/sendmail
+endef
+
+define Package/msmtp-mta/install
+	$(INSTALL_DIR) $(1)/usr/sbin $(1)/usr/lib
+	ln -sf ../bin/msmtp $(1)/usr/sbin/sendmail
+	ln -sf ../bin/msmtp $(1)/usr/lib/sendmail
 endef
 
 Package/msmtp-nossl/conffiles = $(Package/msmtp/conffiles)
 Package/msmtp-nossl/install = $(Package/msmtp/install)
-Package/msmtp-nossl/postinst = $(Package/msmtp/postinst)
-Package/msmtp-nossl/prerm = $(Package/msmtp/prerm)
 
 define Package/msmtp-queue/install
 	$(INSTALL_DIR) $(1)/usr/bin
@@ -129,3 +144,4 @@ endef
 $(eval $(call BuildPackage,msmtp))
 $(eval $(call BuildPackage,msmtp-nossl))
 $(eval $(call BuildPackage,msmtp-queue))
+$(eval $(call BuildPackage,msmtp-mta))