diff --git a/admin/netdata/Makefile b/admin/netdata/Makefile
index 08f2bda53..7bff2a37a 100644
--- a/admin/netdata/Makefile
+++ b/admin/netdata/Makefile
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netdata
-PKG_VERSION:=1.9.0
+PKG_VERSION:=1.10.0
 PKG_RELEASE:=1
 PKG_MAINTAINER:=
 PKG_LICENSE:=GPL-3.0
@@ -16,7 +16,7 @@ PKG_LICENSE_FILES:=COPYING
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/firehol/netdata/releases/download/v$(PKG_VERSION)
-PKG_HASH:=2358f2239e2d62da82af9f8b9ec8e6b1d37ac6cb009a15cf4c1d2cc2638a87e7
+PKG_HASH:=0514fc002c5c5fb730156b3fe928965b22327833c6c17e22b7097eda657e77a2
 
 PKG_INSTALL:=1
 PKG_FIXUP:=autoreconf
diff --git a/admin/netdata/files/netdata.conf b/admin/netdata/files/netdata.conf
index 13418b55e..3026be116 100644
--- a/admin/netdata/files/netdata.conf
+++ b/admin/netdata/files/netdata.conf
@@ -9,224 +9,113 @@
 # You can uncomment and change any of the options below.
 # The value shown in the commented settings, is the default value.
 #
-# Notes about plugins
-#
-# tc          - QoS stats (if wanted)
-# cgcroups    - No support in OpenWRT/LEDE by default
-# charts.d    - REQUIRES bash, enable here and edit charts.d.conf
-# node.d      - REQUIRES node.js
-# python.d    - REQUIRES python and PyYAML, edit python.d.conf to enable
-# apps        - none atm
-# health      - Disabled by default
-# KSM         - No support in OpenWRT/LEDE by default
 
 # global netdata configuration
 
 [global]
 	# glibc malloc arena max for plugins = 1
-	# glibc malloc arena max for netdata = 1
+	# hostname = LEDE
+	# history = 4036
+	update every = 2
 	# config directory = /etc/netdata
-	# plugins directory = /usr/libexec/netdata/plugins.d
+	# log directory = /var/log/netdata
 	# web files directory = /usr/share/netdata/web
 	# cache directory = /var/cache/netdata
 	# lib directory = /var/lib/netdata
-	# log directory = /var/log/netdata
-	# host access prefix = 
 	# home directory = /var/cache/netdata
-	# debug flags = 0x00000000
+	# plugins directory = "/usr/lib/netdata/plugins.d" "/etc/netdata/custom-plugins.d"
+	# memory mode = save
+	# host access prefix = 
 	memory deduplication (ksm) = no
+	# TZ environment variable = :/etc/localtime
+	# timezone = UTC
+	# debug flags = 0x0000000000000000
 	debug log = syslog
 	error log = syslog
 	access log = none
 	# errors flood protection period = 1200
 	# errors to trigger flood protection = 200
-	memory mode = ram
-	# hostname = LEDE
-	# history = 3600
-	# update every = 1
-	update every = 2
-	# pthread stack size = 8388608
-	run as user = nobody
+	run as user = root
+	# OOM score = 1000
+	# process scheduling policy = idle
+	# process nice level = 19
+	# pthread stack size = 81920
+	# cleanup obsolete charts after seconds = 3600
+	# gap when lost iterations above = 1
+	# cleanup orphan hosts after seconds = 3600
+	# delete obsolete charts files = yes
+	# delete orphan hosts files = yes
 
 [web]
-	web files owner = root
-	web files group = root
+	# mode = static-threaded
+	# listen backlog = 4096
 	# default port = 19999
 	# bind to = *
+	# web files owner = nobody
+	# web files group = nogroup
+	# disconnect idle clients after seconds = 60
+	# timeout for first request = 60
+	# respect do not track policy = no
+	# x-frame-options response header = 
+	allow connections from = localhost 10.* 192.168.* 172.16.* 172.17.* 172.18.* 172.19.* 172.20.* 172.21.* 172.22.* 172.23.* 172.24.* 172.25.* 172.26.* 172.27.* 172.28.* 172.29.* 172.30.* 172.31.*
+	allow dashboard from = localhost 10.* 192.168.* 172.16.* 172.17.* 172.18.* 172.19.* 172.20.* 172.21.* 172.22.* 172.23.* 172.24.* 172.25.* 172.26.* 172.27.* 172.28.* 172.29.* 172.30.* 172.31.*
+	# allow badges from = *
+	# allow streaming from = *
+	# allow netdata.conf from = localhost fd* 10.* 192.168.* 172.16.* 172.17.* 172.18.* 172.19.* 172.20.* 172.21.* 172.22.* 172.23.* 172.24.* 172.25.* 172.26.* 172.27.* 172.28.* 172.29.* 172.30.* 172.31.*
+	# enable gzip compression = yes
+	# gzip compression strategy = default
+	# gzip compression level = 3
+	# web server threads = 2
+	# web server max sockets = 512
 
 [plugins]
-	# PATH environment variable = /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/sbin:/usr/sbin:/usr/local/bin:/usr/local/sbin
-	tc = no
-	# idlejitter = yes
+	# PATH environment variable = /usr/sbin:/usr/bin:/sbin:/bin:/sbin:/usr/sbin:/usr/local/bin:/usr/local/sbin
+	# PYTHONPATH environment variable = 
 	# proc = yes
 	# diskspace = yes
-	cgroups = no
-	# checks = no
-	# plugins directory = /usr/libexec/netdata/plugins.d
-	enable running new plugins = no
+	# cgroups = yes
+	# tc = yes
+	# idlejitter = yes
+	# enable running new plugins = yes
 	# check for new plugins every = 60
+	apps = no
 	charts.d = no
-	# plugins directory = /usr/libexec/netdata/plugins.d
+	fping = no
 	node.d = no
 	python.d = no
-	apps = no
-	fping = no
-
-[registry]
-	# enabled = no
-	# registry db directory = /var/lib/netdata/registry
-	# netdata unique id file = /var/lib/netdata/registry/netdata.public.unique.id
-	# registry db file = /var/lib/netdata/registry/registry.db
-	# registry log file = /var/lib/netdata/registry/registry-log.db
-	# registry save db every new entries = 1000000
-	# registry expire idle persons days = 365
-	# registry domain = 
-	# registry to announce = https://registry.my-netdata.io
-	# registry hostname = LEDE
-	# verify browser cookies support = yes
-	# max URL length = 1024
-	# max URL name length = 50
 
 [health]
 	enabled = no
-	# health db directory = /var/lib/netdata/health
-	# health db file = /var/lib/netdata/health/health-log.db
-	# health configuration directory = /etc/netdata/health.d
-	# script to execute on alarm = /usr/libexec/netdata/plugins.d/alarm-notify.sh
 	# in memory max health log entries = 1000
+	# script to execute on alarm = /usr/lib/netdata/plugins.d/alarm-notify.sh
+	# health configuration directory = /etc/netdata/health.d
 	# run at least every seconds = 10
+	# postpone alarms during hibernation for seconds = 60
 	# rotate log every lines = 2000
 
-[backend]
-	# enabled = no
-	# data source = average
-	# type = graphite
-	# destination = localhost
-	# prefix = netdata
-	# hostname = LEDE
-	# update every = 10
-	# buffer on failures = 10
-	# timeout ms = 20000
 
-# per plugin configuration
+[statsd]
+	enabled = no
+	# update every (flushInterval) = 1
+	# udp messages to process at once = 10
+	# create private charts for metrics matching = *
+	# max private charts allowed = 200
+	# max private charts hard limit = 1000
+	# private charts memory mode = save
+	# private charts history = 4036
+	# decimal detail = 1000
+	# disconnect idle tcp clients after seconds = 600
+	# private charts hidden = no
+	# histograms and timers percentile (percentThreshold) = 95.00000
+	# add dimension for number of events received = yes
+	# gaps on gauges (deleteGauges) = no
+	# gaps on counters (deleteCounters) = no
+	# gaps on meters (deleteMeters) = no
+	# gaps on sets (deleteSets) = no
+	# gaps on histograms (deleteHistograms) = no
+	# gaps on timers (deleteTimers) = no
+	# statsd server max TCP sockets = 256
+	# listen backlog = 4096
+	# default port = 8125
+	# bind to = udp:localhost tcp:localhost
 
-[plugin:fping]
-	# update every = 1
-	# command options = 
-
-[plugin:proc]
-	# netdata server resources = yes
-	# /proc/stat = yes
-	# /proc/uptime = yes
-	# /proc/loadavg = yes
-	# /proc/sys/kernel/random/entropy_avail = yes
-	# /proc/interrupts = yes
-	# /proc/softirqs = yes
-	# /proc/vmstat = yes
-	# /proc/meminfo = yes
-	/sys/kernel/mm/ksm = no
-	/sys/devices/system/edac/mc = no
-	/sys/devices/system/node = no
-	# /proc/net/dev = yes
-	/proc/net/netstat = no
-	/proc/net/snmp = no
-	/proc/net/snmp6 = no
-	/proc/net/softnet_stat = no
-	/proc/net/ip_vs/stats = no
-	# /proc/net/stat/conntrack = yes
-	/proc/net/stat/synproxy = no
-	# /proc/diskstats = yes
-	/proc/net/rpc/nfsd = no
-	/proc/net/rpc/nfs = no
-	# ipc = yes
-	/proc/spl/kstat/zfs/arcstats = no
-
-[plugin:proc:/proc/stat]
-	# cpu utilization = yes
-	# per cpu core utilization = yes
-	# cpu interrupts = yes
-	# context switches = yes
-	# processes started = yes
-	# processes running = yes
-	# filename to monitor = /proc/stat
-
-[plugin:proc:/proc/interrupts]
-	# interrupts per core = yes
-	# filename to monitor = /proc/interrupts
-
-[plugin:proc:/proc/softirqs]
-	# interrupts per core = yes
-	# filename to monitor = /proc/softirqs
-
-[plugin:proc:/proc/net/dev]
-	# enable new interfaces detected at runtime = auto
-	# bandwidth for all interfaces = auto
-	# packets for all interfaces = auto
-	# errors for all interfaces = auto
-	# drops for all interfaces = auto
-	# fifo for all interfaces = auto
-	# compressed packets for all interfaces = auto
-	# frames, collisions, carrier counters for all interfaces = auto
-	# disable by default interfaces matching = lo fireqos* *-ifb
-	# filename to monitor = /proc/net/dev 
-
-[plugin:proc:/proc/net/dev:eth0]
-	# enabled = yes
-	# bandwidth = auto
-	# packets = auto
-	# errors = auto
-	# drops = auto
-	# fifo = auto
-	# compressed = auto
-	# events = auto
-
-[plugin:proc:/proc/diskstats]
-	# enable new disks detected at runtime = yes
-	# performance metrics for physical disks = auto
-	# performance metrics for virtual disks = auto
-	# performance metrics for partitions = no
-	# bandwidth for all disks = auto
-	# operations for all disks = auto
-	# merged operations for all disks = auto
-	# i/o time for all disks = auto
-	# queued operations for all disks = auto
-	# utilization percentage for all disks = auto
-	# backlog for all disks = auto
-	# filename to monitor = /proc/diskstats
-	# path to get block device infos = /sys/dev/block/%lu:%lu/%s
-	# path to get h/w sector size = /sys/block/%s/queue/hw_sector_size
-	# path to get h/w sector size for partitions = /sys/dev/block/%lu:%lu/subsystem/%s/../queue/hw_sector_size
-	# performance metrics for disks with major 8 = yes
-
-[plugin:proc:/proc/diskstats:sda]
-	# enable = yes
-	# enable performance metrics = yes
-	# bandwidth = auto
-	# operations = auto
-	# merged operations = auto
-	# i/o time = auto
-	# queued operations = auto
-	# utilization percentage = auto
-	# backlog = auto
-
-[plugin:proc:/proc/net/rpc/nfsd]
-	# filename to monitor = /proc/net/rpc/nfsd
-	# read cache = yes
-	# file handles = yes
-	# I/O = yes
-	# threads = yes
-	# read ahead = yes
-	# network = yes
-	# rpc = yes
-	# NFS v2 procedures = yes
-	# NFS v3 procedures = yes
-	# NFS v4 procedures = yes
-	# NFS v4 operations = yes
-
-[plugin:proc:/proc/net/rpc/nfs]
-	# filename to monitor = /proc/net/rpc/nfs
-	# network = yes
-	# rpc = yes
-	# NFS v2 procedures = yes
-	# NFS v3 procedures = yes
-	# NFS v4 procedures = yes