poco: update to 1.11.0
Refresh patches and fix strerror one. uClibc also defines __GLIBC__. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
b4a4aab5fa
commit
ed6781bef1
3 changed files with 5 additions and 5 deletions
|
@ -9,15 +9,15 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=poco
|
||||
PKG_VERSION:=1.10.1
|
||||
PKG_VERSION:=1.11.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
ifeq ($(BUILD_VARIANT),all)
|
||||
_PKG_VERSION:=${PKG_VERSION}-all
|
||||
PKG_HASH:=2cde4b50778013ab3b7a522aa59bccaa7e85a8ccfc654a354c4d9611b6ce1758
|
||||
PKG_HASH:=b08cf73926fa92a6c8f3c712e8fb217d5d0c2fa5248ec0281f251fe1e925d2f1
|
||||
else
|
||||
_PKG_VERSION:=${PKG_VERSION}
|
||||
PKG_HASH:=cdab379d7d0394a763821d058eee1e7d4d8214a3caec05c775b60962b2f20762
|
||||
PKG_HASH:=06ddc4934ff0a11be425d697f861c15b43b77b610e3642a2f85d0c34d7425ea4
|
||||
endif
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(_PKG_VERSION).tar.bz2
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -237,9 +237,9 @@ while [ $# -ge 1 ]; do
|
||||
@@ -249,9 +249,9 @@ while [ $# -ge 1 ]; do
|
||||
;;
|
||||
|
||||
*)
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
#if (_XOPEN_SOURCE >= 600) || POCO_OS == POCO_OS_ANDROID || __APPLE__
|
||||
setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
|
||||
-#elif _GNU_SOURCE
|
||||
+#elif (_GNU_SOURCE && (defined __GLIBC__ || defined __UCLIBC__))
|
||||
+#elif (defined(_GNU_SOURCE) && defined(__GLIBC__))
|
||||
setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
|
||||
#else
|
||||
setMessage(strerror(err));
|
||||
|
|
Loading…
Reference in a new issue