strongswan: Update to 5.9.12
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
This commit is contained in:
parent
7e77f2c934
commit
ed30ca0f38
3 changed files with 8 additions and 8 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=strongswan
|
||||
PKG_VERSION:=5.9.11
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=5.9.12
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
|
||||
PKG_HASH:=ddf53f1f26ad26979d5f55e8da95bd389552f5de3682e35593f9a70b2584ed2d
|
||||
PKG_HASH:=5e6018b07cbe9f72c044c129955a13be3e2f799ceb53f53a4459da6a922b95e5
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_MAINTAINER:=Philip Prindeville <philipp@redfish-solutions.com>, Noel Kuntze <noel.kuntze@thermi.consulting>
|
||||
PKG_CPE_ID:=cpe:/a:strongswan:strongswan
|
||||
|
|
|
@ -48,7 +48,7 @@ Subject: [PATCH 900/904] src: Patch for building with musl on openwrt (taken
|
|||
#include <linux/rtnetlink.h>
|
||||
--- a/src/libstrongswan/library.h
|
||||
+++ b/src/libstrongswan/library.h
|
||||
@@ -120,6 +120,7 @@
|
||||
@@ -121,6 +121,7 @@
|
||||
#include "utils/leak_detective.h"
|
||||
#include "plugins/plugin_loader.h"
|
||||
#include "settings/settings.h"
|
||||
|
|
|
@ -26,7 +26,7 @@ Subject: [PATCH 904/904] gmpdh: Plugin that implements gmp DH functions in an
|
|||
ARG_DISBL_SET([curve25519], [disable Curve25519 Diffie-Hellman plugin.])
|
||||
ARG_DISBL_SET([hmac], [disable HMAC crypto implementation plugin.])
|
||||
ARG_DISBL_SET([kdf], [disable KDF (prf+) implementation plugin.])
|
||||
@@ -1565,6 +1566,7 @@ ADD_PLUGIN([pkcs8], [s ch
|
||||
@@ -1574,6 +1575,7 @@ ADD_PLUGIN([pkcs8], [s ch
|
||||
ADD_PLUGIN([af-alg], [s charon pki scripts medsrv attest nm cmd aikgen])
|
||||
ADD_PLUGIN([fips-prf], [s charon nm cmd])
|
||||
ADD_PLUGIN([gmp], [s charon pki scripts manager medsrv attest nm cmd aikgen fuzz])
|
||||
|
@ -34,7 +34,7 @@ Subject: [PATCH 904/904] gmpdh: Plugin that implements gmp DH functions in an
|
|||
ADD_PLUGIN([curve25519], [s charon pki scripts nm cmd])
|
||||
ADD_PLUGIN([agent], [s charon nm cmd])
|
||||
ADD_PLUGIN([keychain], [s charon cmd])
|
||||
@@ -1706,6 +1708,7 @@ AM_CONDITIONAL(USE_SHA3, test x$sha3 = x
|
||||
@@ -1716,6 +1718,7 @@ AM_CONDITIONAL(USE_SHA3, test x$sha3 = x
|
||||
AM_CONDITIONAL(USE_MGF1, test x$mgf1 = xtrue)
|
||||
AM_CONDITIONAL(USE_FIPS_PRF, test x$fips_prf = xtrue)
|
||||
AM_CONDITIONAL(USE_GMP, test x$gmp = xtrue)
|
||||
|
@ -42,7 +42,7 @@ Subject: [PATCH 904/904] gmpdh: Plugin that implements gmp DH functions in an
|
|||
AM_CONDITIONAL(USE_CURVE25519, test x$curve25519 = xtrue)
|
||||
AM_CONDITIONAL(USE_RDRAND, test x$rdrand = xtrue)
|
||||
AM_CONDITIONAL(USE_AESNI, test x$aesni = xtrue)
|
||||
@@ -1983,6 +1986,7 @@ AC_CONFIG_FILES([
|
||||
@@ -1996,6 +1999,7 @@ AC_CONFIG_FILES([
|
||||
src/libstrongswan/plugins/mgf1/Makefile
|
||||
src/libstrongswan/plugins/fips_prf/Makefile
|
||||
src/libstrongswan/plugins/gmp/Makefile
|
||||
|
@ -52,7 +52,7 @@ Subject: [PATCH 904/904] gmpdh: Plugin that implements gmp DH functions in an
|
|||
src/libstrongswan/plugins/aesni/Makefile
|
||||
--- a/src/libstrongswan/Makefile.am
|
||||
+++ b/src/libstrongswan/Makefile.am
|
||||
@@ -353,6 +353,13 @@ if MONOLITHIC
|
||||
@@ -357,6 +357,13 @@ if MONOLITHIC
|
||||
endif
|
||||
endif
|
||||
|
||||
|
|
Loading…
Reference in a new issue