luasocket: Replace -fpic with $(FPIC)
This is causing linking errors on i386 and ppc. Also removed custom warnings an optimization levels that override stock settings. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
99e9755459
commit
ecb4fcca0c
2 changed files with 16 additions and 2 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NAME:=luasocket
|
||||
PKG_SOURCE_VERSION:=6d5e40c324c84d9c1453ae88e0ad5bdd0a631448
|
||||
PKG_VERSION:=3.0-rc1-20130909
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_MIRROR_HASH:=d2fa075d8bd026c41e0eb1a634ac2ad8115dee8abb070720e8e91fab51f86ee4
|
||||
|
@ -42,7 +42,7 @@ endef
|
|||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/ \
|
||||
LIBDIR="$(TARGET_LDFLAGS)" \
|
||||
CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -std=gnu99" \
|
||||
CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(FPIC)" \
|
||||
LD="$(TARGET_CROSS)ld -shared" \
|
||||
all
|
||||
endef
|
||||
|
|
14
lang/luasocket/patches/040-remove-fpic-and-warnings.patch
Normal file
14
lang/luasocket/patches/040-remove-fpic-and-warnings.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- a/src/makefile
|
||||
+++ b/src/makefile
|
||||
@@ -163,9 +163,8 @@ DEF_linux=-DLUASOCKET_$(DEBUG) -DLUA_$(COMPAT)_MODULE \
|
||||
-DLUASOCKET_API='__attribute__((visibility("default")))' \
|
||||
-DUNIX_API='__attribute__((visibility("default")))' \
|
||||
-DMIME_API='__attribute__((visibility("default")))'
|
||||
-CFLAGS_linux= -I$(LUAINC) $(DEF) -pedantic -Wall -Wshadow -Wextra \
|
||||
- -Wimplicit -O2 -ggdb3 -fpic -fvisibility=hidden
|
||||
-LDFLAGS_linux=-O -shared -fpic -o
|
||||
+CFLAGS_linux= -I$(LUAINC) $(DEF) -fvisibility=hidden
|
||||
+LDFLAGS_linux=-shared -o
|
||||
LD_linux=gcc
|
||||
SOCKET_linux=usocket.o
|
||||
|
Loading…
Reference in a new issue