nginx: fix musl compatibility
- include Patches according to issue #1129 - refresh Makefile Signed-off-by: heil <heil@terminal-consulting.de>
This commit is contained in:
parent
f15b0ace72
commit
ec14ed490a
2 changed files with 37 additions and 2 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2009-2012 OpenWrt.org
|
# Copyright (C) 2012-2015 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=nginx
|
PKG_NAME:=nginx
|
||||||
PKG_VERSION:=1.4.7
|
PKG_VERSION:=1.4.7
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://nginx.org/download/
|
PKG_SOURCE_URL:=http://nginx.org/download/
|
||||||
|
|
35
net/nginx/patches/100-musl-no-sysctl.patch
Normal file
35
net/nginx/patches/100-musl-no-sysctl.patch
Normal file
|
@ -0,0 +1,35 @@
|
||||||
|
Index: nginx-1.4.7/src/os/unix/ngx_linux_config.h
|
||||||
|
===================================================================
|
||||||
|
--- nginx-1.4.7.orig/src/os/unix/ngx_linux_config.h
|
||||||
|
+++ nginx-1.4.7/src/os/unix/ngx_linux_config.h
|
||||||
|
@@ -51,7 +51,6 @@
|
||||||
|
#include <malloc.h> /* memalign() */
|
||||||
|
#include <limits.h> /* IOV_MAX */
|
||||||
|
#include <sys/ioctl.h>
|
||||||
|
-#include <sys/sysctl.h>
|
||||||
|
#include <crypt.h>
|
||||||
|
#include <sys/utsname.h> /* uname() */
|
||||||
|
|
||||||
|
--- nginx-1.2.7/src/os/unix/ngx_user.c
|
||||||
|
+++ nginx-1.2.7-patched/src/os/unix/ngx_user.c
|
||||||
|
@@ -31,8 +31,6 @@
|
||||||
|
struct crypt_data cd;
|
||||||
|
|
||||||
|
cd.initialized = 0;
|
||||||
|
- /* work around the glibc bug */
|
||||||
|
- cd.current_salt[0] = ~salt[0];
|
||||||
|
|
||||||
|
value = crypt_r((char *) key, (char *) salt, &cd);
|
||||||
|
|
||||||
|
diff --git a/auto/lib/openssl/conf b/auto/lib/openssl/conf
|
||||||
|
index 528ee17..73ef359 100644
|
||||||
|
--- a/auto/lib/openssl/conf
|
||||||
|
+++ b/auto/lib/openssl/conf
|
||||||
|
@@ -47,7 +47,7 @@ else
|
||||||
|
ngx_feature_run=no
|
||||||
|
ngx_feature_incs="#include <openssl/ssl.h>"
|
||||||
|
ngx_feature_path=
|
||||||
|
- ngx_feature_libs="-lssl -lcrypto"
|
||||||
|
+ ngx_feature_libs="-lssl -lcrypto -lz"
|
||||||
|
ngx_feature_test="SSL_library_init()"
|
||||||
|
. auto/feature
|
Loading…
Reference in a new issue