diff --git a/net/xinetd/Makefile b/net/xinetd/Makefile
index 6e9837626..1adf4dae7 100644
--- a/net/xinetd/Makefile
+++ b/net/xinetd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xinetd
 PKG_VERSION:=2.3.15
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/xinetd-org/xinetd/archive
diff --git a/net/xinetd/files/xinetd.init b/net/xinetd/files/xinetd.init
index 51f457594..f91a251b5 100644
--- a/net/xinetd/files/xinetd.init
+++ b/net/xinetd/files/xinetd.init
@@ -109,7 +109,7 @@ start_service() {
 	generate_config
 
 	procd_open_instance
-	procd_set_param command $PROG -f $GENERATED_CONF_FILE -pidfile $PIDFILE
+	procd_set_param command $PROG -dontfork -f $GENERATED_CONF_FILE -pidfile $PIDFILE
 	procd_set_param respawn
 	procd_close_instance
 }