libs/neon: update to latest, add maintainer, add description
the package (ipk) was previously called libneon, so I keep this name instead of neon. Signed-off-by: Federico Di Marco <fededim@gmail.com> Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
This commit is contained in:
parent
2c21f90b84
commit
eb07b2c055
2 changed files with 21 additions and 11 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2007-2011 OpenWrt.org
|
||||
# Copyright (C) 2007-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,14 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=neon
|
||||
PKG_VERSION:=0.29.6
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.30.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.webdav.org/neon
|
||||
PKG_MD5SUM:=591e0c82e6979e7e615211b386b8f6bc
|
||||
PKG_MD5SUM:=fb60b3a124eeec441937a812c456fd94
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -26,8 +25,24 @@ define Package/libneon
|
|||
TITLE:=HTTP and WebDAV client library
|
||||
URL:=http://www.webdav.org/neon/
|
||||
DEPENDS:=+libopenssl +libexpat
|
||||
MAINTAINER:=Federico Di Marco <fededim@gmail.com>
|
||||
endef
|
||||
|
||||
define Package/libneon/description
|
||||
neon is an HTTP and WebDAV client library, with a C interface. Features:
|
||||
|
||||
- High-level wrappers for common HTTP and WebDAV operations (GET, MOVE, DELETE, etc)
|
||||
- Low-level interface to the HTTP request/response engine, allowing the use of arbitrary HTTP methods, headers, etc.
|
||||
- Authentication support including Basic and Digest support, along with GSSAPI-based Negotiate on Unix, and
|
||||
SSPI-based Negotiate/NTLM on Win32
|
||||
- SSL/TLS support using OpenSSL or GnuTLS; exposing an abstraction layer for verifying server certificates, handling client
|
||||
certificates, and examining certificate properties. Smartcard-based client certificates are also supported via a
|
||||
PKCS11 wrapper interface.
|
||||
- Abstract interface to parsing XML using libxml2 or expat, and wrappers for simplifying handling XML HTTP response bodies
|
||||
- WebDAV metadata support; wrappers for PROPFIND and PROPPATCH to simplify property manipulation.
|
||||
endef
|
||||
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
|
||||
|
||||
|
@ -37,7 +52,7 @@ CONFIGURE_ARGS += \
|
|||
--with-expat \
|
||||
--with-ssl="openssl" \
|
||||
--without-egd \
|
||||
--without-libproxy \
|
||||
--without-libproxy
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
LDFLAGS="$$$$LDFLAGS -lcrypto -lssl"
|
||||
|
|
|
@ -1,5 +0,0 @@
|
|||
--- /dev/null
|
||||
+++ b/Makefile.am
|
||||
@@ -0,0 +1,2 @@
|
||||
+SUBDIRS = .
|
||||
+ACLOCAL_AMFLAGS = -I macros
|
Loading…
Reference in a new issue