xr_usb_serial_common: bump to 2022-03-30
This is the latest commit that touches the xr_usb_serial_common-1a dir. The changes are restricted to whitespace fixes and kernel version adaptations: ecc6ebe xr_usb: Use tty_driver_kref_put for kernel 5.15 and above caf6d25 xr_usb: Use tty_alloc_driver for kernel 5.15 and above a42b7e6 xr_usb: Compilation fixes for kernel 5.14 497adb7 #39 fix compilation for newer linux kernels 9103471 xr_usb: fix some whitespace errors Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
This commit is contained in:
parent
9213eee175
commit
eadab32450
2 changed files with 4 additions and 52 deletions
|
@ -2,13 +2,13 @@ include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=usb-serial-xr_usb_serial_common
|
PKG_NAME:=usb-serial-xr_usb_serial_common
|
||||||
PKG_SOURCE_DATE:=2017-08-01
|
PKG_SOURCE_DATE:=2022-03-30
|
||||||
PKG_SOURCE_VERSION:=b8dad8cf15de160afbd9989f880dc74b921a857b
|
PKG_SOURCE_VERSION:=ecc6ebe0141b97942d774e6c6be37a330cc11a74
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=https://github.com/kasbert/epsolar-tracer
|
PKG_SOURCE_URL:=https://github.com/kasbert/epsolar-tracer
|
||||||
PKG_MIRROR_HASH:=2cf23fec2625480bb4a630f96cd172219d401bd3cf90943394504ea0ba814faf
|
PKG_MIRROR_HASH:=487c4259211411d3c435284016f90c6770539c0a6f904f3327f18381a33c23e3
|
||||||
|
|
||||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||||
PKG_LICENSE:=GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
|
|
|
@ -1,48 +0,0 @@
|
||||||
From e4d127ddc83c5fbd93b9c8e2e4fe63b820ac28b6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: David Bauer <mail@david-bauer.net>
|
|
||||||
Date: Sat, 22 May 2021 10:37:06 +0200
|
|
||||||
Subject: [PATCH] common.c: fix kernel 5.10 builds with CONFIG_PM enabled
|
|
||||||
|
|
||||||
Building the xr_usb_serial module fails for Kenel 5.10 with CONFIG_PM
|
|
||||||
enabled:
|
|
||||||
|
|
||||||
xr_usb_serial_common.c:1574:15: error: 'ASYNCB_INITIALIZED' undeclared
|
|
||||||
(first use in this function); did you mean 'RCU_INITIALIZER'?
|
|
||||||
|
|
||||||
Use tty_port_initialized in order to determine the status of the TTY
|
|
||||||
port. This is compatible with Kernel 5.10 and at least Kernel 5.4.
|
|
||||||
|
|
||||||
Signed-off-by: David Bauer <mail@david-bauer.net>
|
|
||||||
---
|
|
||||||
xr_usb_serial_common-1a/xr_usb_serial_common.c | 6 +++---
|
|
||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
--- a/xr_usb_serial_common-1a/xr_usb_serial_common.c
|
|
||||||
+++ b/xr_usb_serial_common-1a/xr_usb_serial_common.c
|
|
||||||
@@ -1571,7 +1571,7 @@ static int xr_usb_serial_suspend(struct
|
|
||||||
if (cnt)
|
|
||||||
return 0;
|
|
||||||
|
|
||||||
- if (test_bit(ASYNCB_INITIALIZED, &xr_usb_serial->port.flags))
|
|
||||||
+ if (tty_port_initialized(&xr_usb_serial->port))
|
|
||||||
stop_data_traffic(xr_usb_serial);
|
|
||||||
|
|
||||||
return 0;
|
|
||||||
@@ -1592,7 +1592,7 @@ static int xr_usb_serial_resume(struct u
|
|
||||||
if (cnt)
|
|
||||||
return 0;
|
|
||||||
|
|
||||||
- if (test_bit(ASYNCB_INITIALIZED, &xr_usb_serial->port.flags)) {
|
|
||||||
+ if (tty_port_initialized(&xr_usb_serial->port)) {
|
|
||||||
rv = usb_submit_urb(xr_usb_serial->ctrlurb, GFP_NOIO);
|
|
||||||
|
|
||||||
spin_lock_irq(&xr_usb_serial->write_lock);
|
|
||||||
@@ -1623,7 +1623,7 @@ static int xr_usb_serial_reset_resume(st
|
|
||||||
{
|
|
||||||
struct xr_usb_serial *xr_usb_serial = usb_get_intfdata(intf);
|
|
||||||
struct tty_struct *tty;
|
|
||||||
- if (test_bit(ASYNCB_INITIALIZED, &xr_usb_serial->port.flags)){
|
|
||||||
+ if (tty_port_initialized(&xr_usb_serial->port)){
|
|
||||||
#if LINUX_VERSION_CODE > KERNEL_VERSION(3, 9, 0)
|
|
||||||
tty_port_tty_hangup(&xr_usb_serial->port, false);
|
|
||||||
#else
|
|
Loading…
Reference in a new issue