postgresql: update to version 14.5
Release date: 2022-08-11 Adresses CVE-2022-2625. For more details, please see the release notes[1]. [1]: https://www.postgresql.org/docs/release/14.5/ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
db667b5b0f
commit
ead096d6dd
3 changed files with 8 additions and 8 deletions
|
@ -5,7 +5,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=postgresql
|
PKG_NAME:=postgresql
|
||||||
PKG_VERSION:=14.2
|
PKG_VERSION:=14.5
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||||
PKG_LICENSE:=PostgreSQL
|
PKG_LICENSE:=PostgreSQL
|
||||||
|
@ -17,7 +17,7 @@ PKG_SOURCE_URL:=\
|
||||||
http://ftp.postgresql.org/pub/source/v$(PKG_VERSION) \
|
http://ftp.postgresql.org/pub/source/v$(PKG_VERSION) \
|
||||||
ftp://ftp.postgresql.org/pub/source/v$(PKG_VERSION)
|
ftp://ftp.postgresql.org/pub/source/v$(PKG_VERSION)
|
||||||
|
|
||||||
PKG_HASH:=2cf78b2e468912f8101d695db5340cf313c2e9f68a612fb71427524e8c9a977a
|
PKG_HASH:=d4f72cb5fb857c9a9f75ec8cf091a1771272802f2178f0b2e65b7b6ff64f4a30
|
||||||
|
|
||||||
PKG_USE_MIPS16:=0
|
PKG_USE_MIPS16:=0
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -2127,9 +2127,9 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
|
@@ -2141,9 +2141,9 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
|
||||||
# flags. If not, check if adding -march=armv8-a+crc flag helps.
|
# flags. If not, check if adding -march=armv8-a+crc flag helps.
|
||||||
# CFLAGS_ARMV8_CRC32C is set if the extra flag is required.
|
# CFLAGS_ARMV8_CRC32C is set if the extra flag is required.
|
||||||
PGAC_ARMV8_CRC32C_INTRINSICS([])
|
PGAC_ARMV8_CRC32C_INTRINSICS([])
|
||||||
|
|
|
@ -8,7 +8,7 @@
|
||||||
static char *argv0 = NULL;
|
static char *argv0 = NULL;
|
||||||
static bool allow_core_files = false;
|
static bool allow_core_files = false;
|
||||||
static time_t start_time;
|
static time_t start_time;
|
||||||
@@ -2049,6 +2050,9 @@ do_help(void)
|
@@ -2081,6 +2082,9 @@ do_help(void)
|
||||||
#endif
|
#endif
|
||||||
printf(_(" -s, --silent only print errors, no informational messages\n"));
|
printf(_(" -s, --silent only print errors, no informational messages\n"));
|
||||||
printf(_(" -t, --timeout=SECS seconds to wait when using -w option\n"));
|
printf(_(" -t, --timeout=SECS seconds to wait when using -w option\n"));
|
||||||
|
@ -18,7 +18,7 @@
|
||||||
printf(_(" -V, --version output version information, then exit\n"));
|
printf(_(" -V, --version output version information, then exit\n"));
|
||||||
printf(_(" -w, --wait wait until operation completes (default)\n"));
|
printf(_(" -w, --wait wait until operation completes (default)\n"));
|
||||||
printf(_(" -W, --no-wait do not wait until operation completes\n"));
|
printf(_(" -W, --no-wait do not wait until operation completes\n"));
|
||||||
@@ -2261,6 +2265,7 @@ main(int argc, char **argv)
|
@@ -2293,6 +2297,7 @@ main(int argc, char **argv)
|
||||||
{"options", required_argument, NULL, 'o'},
|
{"options", required_argument, NULL, 'o'},
|
||||||
{"silent", no_argument, NULL, 's'},
|
{"silent", no_argument, NULL, 's'},
|
||||||
{"timeout", required_argument, NULL, 't'},
|
{"timeout", required_argument, NULL, 't'},
|
||||||
|
@ -26,7 +26,7 @@
|
||||||
{"core-files", no_argument, NULL, 'c'},
|
{"core-files", no_argument, NULL, 'c'},
|
||||||
{"wait", no_argument, NULL, 'w'},
|
{"wait", no_argument, NULL, 'w'},
|
||||||
{"no-wait", no_argument, NULL, 'W'},
|
{"no-wait", no_argument, NULL, 'W'},
|
||||||
@@ -2301,20 +2306,6 @@ main(int argc, char **argv)
|
@@ -2333,20 +2338,6 @@ main(int argc, char **argv)
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -47,7 +47,7 @@
|
||||||
|
|
||||||
env_wait = getenv("PGCTLTIMEOUT");
|
env_wait = getenv("PGCTLTIMEOUT");
|
||||||
if (env_wait != NULL)
|
if (env_wait != NULL)
|
||||||
@@ -2400,11 +2391,15 @@ main(int argc, char **argv)
|
@@ -2432,11 +2423,15 @@ main(int argc, char **argv)
|
||||||
wait_seconds_arg = true;
|
wait_seconds_arg = true;
|
||||||
break;
|
break;
|
||||||
case 'U':
|
case 'U':
|
||||||
|
@ -63,7 +63,7 @@
|
||||||
break;
|
break;
|
||||||
case 'w':
|
case 'w':
|
||||||
do_wait = true;
|
do_wait = true;
|
||||||
@@ -2486,6 +2481,41 @@ main(int argc, char **argv)
|
@@ -2518,6 +2513,41 @@ main(int argc, char **argv)
|
||||||
exit(1);
|
exit(1);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue