Merge pull request #3077 from commodo/tcpreplay-libnl-fix
tcpreplay: remove libnl dependency and update PKG_LICENSE_FILES.
This commit is contained in:
commit
ea44cfddfe
2 changed files with 8 additions and 13 deletions
|
@ -9,13 +9,14 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=tcpreplay
|
PKG_NAME:=tcpreplay
|
||||||
PKG_VERSION:=4.1.1
|
PKG_VERSION:=4.1.1
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/appneta/tcpreplay/releases/download/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/appneta/tcpreplay/releases/download/v$(PKG_VERSION)
|
||||||
PKG_MD5SUM:=80394c33fe697b53b69eac9bb0968ae9
|
PKG_MD5SUM:=80394c33fe697b53b69eac9bb0968ae9
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-3.0
|
PKG_LICENSE:=GPL-3.0
|
||||||
|
PKG_LICENSE_FILES:=docs/LICENSE
|
||||||
|
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=libtool
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
@ -124,6 +125,12 @@ define Package/tcpreplay-all/description
|
||||||
to support switches, routers, and IP Flow/NetFlow appliances.
|
to support switches, routers, and IP Flow/NetFlow appliances.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
CONFIGURE_VARS += \
|
||||||
|
ac_cv_lib_nl_nl_cache_alloc=no \
|
||||||
|
ac_cv_lib_nl_genl_3_genl_connect=no \
|
||||||
|
ac_cv_lib_nl_3_nl_cache_alloc=no \
|
||||||
|
ac_cv_lib_dbus_1_dbus_malloc=no
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
--enable-force-pf \
|
--enable-force-pf \
|
||||||
--enable-dynamic-link \
|
--enable-dynamic-link \
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 6c61381..7f72871 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -773,7 +773,6 @@ if ! test $using_pcap_config = yes; then
|
|
||||||
AC_CHECK_LIB(nl, nl_cache_alloc, [nl_found=yes])
|
|
||||||
AC_CHECK_LIB(nl-genl-3, genl_connect, [nl_genl_3_found=yes])
|
|
||||||
AC_CHECK_LIB(nl-3, nl_cache_alloc, [nl_3_found=yes])
|
|
||||||
- AC_CHECK_LIB(dbus-1, dbus_malloc, [dbus_1_found=yes])
|
|
||||||
if test "$nl_found" = "yes"; then
|
|
||||||
LPCAPLIB="$LPCAPLIB -lnl"
|
|
||||||
fi
|
|
Loading…
Reference in a new issue