From b732157dec0be4d90aad5cec48056bd69939bb45 Mon Sep 17 00:00:00 2001
From: Eneas U de Queiroz <cotequeiroz@gmail.com>
Date: Wed, 24 Feb 2021 15:37:12 -0300
Subject: [PATCH 1/8] restic-rest-server: fix build with golang 1.16

Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be
built in non-module mode.

Module-aware mode will be mandatory in the next golang release.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
---
 net/restic-rest-server/Makefile | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/net/restic-rest-server/Makefile b/net/restic-rest-server/Makefile
index 87288f20f..68632bdce 100644
--- a/net/restic-rest-server/Makefile
+++ b/net/restic-rest-server/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=restic-rest-server
 PKG_VERSION:=0.9.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/rest-server-$(PKG_VERSION)
 PKG_SOURCE:=rest-server-$(PKG_VERSION).tar.gz
@@ -43,6 +43,8 @@ API. It provides secure and efficient way to backup data remotely, using restic
 backup client via the rest: URL.
 endef
 
+GO_PKG_BUILD_VARS += GO111MODULE=auto
+
 define Package/restic-rest-server/install
 	$(INSTALL_DIR) $(1)/usr/bin
 	$(INSTALL_BIN) $(GO_PKG_BUILD_BIN_DIR)/rest-server $(1)/usr/bin/restic-rest-server

From cffae02037e21471e5a0fdc47b171aedbe926e8f Mon Sep 17 00:00:00 2001
From: Eneas U de Queiroz <cotequeiroz@gmail.com>
Date: Wed, 24 Feb 2021 15:37:43 -0300
Subject: [PATCH 2/8] tor-fw-helper: fix build with golang 1.16

Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be
built in non-module mode.

Module-aware mode will be mandatory in the next golang release.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
---
 net/tor-fw-helper/Makefile | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/net/tor-fw-helper/Makefile b/net/tor-fw-helper/Makefile
index 0873ca915..f0a6d438d 100644
--- a/net/tor-fw-helper/Makefile
+++ b/net/tor-fw-helper/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor-fw-helper
 PKG_VERSION:=0.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://git.torproject.org/tor-fw-helper.git
@@ -69,6 +69,8 @@ $(call Package/tor-fw-helper/Default/description)
 This package provides the source files for the helper program.
 endef
 
+GO_PKG_BUILD_VARS += GO111MODULE=auto
+
 $(eval $(call GoBinPackage,tor-fw-helper))
 $(eval $(call BuildPackage,tor-fw-helper))
 

From 619270da0e3b81af08cb2924c8484e92b22339de Mon Sep 17 00:00:00 2001
From: Eneas U de Queiroz <cotequeiroz@gmail.com>
Date: Wed, 24 Feb 2021 15:37:59 -0300
Subject: [PATCH 3/8] cni: fix build with golang 1.16

Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be
built in non-module mode.

Module-aware mode will be mandatory in the next golang release.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
---
 utils/cni/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/utils/cni/Makefile b/utils/cni/Makefile
index 895c6d2aa..589d82793 100644
--- a/utils/cni/Makefile
+++ b/utils/cni/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cni
 PKG_VERSION:=0.8.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
@@ -23,6 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 include ../../lang/golang/golang-package.mk
 
 PKG_USE_MIPS16:=0
+GO_PKG_BUILD_VARS += GO111MODULE=auto
 
 define Package/cni
   SECTION:=utils

From 2d48a7b6e0a5d73962a7cf4bd32a80c762d2f35b Mon Sep 17 00:00:00 2001
From: Eneas U de Queiroz <cotequeiroz@gmail.com>
Date: Wed, 24 Feb 2021 15:37:59 -0300
Subject: [PATCH 4/8] containerd: fix build with golang 1.16

Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be
built in non-module mode.

Module-aware mode will be mandatory in the next golang release.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
---
 utils/containerd/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/utils/containerd/Makefile b/utils/containerd/Makefile
index dcf348234..3ab649994 100644
--- a/utils/containerd/Makefile
+++ b/utils/containerd/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=containerd
 PKG_VERSION:=1.4.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
@@ -36,6 +36,7 @@ define Package/containerd/description
 An industry-standard container runtime with an emphasis on simplicity, robustness and portability
 endef
 
+GO_PKG_BUILD_VARS += GO111MODULE=auto
 GO_PKG_INSTALL_ALL:=1
 MAKE_PATH:=$(GO_PKG_WORK_DIR_NAME)/build/src/$(GO_PKG)
 MAKE_VARS += $(GO_PKG_VARS)

From 5b2d0609c7ab0698c2fa138d664847195b0b452f Mon Sep 17 00:00:00 2001
From: Eneas U de Queiroz <cotequeiroz@gmail.com>
Date: Wed, 24 Feb 2021 15:37:59 -0300
Subject: [PATCH 5/8] docker: fix build with golang 1.16

Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be
built in non-module mode.

Module-aware mode will be mandatory in the next golang release.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
---
 utils/docker/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/utils/docker/Makefile b/utils/docker/Makefile
index 0d8af6dfd..4fa3cd21a 100644
--- a/utils/docker/Makefile
+++ b/utils/docker/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=docker
 PKG_VERSION:=20.10.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
@@ -34,6 +34,7 @@ define Package/docker/description
 The CLI used in the Docker CE and Docker EE products.
 endef
 
+GO_PKG_BUILD_VARS += GO111MODULE=auto
 TAR_OPTIONS:=--strip-components 1 $(TAR_OPTIONS)
 TAR_CMD=$(HOST_TAR) -C $(1) $(TAR_OPTIONS)
 

From 8a4bb56478036efccbf6f092647da53e52574518 Mon Sep 17 00:00:00 2001
From: Eneas U de Queiroz <cotequeiroz@gmail.com>
Date: Wed, 24 Feb 2021 15:37:59 -0300
Subject: [PATCH 6/8] dockerd: fix build with golang 1.16

Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be
built in non-module mode.

Module-aware mode will be mandatory in the next golang release.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
---
 utils/dockerd/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/utils/dockerd/Makefile b/utils/dockerd/Makefile
index c34640a85..1390ae098 100644
--- a/utils/dockerd/Makefile
+++ b/utils/dockerd/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dockerd
 PKG_VERSION:=20.10.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
@@ -46,6 +46,7 @@ define Package/dockerd/description
 The Docker CE Engine.
 endef
 
+GO_PKG_BUILD_VARS += GO111MODULE=auto
 TAR_OPTIONS:=--strip-components 1 $(TAR_OPTIONS)
 TAR_CMD=$(HOST_TAR) -C $(1) $(TAR_OPTIONS)
 

From d9f7dff4a09c82c736560bfe1362873453f6374b Mon Sep 17 00:00:00 2001
From: Eneas U de Queiroz <cotequeiroz@gmail.com>
Date: Wed, 24 Feb 2021 15:38:00 -0300
Subject: [PATCH 7/8] libnetwork: fix build with golang 1.16

Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be
built in non-module mode.

Module-aware mode will be mandatory in the next golang release.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
---
 utils/libnetwork/Makefile | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/utils/libnetwork/Makefile b/utils/libnetwork/Makefile
index a3d7f3b2a..cc445df1a 100644
--- a/utils/libnetwork/Makefile
+++ b/utils/libnetwork/Makefile
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnetwork
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
@@ -38,6 +38,8 @@ Libnetwork provides a native Go implementation for connecting containers.
 The goal of libnetwork is to deliver a robust Container Network Model that provides a consistent programming interface and the required network abstractions for applications.
 endef
 
+GO_PKG_BUILD_VARS += GO111MODULE=auto
+
 define Package/libnetwork/install
 	$(call GoPackage/Package/Install/Bin,$(PKG_INSTALL_DIR))
 

From bb9641e7021293fe1afa6b77e24896874d238c37 Mon Sep 17 00:00:00 2001
From: Eneas U de Queiroz <cotequeiroz@gmail.com>
Date: Wed, 24 Feb 2021 15:38:00 -0300
Subject: [PATCH 8/8] oci-runtime-tools: fix build with golang 1.16

Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be
built in non-module mode.

Module-aware mode will be mandatory in the next golang release.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
---
 utils/oci-runtime-tools/Makefile | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/utils/oci-runtime-tools/Makefile b/utils/oci-runtime-tools/Makefile
index 35d8f7f64..6621ece90 100644
--- a/utils/oci-runtime-tools/Makefile
+++ b/utils/oci-runtime-tools/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oci-runtime-tools
 PKG_VERSION:=1.0.0-pre20210122
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
@@ -54,6 +54,8 @@ define Package/oci-runtime-tests/description
   installable via npm.
 endef
 
+GO_PKG_BUILD_VARS += GO111MODULE=auto
+
 define Build/Compile
 	$(call GoPackage/Build/Compile)
 	$(call GoPackage/Package/Install/Bin,$(PKG_INSTALL_DIR))