lispmob: fix build with musl
lispmob accesses the gnu members of struct udphdr like source and dest and does not use the posix member names. Instead of using the correct names just define this as _GNU_SOURCE. [bump PKG_RELEASE] Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
This commit is contained in:
parent
4c98c181c0
commit
e9d97e52c0
2 changed files with 32 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NAME:=lispmob
|
||||
PKG_REV:=180aa39d338a00bb532e421de7f8513492cf2e8b
|
||||
PKG_VERSION:=0.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=git://github.com/LISPmob/lispmob.git
|
||||
|
|
31
net/lispmob/patches/001-fix-musl-build.patch
Normal file
31
net/lispmob/patches/001-fix-musl-build.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
--- a/lispd/lispd_output.c
|
||||
+++ b/lispd/lispd_output.c
|
||||
@@ -26,6 +26,7 @@
|
||||
* Alberto Rodriguez Natal <arnatal@ac.upc.edu>
|
||||
*/
|
||||
|
||||
+#define _GNU_SOURCE 1
|
||||
|
||||
|
||||
#include <assert.h>
|
||||
--- a/lispd/lispd_input.c
|
||||
+++ b/lispd/lispd_input.c
|
||||
@@ -26,6 +26,7 @@
|
||||
* Alberto Rodriguez Natal <arnatal@ac.upc.edu>
|
||||
*/
|
||||
|
||||
+#define _GNU_SOURCE 1
|
||||
|
||||
#include "lispd_input.h"
|
||||
#include "lispd_map_notify.h"
|
||||
--- a/lispd/lispd_pkt_lib.c
|
||||
+++ b/lispd/lispd_pkt_lib.c
|
||||
@@ -28,6 +28,8 @@
|
||||
*
|
||||
*/
|
||||
|
||||
+#define _GNU_SOURCE 1
|
||||
+
|
||||
#include "lispd_afi.h"
|
||||
#include "lispd_pkt_lib.h"
|
||||
#include "lispd_lib.h"
|
Loading…
Reference in a new issue