diff --git a/multimedia/gst1-plugins-good/Makefile b/multimedia/gst1-plugins-good/Makefile
index c9b87be50..5f27dca19 100644
--- a/multimedia/gst1-plugins-good/Makefile
+++ b/multimedia/gst1-plugins-good/Makefile
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst1-plugins-good
-PKG_VERSION:=1.14.2
+PKG_VERSION:=1.14.4
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
@@ -19,8 +19,8 @@ PKG_LICENSE_FILES:=COPYING
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-good-$(PKG_VERSION)
 PKG_SOURCE:=gst-plugins-good-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-good/
-PKG_HASH:=c0575e2811860bfff59b865b8d125153859a01f0615fa41e279b64d88d25caad
+PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gst-plugins-good/
+PKG_HASH:=5f8b553260cb0aac56890053d8511db1528d53cae10f0287cfce2cb2acc70979
 
 PKG_CONFIG_DEPENDS:= \
 	CONFIG_PACKAGE_gst1-mod-lame \
@@ -38,7 +38,7 @@ define Package/gstreamer1-good/Default
   CATEGORY:=Multimedia
   SECTION:=multimedia
   TITLE:=GStreamer
-  URL:=http://gstreamer.freedesktop.org/
+  URL:=https://gstreamer.freedesktop.org/
   DEPENDS:= +libgstreamer1 +libgst1pbutils $(ICONV_DEPENDS)
 endef
 
diff --git a/multimedia/gst1-plugins-good/patches/001-no-translations.patch b/multimedia/gst1-plugins-good/patches/001-no-translations.patch
index 6b78b2821..6cd701499 100644
--- a/multimedia/gst1-plugins-good/patches/001-no-translations.patch
+++ b/multimedia/gst1-plugins-good/patches/001-no-translations.patch
@@ -1,18 +1,6 @@
-diff -u --recursive gst-plugins-good-1.12.4-vanilla/configure.ac gst-plugins-good-1.12.4/configure.ac
---- gst-plugins-good-1.12.4-vanilla/configure.ac	2018-02-11 10:34:37.773144289 -0500
-+++ gst-plugins-good-1.12.4/configure.ac	2018-02-11 10:35:17.103223474 -0500
-@@ -1061,7 +1061,6 @@
- sys/v4l2/Makefile
- sys/waveform/Makefile
- sys/ximage/Makefile
--po/Makefile.in
- tests/Makefile
- tests/check/Makefile
- tests/examples/Makefile
-diff -u --recursive gst-plugins-good-1.12.4-vanilla/Makefile.am gst-plugins-good-1.12.4/Makefile.am
---- gst-plugins-good-1.12.4-vanilla/Makefile.am	2018-02-11 10:34:37.786144315 -0500
-+++ gst-plugins-good-1.12.4/Makefile.am	2018-02-11 10:35:23.529236411 -0500
-@@ -4,7 +4,6 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -4,7 +4,6 @@ ALWAYS_SUBDIRS =		\
  	gst sys ext 		\
  	tests			\
  	docs			\
@@ -20,3 +8,13 @@ diff -u --recursive gst-plugins-good-1.12.4-vanilla/Makefile.am gst-plugins-good
  	common			\
  	m4			\
  	pkgconfig
+--- a/configure.ac
++++ b/configure.ac
+@@ -1292,7 +1292,6 @@ sys/osxvideo/Makefile
+ sys/v4l2/Makefile
+ sys/waveform/Makefile
+ sys/ximage/Makefile
+-po/Makefile.in
+ tests/Makefile
+ tests/check/Makefile
+ tests/examples/Makefile
diff --git a/multimedia/gst1-plugins-good/patches/002-no-tests.patch b/multimedia/gst1-plugins-good/patches/002-no-tests.patch
index 0474d411b..de2294879 100644
--- a/multimedia/gst1-plugins-good/patches/002-no-tests.patch
+++ b/multimedia/gst1-plugins-good/patches/002-no-tests.patch
@@ -1,7 +1,16 @@
-diff -u --recursive gst-plugins-good-1.14.1-vanilla/configure.ac gst-plugins-good-1.14.1/configure.ac
---- gst-plugins-good-1.14.1-vanilla/configure.ac	2018-07-07 18:56:53.008234372 -0400
-+++ gst-plugins-good-1.14.1/configure.ac	2018-07-07 18:57:24.886355477 -0400
-@@ -1292,22 +1292,6 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -2,7 +2,6 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
+ 
+ ALWAYS_SUBDIRS =		\
+ 	gst sys ext 		\
+-	tests			\
+ 	docs			\
+ 	common			\
+ 	m4			\
+--- a/configure.ac
++++ b/configure.ac
+@@ -1292,22 +1292,6 @@ sys/osxvideo/Makefile
  sys/v4l2/Makefile
  sys/waveform/Makefile
  sys/ximage/Makefile
@@ -24,14 +33,3 @@ diff -u --recursive gst-plugins-good-1.14.1-vanilla/configure.ac gst-plugins-goo
  common/Makefile
  common/m4/Makefile
  m4/Makefile
-diff -u --recursive gst-plugins-good-1.14.1-vanilla/Makefile.am gst-plugins-good-1.14.1/Makefile.am
---- gst-plugins-good-1.14.1-vanilla/Makefile.am	2018-07-07 18:56:53.008234372 -0400
-+++ gst-plugins-good-1.14.1/Makefile.am	2018-07-07 18:57:30.015374957 -0400
-@@ -2,7 +2,6 @@
- 
- ALWAYS_SUBDIRS =		\
- 	gst sys ext 		\
--	tests			\
- 	docs			\
- 	common			\
- 	m4			\
diff --git a/multimedia/gst1-plugins-good/patches/003-no-docs.patch b/multimedia/gst1-plugins-good/patches/003-no-docs.patch
index f13cb61ac..f96205936 100644
--- a/multimedia/gst1-plugins-good/patches/003-no-docs.patch
+++ b/multimedia/gst1-plugins-good/patches/003-no-docs.patch
@@ -1,7 +1,16 @@
-diff -u --recursive gst-plugins-good-1.12.4-vanilla/configure.ac gst-plugins-good-1.12.4/configure.ac
---- gst-plugins-good-1.12.4-vanilla/configure.ac	2018-02-11 10:37:22.304475546 -0500
-+++ gst-plugins-good-1.12.4/configure.ac	2018-02-11 10:38:15.248581736 -0500
-@@ -1064,9 +1064,6 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -2,7 +2,6 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
+ 
+ ALWAYS_SUBDIRS =		\
+ 	gst sys ext 		\
+-	docs			\
+ 	common			\
+ 	m4			\
+ 	pkgconfig
+--- a/configure.ac
++++ b/configure.ac
+@@ -1295,9 +1295,6 @@ sys/ximage/Makefile
  common/Makefile
  common/m4/Makefile
  m4/Makefile
@@ -11,14 +20,3 @@ diff -u --recursive gst-plugins-good-1.12.4-vanilla/configure.ac gst-plugins-goo
  pkgconfig/Makefile
  pkgconfig/gstreamer-plugins-good-uninstalled.pc
  )
-diff -u --recursive gst-plugins-good-1.12.4-vanilla/Makefile.am gst-plugins-good-1.12.4/Makefile.am
---- gst-plugins-good-1.12.4-vanilla/Makefile.am	2018-02-11 10:37:37.242505621 -0500
-+++ gst-plugins-good-1.12.4/Makefile.am	2018-02-11 10:38:28.838608856 -0500
-@@ -2,7 +2,6 @@
- 
- ALWAYS_SUBDIRS =		\
- 	gst sys ext 		\
--	docs			\
- 	common			\
- 	m4			\
- 	pkgconfig