boost: Bump to version 1.78.0
This commit updates boost to version 1.78.0 More info about Boost 1.78.0 can be found at the usual place [1]. No new libraries have been added. [1]: https://www.boost.org/users/history/version_1_78_0.html Signed-off-by: Carlos Miguel Ferreira <carlosmf.pt@gmail.com>
This commit is contained in:
parent
7b2dd3e9ef
commit
e9731ff6b4
5 changed files with 70 additions and 198 deletions
|
@ -11,13 +11,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=boost
|
||||
PKG_VERSION:=1.77.0
|
||||
PKG_SOURCE_VERSION:=1_77_0
|
||||
PKG_VERSION:=1.78.0
|
||||
PKG_SOURCE_VERSION:=1_78_0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
|
||||
PKG_HASH:=fc9f85fc030e233142908241af7a846e60630aa7388de9a5fafb1f3a26840854
|
||||
PKG_HASH:=8681f175d4bdb26c52222665793eef08490d7758529330f98d3b29dd0735bccc
|
||||
|
||||
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
|
||||
PKG_LICENSE:=BSL-1.0
|
||||
|
@ -42,7 +42,7 @@ define Package/boost/Default
|
|||
endef
|
||||
|
||||
define Package/boost/description
|
||||
This package provides the Boost v1.77.0 libraries.
|
||||
This package provides the Boost v1.78.0 libraries.
|
||||
Boost is a set of free, peer-reviewed, portable C++ source libraries.
|
||||
|
||||
This package provides the following run-time libraries:
|
||||
|
@ -77,7 +77,7 @@ This package provides the following run-time libraries:
|
|||
- wave
|
||||
|
||||
There are many more header-only libraries supported by Boost.
|
||||
See more at http://www.boost.org/doc/libs/1_77_0/
|
||||
See more at http://www.boost.org/doc/libs/1_78_0/
|
||||
endef
|
||||
|
||||
PKG_BUILD_DEPENDS:=boost/host
|
||||
|
|
52
libs/boost/patches/010-fix-b2-install.patch
Normal file
52
libs/boost/patches/010-fix-b2-install.patch
Normal file
|
@ -0,0 +1,52 @@
|
|||
--- a/tools/build/src/tools/stage.jam
|
||||
+++ b/tools/build/src/tools/stage.jam
|
||||
@@ -478,6 +478,10 @@ class install-target-class : basic-targe
|
||||
return [ sequence.unique $(result2) ] ;
|
||||
}
|
||||
|
||||
+ rule skip-from-usage-requirements ( )
|
||||
+ {
|
||||
+ }
|
||||
+
|
||||
# Returns true iff 'type' is subtype of some element of 'types-to-include'.
|
||||
#
|
||||
local rule include-type ( type : types-to-include * )
|
||||
--- /dev/null
|
||||
+++ b/tools/build/test/install_build_no.py
|
||||
@@ -0,0 +1,26 @@
|
||||
+#!/usr/bin/python
|
||||
+
|
||||
+# Copyright 2021 Dmitry Arkhipov (grisumbras@gmail.com)
|
||||
+# Distributed under the Boost Software License, Version 1.0.
|
||||
+# (See accompanying file LICENSE.txt or https://www.bfgroup.xyz/b2/LICENSE.txt)
|
||||
+
|
||||
+# Check that <build>no in usage-requirements of dependencies does not affect
|
||||
+# install rule, i.e. a skipped installed target does not affect insallation of
|
||||
+# other targets.
|
||||
+
|
||||
+import BoostBuild
|
||||
+
|
||||
+t = BoostBuild.Tester()
|
||||
+
|
||||
+t.write("a.cpp", "int main() {}\n")
|
||||
+
|
||||
+t.write("jamroot.jam", """
|
||||
+make x : : maker : <build>no ;
|
||||
+exe a : a.cpp ;
|
||||
+install install : x a ;
|
||||
+""")
|
||||
+
|
||||
+t.run_build_system()
|
||||
+t.expect_addition("install/a.exe")
|
||||
+
|
||||
+t.cleanup()
|
||||
--- a/tools/build/test/test_all.py
|
||||
+++ b/tools/build/test/test_all.py
|
||||
@@ -250,6 +250,7 @@ tests = ["abs_workdir",
|
||||
"inherit_toolset",
|
||||
"inherited_dependency",
|
||||
"inline",
|
||||
+ "install_build_no",
|
||||
"libjpeg",
|
||||
"liblzma",
|
||||
"libpng",
|
|
@ -1,15 +0,0 @@
|
|||
--- a/boost/predef/architecture/sparc.h
|
||||
+++ b/boost/predef/architecture/sparc.h
|
||||
@@ -34,10 +34,10 @@ http://en.wikipedia.org/wiki/SPARC[SPARC
|
||||
|
||||
#if defined(__sparc__) || defined(__sparc)
|
||||
# undef BOOST_ARCH_SPARC
|
||||
-# if !defined(BOOST_ARCH_SPARC) && (defined(__sparcv9) || defined(__sparc_v9__)
|
||||
+# if !defined(BOOST_ARCH_SPARC) && (defined(__sparcv9) || defined(__sparc_v9__))
|
||||
# define BOOST_ARCH_SPARC BOOST_VERSION_NUMBER(9,0,0)
|
||||
# endif
|
||||
-# if !defined(BOOST_ARCH_SPARC) && (defined(__sparcv8) || defined(__sparc_v8__)
|
||||
+# if !defined(BOOST_ARCH_SPARC) && (defined(__sparcv8) || defined(__sparc_v8__))
|
||||
# define BOOST_ARCH_SPARC BOOST_VERSION_NUMBER(8,0,0)
|
||||
# endif
|
||||
# if !defined(BOOST_ARCH_SPARC)
|
13
libs/boost/patches/020-fix-musl-build.patch
Normal file
13
libs/boost/patches/020-fix-musl-build.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- a/boost/interprocess/permissions.hpp
|
||||
+++ b/boost/interprocess/permissions.hpp
|
||||
@@ -29,6 +29,10 @@
|
||||
|
||||
#include <boost/interprocess/detail/win32_api.hpp>
|
||||
|
||||
+#else
|
||||
+
|
||||
+#include <sys/stat.h>
|
||||
+
|
||||
#endif
|
||||
|
||||
#endif //#ifndef BOOST_INTERPROCESS_DOXYGEN_INVOKED
|
|
@ -1,178 +0,0 @@
|
|||
--- a/boost/math/special_functions/detail/bernoulli_details.hpp
|
||||
+++ b/boost/math/special_functions/detail/bernoulli_details.hpp
|
||||
@@ -360,7 +360,7 @@ public:
|
||||
return out;
|
||||
}
|
||||
|
||||
- #ifndef BOOST_HAS_THREADS
|
||||
+ #if !defined(BOOST_HAS_THREADS) || defined(BOOST_MATH_BERNOULLI_UNTHREADED)
|
||||
//
|
||||
// Single threaded code, very simple:
|
||||
//
|
||||
@@ -382,6 +382,8 @@ public:
|
||||
*out = (i >= m_overflow_limit) ? policies::raise_overflow_error<T>("boost::math::bernoulli_b2n<%1%>(std::size_t)", 0, T(i), pol) : bn[i];
|
||||
++out;
|
||||
}
|
||||
+ #elif defined(BOOST_MATH_NO_ATOMIC_INT)
|
||||
+ static_assert(sizeof(T) == 1, "Unsupported configuration: your platform appears to have no atomic integers. If you are happy with thread-unsafe code, then you may define BOOST_MATH_BERNOULLI_UNTHREADED to suppress this error.");
|
||||
#else
|
||||
//
|
||||
// Double-checked locking pattern, lets us access cached already cached values
|
||||
@@ -464,7 +466,7 @@ public:
|
||||
return out;
|
||||
}
|
||||
|
||||
- #ifndef BOOST_HAS_THREADS
|
||||
+ #if !defined(BOOST_HAS_THREADS) || defined(BOOST_MATH_BERNOULLI_UNTHREADED)
|
||||
//
|
||||
// Single threaded code, very simple:
|
||||
//
|
||||
@@ -494,6 +496,8 @@ public:
|
||||
}
|
||||
++out;
|
||||
}
|
||||
+ #elif defined(BOOST_MATH_NO_ATOMIC_INT)
|
||||
+ static_assert(sizeof(T) == 1, "Unsupported configuration: your platform appears to have no atomic integers. If you are happy with thread-unsafe code, then you may define BOOST_MATH_BERNOULLI_UNTHREADED to suppress this error.");
|
||||
#else
|
||||
//
|
||||
// Double-checked locking pattern, lets us access cached already cached values
|
||||
@@ -555,7 +559,7 @@ private:
|
||||
// The value at which we know overflow has already occurred for the Bn:
|
||||
std::size_t m_overflow_limit;
|
||||
|
||||
- #ifdef BOOST_HAS_THREADS
|
||||
+ #if defined(BOOST_HAS_THREADS) && !defined(BOOST_MATH_NO_ATOMIC_INT)
|
||||
std::mutex m_mutex;
|
||||
atomic_counter_type m_counter, m_current_precision;
|
||||
#else
|
||||
--- a/boost/math/tools/atomic.hpp
|
||||
+++ b/boost/math/tools/atomic.hpp
|
||||
@@ -16,27 +16,27 @@
|
||||
namespace boost {
|
||||
namespace math {
|
||||
namespace detail {
|
||||
-#if ATOMIC_INT_LOCK_FREE == 2
|
||||
+#if (ATOMIC_INT_LOCK_FREE == 2) && !defined(BOOST_MATH_NO_ATOMIC_INT)
|
||||
typedef std::atomic<int> atomic_counter_type;
|
||||
typedef std::atomic<unsigned> atomic_unsigned_type;
|
||||
typedef int atomic_integer_type;
|
||||
typedef unsigned atomic_unsigned_integer_type;
|
||||
-#elif ATOMIC_SHORT_LOCK_FREE == 2
|
||||
+#elif (ATOMIC_SHORT_LOCK_FREE == 2) && !defined(BOOST_MATH_NO_ATOMIC_INT)
|
||||
typedef std::atomic<short> atomic_counter_type;
|
||||
typedef std::atomic<unsigned short> atomic_unsigned_type;
|
||||
typedef short atomic_integer_type;
|
||||
typedef unsigned short atomic_unsigned_type;
|
||||
-#elif ATOMIC_LONG_LOCK_FREE == 2
|
||||
+#elif (ATOMIC_LONG_LOCK_FREE == 2) && !defined(BOOST_MATH_NO_ATOMIC_INT)
|
||||
typedef std::atomic<long> atomic_unsigned_integer_type;
|
||||
typedef std::atomic<unsigned long> atomic_unsigned_type;
|
||||
typedef unsigned long atomic_unsigned_type;
|
||||
typedef long atomic_integer_type;
|
||||
-#elif ATOMIC_LLONG_LOCK_FREE == 2
|
||||
+#elif (ATOMIC_LLONG_LOCK_FREE == 2) && !defined(BOOST_MATH_NO_ATOMIC_INT)
|
||||
typedef std::atomic<long long> atomic_unsigned_integer_type;
|
||||
typedef std::atomic<unsigned long long> atomic_unsigned_type;
|
||||
typedef long long atomic_integer_type;
|
||||
typedef unsigned long long atomic_unsigned_integer_type;
|
||||
-#else
|
||||
+#elif !defined(BOOST_MATH_NO_ATOMIC_INT)
|
||||
# define BOOST_MATH_NO_ATOMIC_INT
|
||||
#endif
|
||||
} // Namespace detail
|
||||
--- a/libs/math/test/Jamfile.v2
|
||||
+++ b/libs/math/test/Jamfile.v2
|
||||
@@ -121,6 +121,13 @@ test-suite special_fun :
|
||||
|
||||
[ run hypot_test.cpp test_instances//test_instances pch_light ../../test/build//boost_unit_test_framework ]
|
||||
[ run pow_test.cpp ../../test/build//boost_unit_test_framework ]
|
||||
+ [ run ccmath_sqrt_test.cpp ../../test/build//boost_unit_test_framework : : : [ requires cxx17_if_constexpr ] ]
|
||||
+ [ run ccmath_isinf_test.cpp ../../test/build//boost_unit_test_framework : : : [ requires cxx17_if_constexpr ] ]
|
||||
+ [ run ccmath_isnan_test.cpp ../../test/build//boost_unit_test_framework : : : [ requires cxx17_if_constexpr ] ]
|
||||
+ [ run ccmath_abs_test.cpp ../../test/build//boost_unit_test_framework : : : [ requires cxx17_if_constexpr ] ]
|
||||
+ [ run ccmath_isfinite_test.cpp ../../test/build//boost_unit_test_framework : : : [ requires cxx17_if_constexpr ] ]
|
||||
+ [ run ccmath_isnormal_test.cpp ../../test/build//boost_unit_test_framework : : : [ requires cxx17_if_constexpr ] ]
|
||||
+ [ run ccmath_fpclassify_test.cpp ../../test/build//boost_unit_test_framework : : : [ requires cxx17_if_constexpr ] ]
|
||||
[ run log1p_expm1_test.cpp test_instances//test_instances pch_light ../../test/build//boost_unit_test_framework ]
|
||||
[ run powm1_sqrtp1m1_test.cpp test_instances//test_instances pch_light ../../test/build//boost_unit_test_framework ]
|
||||
[ run special_functions_test.cpp ../../test/build//boost_unit_test_framework ]
|
||||
@@ -870,6 +877,7 @@ test-suite mp :
|
||||
;
|
||||
|
||||
test-suite misc :
|
||||
+ [ run header_deprecated_test.cpp ]
|
||||
[ run threading_sanity_check.cpp ]
|
||||
[ run test_tr1.cpp
|
||||
../build//boost_math_tr1
|
||||
@@ -1137,6 +1145,9 @@ test-suite misc :
|
||||
|
||||
# [ run __temporary_test.cpp test_instances//test_instances : : : <test-info>always_show_run_output <pch>off ]
|
||||
[ compile test_no_long_double_policy.cpp ]
|
||||
+ [ compile bernoulli_no_atomic_d.cpp ]
|
||||
+ [ compile bernoulli_no_atomic_mp.cpp ]
|
||||
+ [ compile-fail bernoulli_no_atomic_fail.cpp ]
|
||||
;
|
||||
|
||||
test-suite interpolators :
|
||||
@@ -1163,6 +1174,7 @@ test-suite interpolators :
|
||||
[ run quintic_hermite_test.cpp : : : [ requires cxx17_if_constexpr cxx17_std_apply ] [ check-target-builds ../config//has_float128 "GCC libquadmath and __float128 support" : <linkflags>-lquadmath ] ]
|
||||
[ run cubic_hermite_test.cpp : : : [ requires cxx17_if_constexpr cxx17_std_apply ] [ check-target-builds ../config//has_float128 "GCC libquadmath and __float128 support" : <linkflags>-lquadmath ] ]
|
||||
[ run bilinear_uniform_test.cpp : : : [ requires cxx17_if_constexpr cxx17_std_apply ] ]
|
||||
+ [ run bezier_polynomial_test.cpp : : : [ requires cxx17_if_constexpr cxx17_std_apply ] [ check-target-builds ../config//has_float128 "GCC libquadmath and __float128 support" : <linkflags>-lquadmath ] ]
|
||||
[ run catmull_rom_test.cpp ../../test/build//boost_unit_test_framework : : : <define>TEST=1 [ requires cxx11_hdr_array cxx11_hdr_initializer_list ] : catmull_rom_test_1 ]
|
||||
[ run catmull_rom_test.cpp ../../test/build//boost_unit_test_framework : : : <define>TEST=2 [ requires cxx11_hdr_array cxx11_hdr_initializer_list ] : catmull_rom_test_2 ]
|
||||
[ run catmull_rom_test.cpp ../../test/build//boost_unit_test_framework : : : <define>TEST=3 [ requires cxx11_hdr_array cxx11_hdr_initializer_list ] : catmull_rom_test_3 ]
|
||||
--- /dev/null
|
||||
+++ b/libs/math/test/bernoulli_no_atomic_d.cpp
|
||||
@@ -0,0 +1,14 @@
|
||||
+// (C) Copyright John Maddock 2021.
|
||||
+// Use, modification and distribution are subject to the
|
||||
+// Boost Software License, Version 1.0. (See accompanying file
|
||||
+// LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
|
||||
+
|
||||
+#define BOOST_MATH_NO_ATOMIC_INT
|
||||
+
|
||||
+#include <boost/math/special_functions/bernoulli.hpp>
|
||||
+#include "compile_test/test_compile_result.hpp"
|
||||
+
|
||||
+void compile_and_link_test()
|
||||
+{
|
||||
+ check_result<double>(boost::math::bernoulli_b2n<double>(4));
|
||||
+}
|
||||
--- /dev/null
|
||||
+++ b/libs/math/test/bernoulli_no_atomic_fail.cpp
|
||||
@@ -0,0 +1,15 @@
|
||||
+// (C) Copyright John Maddock 2021.
|
||||
+// Use, modification and distribution are subject to the
|
||||
+// Boost Software License, Version 1.0. (See accompanying file
|
||||
+// LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
|
||||
+
|
||||
+#define BOOST_MATH_NO_ATOMIC_INT
|
||||
+
|
||||
+#include <boost/math/special_functions/bernoulli.hpp>
|
||||
+#include <boost/multiprecision/cpp_bin_float.hpp>
|
||||
+#include "compile_test/test_compile_result.hpp"
|
||||
+
|
||||
+void compile_and_link_test()
|
||||
+{
|
||||
+ check_result<boost::multiprecision::cpp_bin_float_50>(boost::math::bernoulli_b2n<boost::multiprecision::cpp_bin_float_50>(4));
|
||||
+}
|
||||
--- /dev/null
|
||||
+++ b/libs/math/test/bernoulli_no_atomic_mp.cpp
|
||||
@@ -0,0 +1,16 @@
|
||||
+// (C) Copyright John Maddock 2021.
|
||||
+// Use, modification and distribution are subject to the
|
||||
+// Boost Software License, Version 1.0. (See accompanying file
|
||||
+// LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
|
||||
+
|
||||
+#define BOOST_MATH_NO_ATOMIC_INT
|
||||
+#define BOOST_MATH_BERNOULLI_UNTHREADED
|
||||
+
|
||||
+#include <boost/math/special_functions/bernoulli.hpp>
|
||||
+#include <boost/multiprecision/cpp_bin_float.hpp>
|
||||
+#include "compile_test/test_compile_result.hpp"
|
||||
+
|
||||
+void compile_and_link_test()
|
||||
+{
|
||||
+ check_result<boost::multiprecision::cpp_bin_float_50>(boost::math::bernoulli_b2n<boost::multiprecision::cpp_bin_float_50>(4));
|
||||
+}
|
Loading…
Reference in a new issue