Copy netatalk package from old repository
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
9608f08ef1
commit
e943dbc6c0
5 changed files with 120 additions and 0 deletions
85
net/netatalk/Makefile
Normal file
85
net/netatalk/Makefile
Normal file
|
@ -0,0 +1,85 @@
|
||||||
|
#
|
||||||
|
# Copyright (C) 2009-2013 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=netatalk
|
||||||
|
PKG_VERSION:=2.2.4
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_SOURCE_URL:=@SF/netatalk
|
||||||
|
PKG_MD5SUM:=40753a32340c24e4ec395aeb55ef056e
|
||||||
|
|
||||||
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
PKG_FIXUP:=autoreconf
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/netatalk
|
||||||
|
SECTION:=net
|
||||||
|
CATEGORY:=Network
|
||||||
|
SUBMENU:=Filesystem
|
||||||
|
DEPENDS:=+libdb47 +libgcrypt +libopenssl $(LIBRPC_DEPENDS)
|
||||||
|
TITLE:=netatalk
|
||||||
|
URL:=http://netatalk.sourceforge.net
|
||||||
|
MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/netatalk/decription
|
||||||
|
Netatalk is a freely-available Open Source AFP fileserver.
|
||||||
|
It also provides a kernel level implementation of the AppleTalk
|
||||||
|
Protocol Suite.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/netatalk/conffiles
|
||||||
|
/etc/netatalk/afpd.conf
|
||||||
|
endef
|
||||||
|
|
||||||
|
TARGET_CFLAGS += -std=gnu99
|
||||||
|
TARGET_LDFLAGS += $(LIBRPC)
|
||||||
|
|
||||||
|
CONFIGURE_ARGS += \
|
||||||
|
--disable-afs \
|
||||||
|
--enable-hfs \
|
||||||
|
--disable-debugging \
|
||||||
|
--disable-shell-check \
|
||||||
|
--disable-timelord \
|
||||||
|
--disable-a2boot \
|
||||||
|
--disable-cups \
|
||||||
|
--disable-tcp-wrappers \
|
||||||
|
--with-cnid-default-backend=dbd \
|
||||||
|
--with-bdb="$(STAGING_DIR)/usr/" \
|
||||||
|
--with-libgcrypt-dir="$(STAGING_DIR)/usr" \
|
||||||
|
--with-ssl-dir="$(STAGING_DIR)/usr" \
|
||||||
|
--with-uams-path="/usr/lib/uams" \
|
||||||
|
--without-pam \
|
||||||
|
--disable-admin-group \
|
||||||
|
--disable-srvloc \
|
||||||
|
--disable-zeroconf \
|
||||||
|
$(if $(CONFIG_SHADOW_PASSWORDS),--with-shadow,--without-shadow) \
|
||||||
|
--without-ldap
|
||||||
|
|
||||||
|
define Package/netatalk/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib/uams
|
||||||
|
$(INSTALL_DIR) $(1)/etc/netatalk
|
||||||
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/afppasswd $(1)/usr/bin/
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/afpd $(1)/usr/sbin/
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/cnid_dbd $(1)/usr/sbin/
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/cnid_metad $(1)/usr/sbin/
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/uams/*.so $(1)/usr/lib/uams/
|
||||||
|
$(CP) ./files/AppleVolumes.default $(1)/etc/netatalk/
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/etc/netatalk/AppleVolumes.system $(1)/etc/netatalk/
|
||||||
|
$(INSTALL_CONF) ./files/afpd.conf $(1)/etc/netatalk/
|
||||||
|
$(INSTALL_BIN) ./files/afpd.init $(1)/etc/init.d/afpd
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,netatalk))
|
2
net/netatalk/files/AppleVolumes.default
Normal file
2
net/netatalk/files/AppleVolumes.default
Normal file
|
@ -0,0 +1,2 @@
|
||||||
|
-
|
||||||
|
/tmp Temp allow:root,nobody cnidscheme:dbd
|
1
net/netatalk/files/afpd.conf
Normal file
1
net/netatalk/files/afpd.conf
Normal file
|
@ -0,0 +1 @@
|
||||||
|
- -noddp -uampath /usr/lib/uams -uamlist uams_guest.so,uams_passwd.so,uams_dhx_passwd.so,uams_randnum.so,uams_dhx2.so -passwdfile /etc/netatalk/afppasswd -savepassword -passwdminlen 0 -nosetpassword -defaultvol /etc/netatalk/AppleVolumes.default -systemvol /etc/netatalk/AppleVolumes.system -nouservol -guestname "nobody" -sleep 1 -icon
|
23
net/netatalk/files/afpd.init
Normal file
23
net/netatalk/files/afpd.init
Normal file
|
@ -0,0 +1,23 @@
|
||||||
|
#!/bin/sh /etc/rc.common
|
||||||
|
# Copyright (C) 2010-2012 OpenWrt.org
|
||||||
|
|
||||||
|
START=70
|
||||||
|
|
||||||
|
MAXCONS="7"
|
||||||
|
|
||||||
|
start()
|
||||||
|
{
|
||||||
|
service_start /usr/sbin/cnid_metad
|
||||||
|
service_start /usr/sbin/afpd -c ${MAXCONS}
|
||||||
|
}
|
||||||
|
|
||||||
|
stop()
|
||||||
|
{
|
||||||
|
service_stop /usr/sbin/afpd
|
||||||
|
service_stop /usr/sbin/cnid_metad
|
||||||
|
}
|
||||||
|
|
||||||
|
reload()
|
||||||
|
{
|
||||||
|
service_reload /usr/sbin/afpd
|
||||||
|
}
|
9
net/netatalk/patches/001-automake-compat.patch
Normal file
9
net/netatalk/patches/001-automake-compat.patch
Normal file
|
@ -0,0 +1,9 @@
|
||||||
|
--- a/macros/iconv.m4
|
||||||
|
+++ b/macros/iconv.m4
|
||||||
|
@@ -114,6 +114,5 @@ int main() {
|
||||||
|
|
||||||
|
CFLAGS="$savedcflags"
|
||||||
|
LDFLAGS="$savedldflags"
|
||||||
|
- CPPFLAGS="$saved_CPPFLAGS"
|
||||||
|
|
||||||
|
])
|
Loading…
Reference in a new issue