Merge pull request #13899 from nxhack/bindings_902
node-serialport-bindings: update to 9.0.2
This commit is contained in:
commit
e869fee56e
2 changed files with 2 additions and 18 deletions
|
@ -7,12 +7,12 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NPM_SCOPE:=serialport
|
||||
PKG_NPM_NAME:=bindings
|
||||
PKG_NAME:=node-$(PKG_NPM_SCOPE)-$(PKG_NPM_NAME)
|
||||
PKG_VERSION:=9.0.1
|
||||
PKG_VERSION:=9.0.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NPM_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=https://registry.npmjs.org/@$(PKG_NPM_SCOPE)/$(PKG_NPM_NAME)/-/
|
||||
PKG_HASH:=12cd7864a18d2025bf152754c019badaef387c75417fe86b9a80c86ec0ae6b49
|
||||
PKG_HASH:=03e28d0ef191f3e3f2cf9215c2f2f43106e85638a8d3bd210127781cb73ed50a
|
||||
|
||||
PKG_BUILD_DEPENDS:=node/host
|
||||
PKG_USE_MIPS16:=0
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
--- a/src/serialport_linux.cpp
|
||||
+++ b/src/serialport_linux.cpp
|
||||
@@ -1,8 +1,13 @@
|
||||
#if defined(__linux__)
|
||||
|
||||
#include <sys/ioctl.h>
|
||||
+#if defined(__powerpc__) || defined(__powerpc64__)
|
||||
+#include <asm-generic/ioctls.h>
|
||||
+#include <asm-generic/termbits.h>
|
||||
+#else
|
||||
#include <asm/ioctls.h>
|
||||
#include <asm/termbits.h>
|
||||
+#endif
|
||||
|
||||
// Uses the termios2 interface to set nonstandard baud rates
|
||||
int linuxSetCustomBaudRate(const int fd, const unsigned int baudrate) {
|
Loading…
Reference in a new issue