Merge pull request #2488 from obsy/master

transmission: update to 2.92, refresh patches
This commit is contained in:
Hannu Nyman 2016-03-12 12:03:12 +02:00
commit e854a5541a
4 changed files with 15 additions and 31 deletions

View file

@ -1,5 +1,5 @@
#
# Copyright (C) 2009-2014 OpenWrt.org
# Copyright (C) 2009-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=transmission
PKG_VERSION:=2.84
PKG_RELEASE:=4
PKG_VERSION:=2.92
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://download-origin.transmissionbt.com/files/ http://mirrors.m0k.org/transmission/files
PKG_MD5SUM:=411aec1c418c14f6765710d89743ae42
PKG_MD5SUM:=3fce404a436e3cd7fde80fb6ed61c264
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@ -89,6 +89,8 @@ CONFIGURE_ARGS += \
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE"
TARGET_CFLAGS += -std=gnu99
define Package/transmission-daemon/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/transmission-daemon $(1)/usr/bin/

View file

@ -1,14 +0,0 @@
--- a/libtransmission/fdlimit.c
+++ b/libtransmission/fdlimit.c
@@ -22,11 +22,6 @@
#include <fcntl.h>
#endif
-#ifdef HAVE_FALLOCATE64
- /* FIXME can't find the right #include voodoo to pick up the declaration.. */
- extern int fallocate64 (int fd, int mode, uint64_t offset, uint64_t len);
-#endif
-
#ifdef HAVE_XFS_XFS_H
#include <xfs/xfs.h>
#endif

View file

@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
@@ -251,7 +251,7 @@
@@ -378,7 +378,7 @@ dnl See if ANY version of miniupnpc is i
AC_LINK_IFELSE(
[AC_LANG_PROGRAM([#include <miniupnpc/miniupnpc.h>],
[struct UPNPDev dev;])],

View file

@ -1,17 +1,15 @@
Index: transmission-2.84/libtransmission/bitfield.c
===================================================================
--- transmission-2.84.orig/libtransmission/bitfield.c
+++ transmission-2.84/libtransmission/bitfield.c
--- a/libtransmission/bitfield.c
+++ b/libtransmission/bitfield.c
@@ -7,6 +7,8 @@
* $Id: bitfield.c 14302 2014-06-29 01:42:38Z jordan $
* $Id: bitfield.c 14646 2015-12-31 05:22:42Z mikedld $
*/
+#define __NEED_ssize_t
+
#include <assert.h>
#include <stdlib.h> /* realloc () */
#include <string.h> /* memset */
@@ -15,6 +17,7 @@
@@ -14,6 +16,7 @@
#include "bitfield.h"
#include "utils.h" /* tr_new0 () */
@ -19,10 +17,8 @@ Index: transmission-2.84/libtransmission/bitfield.c
const tr_bitfield TR_BITFIELD_INIT = { NULL, 0, 0, 0, false, false };
/****
Index: transmission-2.84/libtransmission/fdlimit.h
===================================================================
--- transmission-2.84.orig/libtransmission/fdlimit.h
+++ transmission-2.84/libtransmission/fdlimit.h
--- a/libtransmission/fdlimit.h
+++ b/libtransmission/fdlimit.h
@@ -11,6 +11,8 @@
#error only libtransmission should #include this header.
#endif
@ -30,5 +26,5 @@ Index: transmission-2.84/libtransmission/fdlimit.h
+#define __NEED_off_t
+
#include "transmission.h"
#include "file.h"
#include "net.h"