Merge pull request #285 from morgenroth/Disable-building-of-documentation
ibrdtnd: Add patch to exclude build of documentation using pdflatex
This commit is contained in:
commit
e82f9c62af
1 changed files with 26 additions and 0 deletions
26
net/ibrdtnd/patches/110-add_configure_options_docs.patch
Normal file
26
net/ibrdtnd/patches/110-add_configure_options_docs.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -138,11 +138,17 @@ AS_IF([test "x$enable_android" = "xyes"], [
|
||||
# Checks for library functions.
|
||||
AC_CHECK_FUNCS([gethostname socket])
|
||||
|
||||
- # Check for presence of pdfLaTeX
|
||||
- AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
|
||||
- if test -z "$PDFLATEX"; then
|
||||
- AC_MSG_WARN([Unable to create PDF version of the documentation.])
|
||||
- fi
|
||||
+ AC_ARG_ENABLE([docs],
|
||||
+ AS_HELP_STRING([--enable-docs], [Build documentation using PDFLaTeX]),
|
||||
+ [
|
||||
+ # Check for presence of pdfLaTeX
|
||||
+ AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
|
||||
+ if test -z "$PDFLATEX"; then
|
||||
+ AC_MSG_WARN([Unable to create PDF version of the documentation.])
|
||||
+ fi
|
||||
+ ], [
|
||||
+ PDFLATEX="no"
|
||||
+ ])
|
||||
|
||||
AC_ARG_ENABLE([libdaemon],
|
||||
AS_HELP_STRING([--disable-libdaemon], [Build without libdaemon support]),
|
||||
--
|
Loading…
Reference in a new issue