device-observatory: fix compilation with newer libmicrohttpd
API change. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
10eba3a334
commit
e82e31badd
2 changed files with 21 additions and 1 deletions
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=device-observatory
|
PKG_NAME:=device-observatory
|
||||||
PKG_VERSION:=1.2.0
|
PKG_VERSION:=1.2.0
|
||||||
PKG_RELEASE:=6
|
PKG_RELEASE:=7
|
||||||
|
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/mwarning/device-observatory/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/mwarning/device-observatory/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
|
20
utils/device-observatory/patches/020-libmicrohttpd.patch
Normal file
20
utils/device-observatory/patches/020-libmicrohttpd.patch
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
--- a/src/webserver.c
|
||||||
|
+++ b/src/webserver.c
|
||||||
|
@@ -129,7 +129,7 @@ const char *get_mimetype(const char str[])
|
||||||
|
return "application/octet-stream";
|
||||||
|
}
|
||||||
|
|
||||||
|
-static int send_response(void *cls, struct MHD_Connection *connection,
|
||||||
|
+static enum MHD_Result send_response(void *cls, struct MHD_Connection *connection,
|
||||||
|
const char *url, const char *method, const char *version,
|
||||||
|
const char *upload_data, size_t *upload_data_size, void **con_cls)
|
||||||
|
{
|
||||||
|
@@ -142,7 +142,7 @@ static int send_response(void *cls, struct MHD_Connection *connection,
|
||||||
|
struct device *device;
|
||||||
|
int is_localhost;
|
||||||
|
FILE *fp;
|
||||||
|
- int ret;
|
||||||
|
+ enum MHD_Result ret;
|
||||||
|
|
||||||
|
connection_info = MHD_get_connection_info(connection, MHD_CONNECTION_INFO_CLIENT_ADDRESS);
|
||||||
|
if (!connection_info) {
|
Loading…
Reference in a new issue