Revert "vnstat: update to v1.16"
This reverts commit 79b6e9dc61
.
Undo the recent vnstat update due to upstream bugs preventing database
restoration.
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
This commit is contained in:
parent
3c5937d60f
commit
e751c3abbe
6 changed files with 64 additions and 53 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=vnstat
|
PKG_NAME:=vnstat
|
||||||
PKG_VERSION:=1.16
|
PKG_VERSION:=1.12
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://humdi.net/vnstat
|
PKG_SOURCE_URL:=http://humdi.net/vnstat
|
||||||
PKG_HASH:=420fec6c89229a100697f3189e824a1b81f7148dd651558f2ff03cc298308e8b
|
PKG_MD5SUM:=a154b2196771e06a8accd1c24374009c
|
||||||
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
|
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
@ -86,7 +86,7 @@ define Package/vnstat/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/vnstatd $(1)/usr/sbin/
|
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/vnstatd $(1)/usr/sbin/
|
||||||
$(INSTALL_DIR) $(1)/etc
|
$(INSTALL_DIR) $(1)/etc
|
||||||
$(INSTALL_CONF) $(PKG_BUILD_DIR)/cfg/vnstat.conf $(1)/etc/
|
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/vnstat.conf $(1)/etc/
|
||||||
$(INSTALL_DIR) $(1)/etc/config
|
$(INSTALL_DIR) $(1)/etc/config
|
||||||
$(INSTALL_CONF) ./files/vnstat.config $(1)/etc/config/vnstat
|
$(INSTALL_CONF) ./files/vnstat.config $(1)/etc/config/vnstat
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
|
|
|
@ -1,15 +1,6 @@
|
||||||
From: Jo-Philipp Wich <jo@mein.io>
|
|
||||||
Date: Thu, 26 Jan 2017 15:30:00 +0100
|
|
||||||
Subject: [PATCH] config: adjust default values
|
|
||||||
|
|
||||||
Adjust the default interval settings to be better suited for slower embedded
|
|
||||||
devices.
|
|
||||||
|
|
||||||
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
|
|
||||||
|
|
||||||
--- a/cfg/vnstat.conf
|
--- a/cfg/vnstat.conf
|
||||||
+++ b/cfg/vnstat.conf
|
+++ b/cfg/vnstat.conf
|
||||||
@@ -87,13 +87,13 @@ DaemonUser ""
|
@@ -78,13 +78,13 @@ DaemonUser ""
|
||||||
DaemonGroup ""
|
DaemonGroup ""
|
||||||
|
|
||||||
# how often (in seconds) interface data is updated
|
# how often (in seconds) interface data is updated
|
35
net/vnstat/patches/002-no_install_strip.patch
Normal file
35
net/vnstat/patches/002-no_install_strip.patch
Normal file
|
@ -0,0 +1,35 @@
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -66,11 +66,11 @@ install:
|
||||||
|
|
||||||
|
# install everything else
|
||||||
|
install -d -m 755 $(BIN) $(SBIN) $(MAN)/man1 $(MAN)/man5
|
||||||
|
- install -s -m 755 src/vnstat $(BIN)
|
||||||
|
- install -s -m 755 src/vnstatd $(SBIN)
|
||||||
|
+ install -m 755 src/vnstat $(BIN)
|
||||||
|
+ install -m 755 src/vnstatd $(SBIN)
|
||||||
|
@if [ -f "src/vnstati" ]; \
|
||||||
|
- then echo install -s -m 755 src/vnstati $(BIN); \
|
||||||
|
- install -s -m 755 src/vnstati $(BIN); \
|
||||||
|
+ then echo install -m 755 src/vnstati $(BIN); \
|
||||||
|
+ install -m 755 src/vnstati $(BIN); \
|
||||||
|
fi
|
||||||
|
|
||||||
|
# update man pages, gzip it if previous version was done so
|
||||||
|
@@ -139,12 +139,12 @@ bsdinstall:
|
||||||
|
|
||||||
|
# install binaries
|
||||||
|
install -d -m 755 $(DESTDIR)/var/db/vnstat
|
||||||
|
- install -s -m 755 src/vnstat $(BIN_BSD)
|
||||||
|
- install -s -m 755 src/vnstatd $(SBIN_BSD)
|
||||||
|
+ install -m 755 src/vnstat $(BIN_BSD)
|
||||||
|
+ install -m 755 src/vnstatd $(SBIN_BSD)
|
||||||
|
|
||||||
|
@if [ -f "src/vnstati" ]; \
|
||||||
|
- then echo install -s -m 755 src/vnstati $(BIN_BSD); \
|
||||||
|
- install -s -m 755 src/vnstati $(BIN_BSD); \
|
||||||
|
+ then echo install -m 755 src/vnstati $(BIN_BSD); \
|
||||||
|
+ install -m 755 src/vnstati $(BIN_BSD); \
|
||||||
|
fi
|
||||||
|
|
||||||
|
# install default config if such doesn't exist
|
15
net/vnstat/patches/003-no_install_uname.patch
Normal file
15
net/vnstat/patches/003-no_install_uname.patch
Normal file
|
@ -0,0 +1,15 @@
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -33,12 +33,6 @@ debug:
|
||||||
|
install:
|
||||||
|
@echo "Installing vnStat..."
|
||||||
|
|
||||||
|
-# check that system is really Linux
|
||||||
|
- @if [ `uname` != "Linux" ]; \
|
||||||
|
- then echo "This isn't a Linux system. Maybe 'make bsdinstall' is what you need?"; \
|
||||||
|
- false; \
|
||||||
|
- fi
|
||||||
|
-
|
||||||
|
# check that there's something to install
|
||||||
|
@if [ ! -f "src/vnstat" ] || [ ! -f "src/vnstatd" ]; \
|
||||||
|
then echo "Nothing to install, run make first."; \
|
10
net/vnstat/patches/100-musl-compat.patch
Normal file
10
net/vnstat/patches/100-musl-compat.patch
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- a/src/common.h
|
||||||
|
+++ b/src/common.h
|
||||||
|
@@ -22,6 +22,7 @@
|
||||||
|
#include <pwd.h>
|
||||||
|
#include <grp.h>
|
||||||
|
#include <libgen.h>
|
||||||
|
+#include <fcntl.h>
|
||||||
|
|
||||||
|
#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__APPLE__) || defined(__FreeBSD_kernel__)
|
||||||
|
#include <sys/param.h>
|
|
@ -1,40 +0,0 @@
|
||||||
From: Jo-Philipp Wich <jo@mein.io>
|
|
||||||
Date: Thu, 26 Jan 2017 15:31:00 +0100
|
|
||||||
Subject: [PATCH] make: do not invoke vnstat --showconfig
|
|
||||||
|
|
||||||
In a cross-compile setting we cannot invoke the complied target executable,
|
|
||||||
therfore commit out the --showconfig call in order to prevent make from
|
|
||||||
exiting with an error.
|
|
||||||
|
|
||||||
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
|
|
||||||
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -104,9 +104,9 @@ release: distcheck
|
|
||||||
ls -l $(PACKAGE_NAME)-$(PACKAGE_VERSION).tar.gz
|
|
||||||
|
|
||||||
install-data-hook:
|
|
||||||
- $(DESTDIR)$(bindir)/vnstat$(EXEEXT) --showconfig >vnstat.conf && \
|
|
||||||
- $(MKDIR_P) $(DESTDIR)$(sysconfdir) && \
|
|
||||||
- mv -f vnstat.conf $(DESTDIR)$(sysconfdir)/vnstat.conf
|
|
||||||
+ #$(DESTDIR)$(bindir)/vnstat$(EXEEXT) --showconfig >vnstat.conf && \
|
|
||||||
+ # $(MKDIR_P) $(DESTDIR)$(sysconfdir) && \
|
|
||||||
+ # mv -f vnstat.conf $(DESTDIR)$(sysconfdir)/vnstat.conf
|
|
||||||
@echo
|
|
||||||
@echo "============================================================================"
|
|
||||||
@echo " Note: No service file has been installed for starting the daemon"
|
|
||||||
--- a/Makefile.in
|
|
||||||
+++ b/Makefile.in
|
|
||||||
@@ -2051,9 +2051,9 @@ release: distcheck
|
|
||||||
ls -l $(PACKAGE_NAME)-$(PACKAGE_VERSION).tar.gz
|
|
||||||
|
|
||||||
install-data-hook:
|
|
||||||
- $(DESTDIR)$(bindir)/vnstat$(EXEEXT) --showconfig >vnstat.conf && \
|
|
||||||
- $(MKDIR_P) $(DESTDIR)$(sysconfdir) && \
|
|
||||||
- mv -f vnstat.conf $(DESTDIR)$(sysconfdir)/vnstat.conf
|
|
||||||
+ #$(DESTDIR)$(bindir)/vnstat$(EXEEXT) --showconfig >vnstat.conf && \
|
|
||||||
+ # $(MKDIR_P) $(DESTDIR)$(sysconfdir) && \
|
|
||||||
+ # mv -f vnstat.conf $(DESTDIR)$(sysconfdir)/vnstat.conf
|
|
||||||
@echo
|
|
||||||
@echo "============================================================================"
|
|
||||||
@echo " Note: No service file has been installed for starting the daemon"
|
|
Loading…
Reference in a new issue