Merge pull request #4115 from dibdot/mc
mc (midnight commander): release 4.8.19
This commit is contained in:
commit
e68843c29d
2 changed files with 24 additions and 11 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006-2016 OpenWrt.org
|
# Copyright (C) 2006-2017 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -8,14 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mc
|
PKG_NAME:=mc
|
||||||
PKG_VERSION:=4.8.18
|
PKG_VERSION:=4.8.19
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
|
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
|
||||||
PKG_LICENSE:=GPL-3.0+
|
PKG_LICENSE:=GPL-3.0+
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://ftp.midnight-commander.org/
|
PKG_SOURCE_URL:=http://ftp.midnight-commander.org/
|
||||||
PKG_MD5SUM:=f7636815c987c1719c4f5de2dcd156a0e7d097b1d10e4466d2bdead343d5bece
|
PKG_HASH:=eb9e56bbb5b2893601d100d0e0293983049b302c5ab61bfb544ad0ee2cc1f2df
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
PKG_FIXUP:=autoreconf gettext-version
|
PKG_FIXUP:=autoreconf gettext-version
|
||||||
|
|
||||||
|
@ -54,6 +54,8 @@ Internal viewer and editor are included as well.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
|
--enable-silent-rules \
|
||||||
|
--disable-tests \
|
||||||
--disable-doxygen-doc \
|
--disable-doxygen-doc \
|
||||||
--with-homedir=/etc/mc \
|
--with-homedir=/etc/mc \
|
||||||
--with-screen=ncurses \
|
--with-screen=ncurses \
|
||||||
|
|
|
@ -1,11 +1,22 @@
|
||||||
--- a/src/subshell/common.c
|
--- a/src/subshell/common.c
|
||||||
+++ b/src/subshell/common.c
|
+++ b/src/subshell/common.c
|
||||||
@@ -849,7 +849,7 @@ init_subshell_precmd (char *precmd, size
|
@@ -843,16 +843,9 @@ init_subshell_precmd (char *precmd, size
|
||||||
"else "
|
* "PS1='$($PRECMD)$ '\n",
|
||||||
"[ \"${PWD##$HOME/}\" = \"$PWD\" ] && MC_PWD=\"$PWD\" || MC_PWD=\"~/${PWD##$HOME/}\"; "
|
*/
|
||||||
"fi; "
|
g_snprintf (precmd, buff_size,
|
||||||
|
- "precmd() { "
|
||||||
|
- "if [ ! \"${PWD##$HOME}\" ]; then "
|
||||||
|
- "MC_PWD=\"~\"; "
|
||||||
|
- "else "
|
||||||
|
- "[ \"${PWD##$HOME/}\" = \"$PWD\" ] && MC_PWD=\"$PWD\" || MC_PWD=\"~/${PWD##$HOME/}\"; "
|
||||||
|
- "fi; "
|
||||||
- "echo \"$USER@$(hostname -s):$MC_PWD\"; "
|
- "echo \"$USER@$(hostname -s):$MC_PWD\"; "
|
||||||
+ "echo \"$USER@$HOSTNAME:$MC_PWD\"; "
|
- "pwd>&%d; "
|
||||||
"pwd>&%d; "
|
- "kill -STOP $$; "
|
||||||
"kill -STOP $$; "
|
- "}; " "PRECMD=precmd; " "PS1='$($PRECMD)$ '\n", subshell_pipe[WRITE]);
|
||||||
"}; " "PRECMD=precmd; " "PS1='$($PRECMD)$ '\n", subshell_pipe[WRITE]);
|
+ "precmd() { pwd>&%d; kill -STOP $$; }; "
|
||||||
|
+ "PRECMD=precmd; "
|
||||||
|
+ "PS1='$(eval $PRECMD)\\u@\\h:\\w\\$ '\n", subshell_pipe[WRITE]);
|
||||||
|
break;
|
||||||
|
|
||||||
|
case SHELL_ZSH:
|
||||||
|
|
Loading…
Reference in a new issue