git: update to 2.33.0
* refresh patches Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
This commit is contained in:
parent
1cba8af1b1
commit
e684672916
3 changed files with 6 additions and 6 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=git
|
PKG_NAME:=git
|
||||||
PKG_VERSION:=2.30.2
|
PKG_VERSION:=2.33.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@KERNEL/software/scm/git/
|
PKG_SOURCE_URL:=@KERNEL/software/scm/git/
|
||||||
PKG_HASH:=41f7d90c71f9476cd387673fcb10ce09ccbed67332436a4cc58d7af32c355faa
|
PKG_HASH:=bf3c6ab5f82e072aad4768f647cfb1ef60aece39855f83f080f9c0222dd20c4f
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -1001,7 +1001,8 @@ AC_RUN_IFELSE(
|
@@ -966,7 +966,8 @@ AC_RUN_IFELSE(
|
||||||
FILE *f = fopen(".", "r");
|
FILE *f = fopen(".", "r");
|
||||||
return f != NULL;]])],
|
return f != NULL;]])],
|
||||||
[ac_cv_fread_reads_directories=no],
|
[ac_cv_fread_reads_directories=no],
|
||||||
|
@ -10,7 +10,7 @@
|
||||||
])
|
])
|
||||||
if test $ac_cv_fread_reads_directories = yes; then
|
if test $ac_cv_fread_reads_directories = yes; then
|
||||||
FREAD_READS_DIRECTORIES=UnfortunatelyYes
|
FREAD_READS_DIRECTORIES=UnfortunatelyYes
|
||||||
@@ -1035,7 +1036,8 @@ AC_RUN_IFELSE(
|
@@ -1000,7 +1001,8 @@ AC_RUN_IFELSE(
|
||||||
if (snprintf(buf, 3, "%s", "12345") != 5
|
if (snprintf(buf, 3, "%s", "12345") != 5
|
||||||
|| strcmp(buf, "12")) return 1]])],
|
|| strcmp(buf, "12")) return 1]])],
|
||||||
[ac_cv_snprintf_returns_bogus=no],
|
[ac_cv_snprintf_returns_bogus=no],
|
||||||
|
@ -20,7 +20,7 @@
|
||||||
])
|
])
|
||||||
if test $ac_cv_snprintf_returns_bogus = yes; then
|
if test $ac_cv_snprintf_returns_bogus = yes; then
|
||||||
SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
|
SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
|
||||||
@@ -1058,7 +1060,8 @@ yippeeyeswehaveit
|
@@ -1023,7 +1025,8 @@ yippeeyeswehaveit
|
||||||
#endif
|
#endif
|
||||||
]),
|
]),
|
||||||
[ac_cv_sane_mode_bits=yes],
|
[ac_cv_sane_mode_bits=yes],
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -1434,7 +1434,7 @@ else
|
@@ -1448,7 +1448,7 @@ else
|
||||||
endif
|
endif
|
||||||
curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
|
curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
|
||||||
ifeq "$(curl_check)" "072200"
|
ifeq "$(curl_check)" "072200"
|
||||||
|
|
Loading…
Reference in a new issue