btrfs-progs: bump to 3.19.1
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
70344eea14
commit
e6825ac677
2 changed files with 56 additions and 36 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=btrfs-progs
|
||||
PKG_VERSION:=3.17.3
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=3.19.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/kdave/btrfs-progs/
|
||||
PKG_MD5SUM:=6716b4b109dd909af63ab3becbad67a6
|
||||
PKG_MD5SUM:=ec3b3c99df18633ddc9e41f0680c5a51
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
|
@ -24,6 +24,8 @@ PKG_INSTALL:=1
|
|||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_DEPENDS:=libacl
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/btrfs-progs
|
||||
|
@ -46,15 +48,9 @@ progs = btrfs btrfsck btrfs-convert btrfs-debug-tree btrfs-find-root \
|
|||
btrfs-image btrfs-map-logical btrfs-show-super btrfstune \
|
||||
btrfs-zero-log fsck.btrfs mkfs.btrfs
|
||||
|
||||
|
||||
MAKE_FLAGS+=\
|
||||
CC="$(TARGET_CC)" \
|
||||
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
|
||||
LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||
prefix=/usr \
|
||||
DESTDIR=$(PKG_INSTALL_DIR) \
|
||||
DISABLE_BACKTRACE=1 \
|
||||
DISABLE_DOCUMENTATION=1
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-backtrace \
|
||||
--disable-documentation
|
||||
|
||||
define Package/btrfs-progs/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
|
|
|
@ -1,16 +1,20 @@
|
|||
--- a/mkfs.c
|
||||
+++ b/mkfs.c
|
||||
@@ -34,7 +34,7 @@
|
||||
Index: btrfs-progs-v3.19.1/mkfs.c
|
||||
===================================================================
|
||||
--- btrfs-progs-v3.19.1.orig/mkfs.c
|
||||
+++ btrfs-progs-v3.19.1/mkfs.c
|
||||
@@ -31,7 +31,7 @@
|
||||
#include <getopt.h>
|
||||
#include <uuid/uuid.h>
|
||||
#include <ctype.h>
|
||||
-#include <sys/xattr.h>
|
||||
+#include <attr/xattr.h>
|
||||
#include <limits.h>
|
||||
#include <linux/limits.h>
|
||||
#include <blkid/blkid.h>
|
||||
#include <ftw.h>
|
||||
#include "ctree.h"
|
||||
--- a/props.c
|
||||
+++ b/props.c
|
||||
Index: btrfs-progs-v3.19.1/props.c
|
||||
===================================================================
|
||||
--- btrfs-progs-v3.19.1.orig/props.c
|
||||
+++ btrfs-progs-v3.19.1/props.c
|
||||
@@ -17,7 +17,7 @@
|
||||
#include <sys/stat.h>
|
||||
#include <sys/ioctl.h>
|
||||
|
@ -20,9 +24,11 @@
|
|||
#include <fcntl.h>
|
||||
#include <unistd.h>
|
||||
|
||||
--- a/cmds-receive.c
|
||||
+++ b/cmds-receive.c
|
||||
@@ -39,7 +39,7 @@
|
||||
Index: btrfs-progs-v3.19.1/cmds-receive.c
|
||||
===================================================================
|
||||
--- btrfs-progs-v3.19.1.orig/cmds-receive.c
|
||||
+++ btrfs-progs-v3.19.1/cmds-receive.c
|
||||
@@ -34,7 +34,7 @@
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/time.h>
|
||||
#include <sys/types.h>
|
||||
|
@ -31,9 +37,11 @@
|
|||
#include <uuid/uuid.h>
|
||||
|
||||
#include "ctree.h"
|
||||
--- a/cmds-restore.c
|
||||
+++ b/cmds-restore.c
|
||||
@@ -34,7 +34,7 @@
|
||||
Index: btrfs-progs-v3.19.1/cmds-restore.c
|
||||
===================================================================
|
||||
--- btrfs-progs-v3.19.1.orig/cmds-restore.c
|
||||
+++ btrfs-progs-v3.19.1/cmds-restore.c
|
||||
@@ -32,7 +32,7 @@
|
||||
#include <regex.h>
|
||||
#include <getopt.h>
|
||||
#include <sys/types.h>
|
||||
|
@ -42,14 +50,30 @@
|
|||
|
||||
#include "ctree.h"
|
||||
#include "disk-io.h"
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -26,7 +26,7 @@ TESTS = fsck-tests.sh convert-tests.sh
|
||||
INSTALL = install
|
||||
prefix ?= /usr/local
|
||||
bindir = $(prefix)/bin
|
||||
-lib_LIBS = -luuid -lblkid -lm -lz -llzo2 -L.
|
||||
+lib_LIBS = -lattr -luuid -lblkid -lm -lz -llzo2 -L.
|
||||
libdir ?= $(prefix)/lib
|
||||
incdir = $(prefix)/include/btrfs
|
||||
LIBS = $(lib_LIBS) $(libs_static)
|
||||
Index: btrfs-progs-v3.19.1/Makefile.in
|
||||
===================================================================
|
||||
--- btrfs-progs-v3.19.1.orig/Makefile.in
|
||||
+++ btrfs-progs-v3.19.1/Makefile.in
|
||||
@@ -21,7 +21,7 @@ CFLAGS = @CFLAGS@ \
|
||||
LDFLAGS = @LDFLAGS@ \
|
||||
-rdynamic
|
||||
|
||||
-LIBS = @UUID_LIBS@ @BLKID_LIBS@ @ZLIB_LIBS@ @LZO2_LIBS@ -L. -pthread
|
||||
+LIBS = @ATTR_LIBS@ @UUID_LIBS@ @BLKID_LIBS@ @ZLIB_LIBS@ @LZO2_LIBS@ -L. -pthread
|
||||
LIBBTRFS_LIBS = $(LIBS)
|
||||
|
||||
# Static compilation flags
|
||||
Index: btrfs-progs-v3.19.1/configure.ac
|
||||
===================================================================
|
||||
--- btrfs-progs-v3.19.1.orig/configure.ac
|
||||
+++ btrfs-progs-v3.19.1/configure.ac
|
||||
@@ -115,6 +115,9 @@ dnl
|
||||
dnl The default PKG_CHECK_MODULES() action-if-not-found is end the
|
||||
dnl execution with error. The static libs are optional.
|
||||
|
||||
+PKG_CHECK_MODULES(ATTR, [libattr])
|
||||
+PKG_STATIC(BLKID_LIBS_STATIC, [libattr])
|
||||
+
|
||||
PKG_CHECK_MODULES(BLKID, [blkid])
|
||||
PKG_STATIC(BLKID_LIBS_STATIC, [blkid])
|
||||
|
||||
|
|
Loading…
Reference in a new issue