jool: Update to 4.0.6
Update jool to te latest stable version (4.0.6). Signed-off-by: Tiago Gaspar <tiagogaspar8@gmail.com>
This commit is contained in:
parent
e239dba400
commit
e64cac5d7b
2 changed files with 2 additions and 26 deletions
|
@ -8,12 +8,12 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=jool
|
||||
PKG_VERSION:=4.0.5
|
||||
PKG_VERSION:=4.0.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/NICMx/Jool/releases/download/v$(PKG_VERSION)
|
||||
PKG_HASH:=b61ae37d7a71e28530765bdfd9a62f89e7878e3ea9c15dabbcefcd144891100d
|
||||
PKG_HASH:=d9314c9de421c1fa854be83ab8ad6b4ad5062a01a9865a97bb87c5850d1c2b2a
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
--- a/src/usr/argp/main.c
|
||||
+++ b/src/usr/argp/main.c
|
||||
@@ -8,6 +8,7 @@
|
||||
#include <errno.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <getopt.h>
|
||||
|
||||
#include "command.h"
|
||||
#include "log.h"
|
||||
--- a/src/usr/iptables/Makefile
|
||||
+++ b/src/usr/iptables/Makefile
|
||||
@@ -34,9 +34,9 @@ uninstall:
|
||||
rm -f ${DESTDIR}${XTABLES_SO_DIR}/libxt_JOOL_SIIT.so
|
||||
rm -f ${DESTDIR}${XTABLES_SO_DIR}/libxt_JOOL.so
|
||||
lib%.so: lib%.o
|
||||
- gcc -shared -fPIC ${LDFLAGS} -o $@ $^;
|
||||
+ ${CC} -shared -fPIC ${LDFLAGS} -o $@ $^;
|
||||
lib%.o: lib%.c
|
||||
- gcc ${DEFAULT_CFLAGS} ${CFLAGS} -D_INIT=lib$*_init -fPIC -c -o $@ $<;
|
||||
+ ${CC} ${DEFAULT_CFLAGS} ${CFLAGS} -D_INIT=lib$*_init -fPIC -c -o $@ $<;
|
||||
clean distclean:
|
||||
rm -f *.so
|
||||
distdir:
|
Loading…
Reference in a new issue