Merge pull request #5233 from wigyori/for-15.05-bind
CC: bind: bump to 9.11.2
This commit is contained in:
commit
e5f16da2ec
5 changed files with 120 additions and 69 deletions
|
@ -1,6 +1,6 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006-2012 OpenWrt.org
|
# Copyright (C) 2006-2012 OpenWrt.org
|
||||||
# 2014 Noah Meyerhans <frodo@morgul.net>
|
# 2014-2016 Noah Meyerhans <frodo@morgul.net>
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -9,7 +9,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=bind
|
PKG_NAME:=bind
|
||||||
PKG_VERSION:=9.9.8-P3
|
PKG_VERSION:=9.11.2
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
USERID:=bind=57:bind=57
|
USERID:=bind=57:bind=57
|
||||||
|
|
||||||
|
@ -18,14 +18,15 @@ PKG_LICENSE := BSD-3-Clause
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
|
http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION) \
|
||||||
http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
|
http://ftp.isc.org/isc/bind9/$(PKG_VERSION)
|
||||||
PKG_MD5SUM:=30b9bf88a78eee783d3fef5257445788
|
PKG_MD5SUM:=efca7e5a63a07efba264da9be2fbb57f
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
|
PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
PKG_USE_MIPS16:=0
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -41,7 +42,7 @@ endef
|
||||||
define Package/bind-libs
|
define Package/bind-libs
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
DEPENDS:=+libopenssl
|
DEPENDS:=+libopenssl +zlib
|
||||||
TITLE:=bind shared libraries
|
TITLE:=bind shared libraries
|
||||||
URL:=https://www.isc.org/software/bind
|
URL:=https://www.isc.org/software/bind
|
||||||
endef
|
endef
|
||||||
|
@ -73,7 +74,7 @@ endef
|
||||||
|
|
||||||
define Package/bind-dnssec
|
define Package/bind-dnssec
|
||||||
$(call Package/bind/Default)
|
$(call Package/bind/Default)
|
||||||
TITLE+= administration tools (dnssec-keygen and dnssec-signzone only)
|
TITLE+= administration tools (dnssec-keygen, dnssec-settime and dnssec-signzone only)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/bind-host
|
define Package/bind-host
|
||||||
|
@ -95,6 +96,7 @@ CONFIGURE_ARGS += \
|
||||||
--disable-threads \
|
--disable-threads \
|
||||||
--disable-linux-caps \
|
--disable-linux-caps \
|
||||||
--with-openssl="$(STAGING_DIR)/usr" \
|
--with-openssl="$(STAGING_DIR)/usr" \
|
||||||
|
--with-libjson=no \
|
||||||
--with-libtool \
|
--with-libtool \
|
||||||
--with-libxml2=no \
|
--with-libxml2=no \
|
||||||
--enable-epoll=yes \
|
--enable-epoll=yes \
|
||||||
|
@ -102,6 +104,7 @@ CONFIGURE_ARGS += \
|
||||||
--with-gssapi=no \
|
--with-gssapi=no \
|
||||||
--with-ecdsa=no \
|
--with-ecdsa=no \
|
||||||
--with-readline=no
|
--with-readline=no
|
||||||
|
--sysconfdir=/etc/bind
|
||||||
|
|
||||||
CONFIGURE_VARS += \
|
CONFIGURE_VARS += \
|
||||||
BUILD_CC="$(TARGET_CC)" \
|
BUILD_CC="$(TARGET_CC)" \
|
||||||
|
@ -158,6 +161,7 @@ define Package/bind-tools/install
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/host $(1)/usr/bin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/host $(1)/usr/bin/
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-keygen $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-keygen $(1)/usr/sbin/
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-settime $(1)/usr/sbin/
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-signzone $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-signzone $(1)/usr/sbin/
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/named-checkconf $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/named-checkconf $(1)/usr/sbin/
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/named-checkzone $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/named-checkzone $(1)/usr/sbin/
|
||||||
|
@ -180,6 +184,7 @@ endef
|
||||||
define Package/bind-dnssec/install
|
define Package/bind-dnssec/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-keygen $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-keygen $(1)/usr/sbin/
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-settime $(1)/usr/sbin/
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-signzone $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dnssec-signzone $(1)/usr/sbin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
|
|
@ -1,45 +1,90 @@
|
||||||
|
; This file holds the information on root name servers needed to
|
||||||
; <<>> DiG 9.2.3 <<>> ns . @a.root-servers.net.
|
; initialize cache of Internet domain name servers
|
||||||
;; global options: printcmd
|
; (e.g. reference this file in the "cache . <file>"
|
||||||
;; Got answer:
|
; configuration file of BIND domain name servers).
|
||||||
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18944
|
;
|
||||||
;; flags: qr aa rd; QUERY: 1, ANSWER: 13, AUTHORITY: 0, ADDITIONAL: 13
|
; This file is made available by InterNIC
|
||||||
|
; under anonymous FTP as
|
||||||
;; QUESTION SECTION:
|
; file /domain/named.cache
|
||||||
;. IN NS
|
; on server FTP.INTERNIC.NET
|
||||||
|
; -OR- RS.INTERNIC.NET
|
||||||
;; ANSWER SECTION:
|
;
|
||||||
. 518400 IN NS A.ROOT-SERVERS.NET.
|
; last update: February 17, 2016
|
||||||
. 518400 IN NS B.ROOT-SERVERS.NET.
|
; related version of root zone: 2016021701
|
||||||
. 518400 IN NS C.ROOT-SERVERS.NET.
|
;
|
||||||
. 518400 IN NS D.ROOT-SERVERS.NET.
|
; formerly NS.INTERNIC.NET
|
||||||
. 518400 IN NS E.ROOT-SERVERS.NET.
|
;
|
||||||
. 518400 IN NS F.ROOT-SERVERS.NET.
|
. 3600000 NS A.ROOT-SERVERS.NET.
|
||||||
. 518400 IN NS G.ROOT-SERVERS.NET.
|
A.ROOT-SERVERS.NET. 3600000 A 198.41.0.4
|
||||||
. 518400 IN NS H.ROOT-SERVERS.NET.
|
A.ROOT-SERVERS.NET. 3600000 AAAA 2001:503:ba3e::2:30
|
||||||
. 518400 IN NS I.ROOT-SERVERS.NET.
|
;
|
||||||
. 518400 IN NS J.ROOT-SERVERS.NET.
|
; FORMERLY NS1.ISI.EDU
|
||||||
. 518400 IN NS K.ROOT-SERVERS.NET.
|
;
|
||||||
. 518400 IN NS L.ROOT-SERVERS.NET.
|
. 3600000 NS B.ROOT-SERVERS.NET.
|
||||||
. 518400 IN NS M.ROOT-SERVERS.NET.
|
B.ROOT-SERVERS.NET. 3600000 A 192.228.79.201
|
||||||
|
B.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:84::b
|
||||||
;; ADDITIONAL SECTION:
|
;
|
||||||
A.ROOT-SERVERS.NET. 3600000 IN A 198.41.0.4
|
; FORMERLY C.PSI.NET
|
||||||
B.ROOT-SERVERS.NET. 3600000 IN A 192.228.79.201
|
;
|
||||||
C.ROOT-SERVERS.NET. 3600000 IN A 192.33.4.12
|
. 3600000 NS C.ROOT-SERVERS.NET.
|
||||||
D.ROOT-SERVERS.NET. 3600000 IN A 128.8.10.90
|
C.ROOT-SERVERS.NET. 3600000 A 192.33.4.12
|
||||||
E.ROOT-SERVERS.NET. 3600000 IN A 192.203.230.10
|
C.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:2::c
|
||||||
F.ROOT-SERVERS.NET. 3600000 IN A 192.5.5.241
|
;
|
||||||
G.ROOT-SERVERS.NET. 3600000 IN A 192.112.36.4
|
; FORMERLY TERP.UMD.EDU
|
||||||
H.ROOT-SERVERS.NET. 3600000 IN A 128.63.2.53
|
;
|
||||||
I.ROOT-SERVERS.NET. 3600000 IN A 192.36.148.17
|
. 3600000 NS D.ROOT-SERVERS.NET.
|
||||||
J.ROOT-SERVERS.NET. 3600000 IN A 192.58.128.30
|
D.ROOT-SERVERS.NET. 3600000 A 199.7.91.13
|
||||||
K.ROOT-SERVERS.NET. 3600000 IN A 193.0.14.129
|
D.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:2d::d
|
||||||
L.ROOT-SERVERS.NET. 3600000 IN A 199.7.83.42
|
;
|
||||||
M.ROOT-SERVERS.NET. 3600000 IN A 202.12.27.33
|
; FORMERLY NS.NASA.GOV
|
||||||
|
;
|
||||||
;; Query time: 81 msec
|
. 3600000 NS E.ROOT-SERVERS.NET.
|
||||||
;; SERVER: 198.41.0.4#53(a.root-servers.net.)
|
E.ROOT-SERVERS.NET. 3600000 A 192.203.230.10
|
||||||
;; WHEN: Sun Feb 1 11:27:14 2004
|
;
|
||||||
;; MSG SIZE rcvd: 436
|
; FORMERLY NS.ISC.ORG
|
||||||
|
;
|
||||||
|
. 3600000 NS F.ROOT-SERVERS.NET.
|
||||||
|
F.ROOT-SERVERS.NET. 3600000 A 192.5.5.241
|
||||||
|
F.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:2f::f
|
||||||
|
;
|
||||||
|
; FORMERLY NS.NIC.DDN.MIL
|
||||||
|
;
|
||||||
|
. 3600000 NS G.ROOT-SERVERS.NET.
|
||||||
|
G.ROOT-SERVERS.NET. 3600000 A 192.112.36.4
|
||||||
|
;
|
||||||
|
; FORMERLY AOS.ARL.ARMY.MIL
|
||||||
|
;
|
||||||
|
. 3600000 NS H.ROOT-SERVERS.NET.
|
||||||
|
H.ROOT-SERVERS.NET. 3600000 A 198.97.190.53
|
||||||
|
H.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:1::53
|
||||||
|
;
|
||||||
|
; FORMERLY NIC.NORDU.NET
|
||||||
|
;
|
||||||
|
. 3600000 NS I.ROOT-SERVERS.NET.
|
||||||
|
I.ROOT-SERVERS.NET. 3600000 A 192.36.148.17
|
||||||
|
I.ROOT-SERVERS.NET. 3600000 AAAA 2001:7fe::53
|
||||||
|
;
|
||||||
|
; OPERATED BY VERISIGN, INC.
|
||||||
|
;
|
||||||
|
. 3600000 NS J.ROOT-SERVERS.NET.
|
||||||
|
J.ROOT-SERVERS.NET. 3600000 A 192.58.128.30
|
||||||
|
J.ROOT-SERVERS.NET. 3600000 AAAA 2001:503:c27::2:30
|
||||||
|
;
|
||||||
|
; OPERATED BY RIPE NCC
|
||||||
|
;
|
||||||
|
. 3600000 NS K.ROOT-SERVERS.NET.
|
||||||
|
K.ROOT-SERVERS.NET. 3600000 A 193.0.14.129
|
||||||
|
K.ROOT-SERVERS.NET. 3600000 AAAA 2001:7fd::1
|
||||||
|
;
|
||||||
|
; OPERATED BY ICANN
|
||||||
|
;
|
||||||
|
. 3600000 NS L.ROOT-SERVERS.NET.
|
||||||
|
L.ROOT-SERVERS.NET. 3600000 A 199.7.83.42
|
||||||
|
L.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:3::42
|
||||||
|
;
|
||||||
|
; OPERATED BY WIDE
|
||||||
|
;
|
||||||
|
. 3600000 NS M.ROOT-SERVERS.NET.
|
||||||
|
M.ROOT-SERVERS.NET. 3600000 A 202.12.27.33
|
||||||
|
M.ROOT-SERVERS.NET. 3600000 AAAA 2001:dc3::35
|
||||||
|
; End of file
|
||||||
|
|
|
@ -13,7 +13,6 @@ pid_file=/var/run/named/named.pid
|
||||||
logdir=/var/log/named/
|
logdir=/var/log/named/
|
||||||
cachedir=/var/cache/bind
|
cachedir=/var/cache/bind
|
||||||
libdir=/var/lib/bind
|
libdir=/var/lib/bind
|
||||||
config_file=/etc/bind/named.conf
|
|
||||||
|
|
||||||
fix_perms() {
|
fix_perms() {
|
||||||
for dir in $libdir $logdir $cachedir; do
|
for dir in $libdir $logdir $cachedir; do
|
||||||
|
|
|
@ -1,26 +1,26 @@
|
||||||
Index: bind-9.9.4/bin/Makefile.in
|
Index: bind-9.10.4-P3/bin/Makefile.in
|
||||||
===================================================================
|
===================================================================
|
||||||
--- bind-9.9.4.orig/bin/Makefile.in
|
--- bind-9.10.4-P3.orig/bin/Makefile.in
|
||||||
+++ bind-9.9.4/bin/Makefile.in
|
+++ bind-9.10.4-P3/bin/Makefile.in
|
||||||
@@ -19,7 +19,7 @@ srcdir = @srcdir@
|
@@ -10,7 +10,7 @@ srcdir = @srcdir@
|
||||||
VPATH = @srcdir@
|
VPATH = @srcdir@
|
||||||
top_srcdir = @top_srcdir@
|
top_srcdir = @top_srcdir@
|
||||||
|
|
||||||
-SUBDIRS = named rndc dig dnssec tools tests nsupdate \
|
-SUBDIRS = named rndc dig delv dnssec tools tests nsupdate \
|
||||||
+SUBDIRS = named rndc dig dnssec tools nsupdate \
|
+SUBDIRS = named rndc dig delv dnssec tools nsupdate \
|
||||||
check confgen @PYTHON_TOOLS@ @PKCS11_TOOLS@
|
check confgen @NZD_TOOLS@ @PYTHON_TOOLS@ @PKCS11_TOOLS@
|
||||||
TARGETS =
|
TARGETS =
|
||||||
|
|
||||||
Index: bind-9.9.4/lib/Makefile.in
|
Index: bind-9.10.4-P3/lib/Makefile.in
|
||||||
===================================================================
|
===================================================================
|
||||||
--- bind-9.9.4.orig/lib/Makefile.in
|
--- bind-9.10.4-P3.orig/lib/Makefile.in
|
||||||
+++ bind-9.9.4/lib/Makefile.in
|
+++ bind-9.10.4-P3/lib/Makefile.in
|
||||||
@@ -23,7 +23,7 @@ top_srcdir = @top_srcdir@
|
@@ -14,7 +14,7 @@ top_srcdir = @top_srcdir@
|
||||||
# Attempt to disable parallel processing.
|
# Attempt to disable parallel processing.
|
||||||
.NOTPARALLEL:
|
.NOTPARALLEL:
|
||||||
.NO_PARALLEL:
|
.NO_PARALLEL:
|
||||||
-SUBDIRS = isc isccc dns isccfg bind9 lwres tests
|
-SUBDIRS = isc isccc dns isccfg bind9 lwres irs tests samples
|
||||||
+SUBDIRS = isc isccc dns isccfg bind9 lwres
|
+SUBDIRS = isc isccc dns isccfg bind9 lwres irs samples
|
||||||
TARGETS =
|
TARGETS =
|
||||||
|
|
||||||
@BIND9_MAKE_RULES@
|
@BIND9_MAKE_RULES@
|
||||||
|
|
|
@ -1,6 +1,8 @@
|
||||||
--- a/configure.in
|
Index: bind-9.10.4-P3/configure.in
|
||||||
+++ b/configure.in
|
===================================================================
|
||||||
@@ -93,26 +93,11 @@ esac
|
--- bind-9.10.4-P3.orig/configure.in
|
||||||
|
+++ bind-9.10.4-P3/configure.in
|
||||||
|
@@ -157,26 +157,11 @@ esac
|
||||||
#
|
#
|
||||||
AC_CONFIG_FILES([make/rules make/includes])
|
AC_CONFIG_FILES([make/rules make/includes])
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue