git: Update to version 2.23.0
Refresh patches
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
(cherry-picked from commit d8d736711d
)
This commit is contained in:
parent
45f3e75558
commit
e4f1737056
4 changed files with 7 additions and 12 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=git
|
||||
PKG_VERSION:=2.22.0
|
||||
PKG_VERSION:=2.23.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/software/scm/git/
|
||||
PKG_HASH:=159e4b599f8af4612e70b666600a3139541f8bacc18124daf2cbe8d1b934f29f
|
||||
PKG_HASH:=234fa05b6839e92dc300b2dd78c92ec9c0c8d439f65e1d430a7034f60af16067
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -929,7 +929,8 @@ AC_RUN_IFELSE(
|
||||
@@ -952,7 +952,8 @@ AC_RUN_IFELSE(
|
||||
FILE *f = fopen(".", "r");
|
||||
return f != NULL;]])],
|
||||
[ac_cv_fread_reads_directories=no],
|
||||
|
@ -10,7 +10,7 @@
|
|||
])
|
||||
if test $ac_cv_fread_reads_directories = yes; then
|
||||
FREAD_READS_DIRECTORIES=UnfortunatelyYes
|
||||
@@ -963,7 +964,8 @@ AC_RUN_IFELSE(
|
||||
@@ -986,7 +987,8 @@ AC_RUN_IFELSE(
|
||||
if (snprintf(buf, 3, "%s", "12345") != 5
|
||||
|| strcmp(buf, "12")) return 1]])],
|
||||
[ac_cv_snprintf_returns_bogus=no],
|
||||
|
@ -20,7 +20,7 @@
|
|||
])
|
||||
if test $ac_cv_snprintf_returns_bogus = yes; then
|
||||
SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
|
||||
@@ -986,7 +988,8 @@ yippeeyeswehaveit
|
||||
@@ -1009,7 +1011,8 @@ yippeeyeswehaveit
|
||||
#endif
|
||||
]),
|
||||
[ac_cv_sane_mode_bits=yes],
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1312,7 +1312,7 @@ else
|
||||
@@ -1365,7 +1365,7 @@ endif
|
||||
endif
|
||||
curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
|
||||
ifeq "$(curl_check)" "072200"
|
||||
|
|
|
@ -12,11 +12,9 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
|||
imap-send.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/imap-send.c b/imap-send.c
|
||||
index b4eb886e2..877a4e368 100644
|
||||
--- a/imap-send.c
|
||||
+++ b/imap-send.c
|
||||
@@ -284,8 +284,10 @@ static int ssl_socket_connect(struct imap_socket *sock, int use_tls_only, int ve
|
||||
@@ -284,8 +284,10 @@ static int ssl_socket_connect(struct ima
|
||||
int ret;
|
||||
X509 *cert;
|
||||
|
||||
|
@ -27,6 +25,3 @@ index b4eb886e2..877a4e368 100644
|
|||
|
||||
meth = SSLv23_method();
|
||||
if (!meth) {
|
||||
--
|
||||
2.20.1
|
||||
|
||||
|
|
Loading…
Reference in a new issue