boinc: update to 7.16.16
Remove upstreamed patch.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit ce361e3c1a
)
This commit is contained in:
parent
50512fccd1
commit
e3cf0d1218
4 changed files with 6 additions and 37 deletions
|
@ -6,14 +6,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=boinc
|
PKG_NAME:=boinc
|
||||||
PKG_VERSION:=7.16.6
|
PKG_VERSION:=7.16.16
|
||||||
PKG_VERSION_SHORT:=$(shell echo $(PKG_VERSION)| cut -f1,2 -d.)
|
PKG_VERSION_SHORT:=$(shell echo $(PKG_VERSION)| cut -f1,2 -d.)
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE_DATE:=2020-02-25
|
PKG_SOURCE_DATE:=2020-02-25
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/BOINC/boinc/tar.gz/client_release/$(PKG_VERSION_SHORT)/$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/BOINC/boinc/tar.gz/client_release/$(PKG_VERSION_SHORT)/$(PKG_VERSION)?
|
||||||
PKG_HASH:=caa567da8d3eb50859efe2eeba1c23c7b27d3b0f15b548136e75302713b25303
|
PKG_HASH:=0d5656a9f8ed1048936a5764270848b892d63f27bdb863d0ace447f1eaae6002
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-client_release-$(PKG_VERSION_SHORT)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-client_release-$(PKG_VERSION_SHORT)-$(PKG_VERSION)
|
||||||
|
|
||||||
PKG_MAINTAINER:=Christian Dreihsig <christian.dreihsig@t-online.de>, Steffen Moeller <moeller@debian.org>
|
PKG_MAINTAINER:=Christian Dreihsig <christian.dreihsig@t-online.de>, Steffen Moeller <moeller@debian.org>
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -506,8 +506,10 @@ SAH_CHECK_LIB([dl], [dlopen],
|
@@ -502,8 +502,10 @@ SAH_CHECK_LIB([dl], [dlopen],
|
||||||
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
|
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
|
||||||
SAH_CHECK_LIB([nsl], [gethostbyname],
|
SAH_CHECK_LIB([nsl], [gethostbyname],
|
||||||
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
|
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
|
||||||
|
|
|
@ -22,7 +22,7 @@
|
||||||
#if defined(_WIN32) && !defined(__CYGWIN32__)
|
#if defined(_WIN32) && !defined(__CYGWIN32__)
|
||||||
#if defined(_WIN64) && defined(_M_X64)
|
#if defined(_WIN64) && defined(_M_X64)
|
||||||
add_platform("windows_x86_64");
|
add_platform("windows_x86_64");
|
||||||
@@ -206,15 +221,6 @@ void CLIENT_STATE::detect_platforms() {
|
@@ -210,15 +225,6 @@ void CLIENT_STATE::detect_platforms() {
|
||||||
add_platform("i686-pc-linux-gnu");
|
add_platform("i686-pc-linux-gnu");
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -38,7 +38,7 @@
|
||||||
#elif defined(sun)
|
#elif defined(sun)
|
||||||
// Check if we can run 64-bit binaries...
|
// Check if we can run 64-bit binaries...
|
||||||
// this assumes there isn't a 64-bit only solaris. (Every 64-bit solaris can run 32 bit binaries)
|
// this assumes there isn't a 64-bit only solaris. (Every 64-bit solaris can run 32 bit binaries)
|
||||||
@@ -290,6 +296,8 @@ void CLIENT_STATE::detect_platforms() {
|
@@ -294,6 +300,8 @@ void CLIENT_STATE::detect_platforms() {
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
#endif
|
#endif
|
||||||
|
|
|
@ -1,31 +0,0 @@
|
||||||
--- a/lib/crypt.cpp
|
|
||||||
+++ b/lib/crypt.cpp
|
|
||||||
@@ -44,6 +44,7 @@
|
|
||||||
#include <openssl/engine.h>
|
|
||||||
#include <openssl/err.h>
|
|
||||||
#include <openssl/rsa.h>
|
|
||||||
+#include <openssl/bn.h>
|
|
||||||
|
|
||||||
#ifdef _USING_FCGI_
|
|
||||||
#include "boinc_fcgi.h"
|
|
||||||
@@ -720,8 +721,10 @@ char *check_validity(
|
|
||||||
int rbytes;
|
|
||||||
unsigned char md5_md[MD5_DIGEST_LENGTH], rbuf[2048];
|
|
||||||
|
|
||||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(HAVE_LIBRESSL)
|
|
||||||
SSL_load_error_strings();
|
|
||||||
SSL_library_init();
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
if (!is_file(origFile)) {
|
|
||||||
return NULL;
|
|
||||||
@@ -772,7 +775,9 @@ int cert_verify_file(
|
|
||||||
fflush(stdout);
|
|
||||||
return false;
|
|
||||||
}
|
|
||||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(HAVE_LIBRESSL)
|
|
||||||
SSL_library_init();
|
|
||||||
+#endif
|
|
||||||
if (!is_file(origFile)) return false;
|
|
||||||
FILE* of = boinc_fopen(origFile, "r");
|
|
||||||
if (!of) return false;
|
|
Loading…
Reference in a new issue