treewide: remove obsolete references to avr32
This is a long overdue followup commit to openwrt/openwrt@5d9eeab ("build: remove obsolete references to cris and avr32") Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
This commit is contained in:
parent
099d045c7c
commit
e38c100612
6 changed files with 4 additions and 33 deletions
|
@ -30,7 +30,7 @@ define Package/jamvm
|
||||||
CATEGORY:=Languages
|
CATEGORY:=Languages
|
||||||
TITLE:=A compact Java Virtual Machine
|
TITLE:=A compact Java Virtual Machine
|
||||||
URL:=http://sourceforge.net/projects/jamvm
|
URL:=http://sourceforge.net/projects/jamvm
|
||||||
DEPENDS:=+zlib +libpthread +librt +classpath @!avr32
|
DEPENDS:=+zlib +libpthread +librt +classpath
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/jamvm/description
|
define Package/jamvm/description
|
||||||
|
|
|
@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
|
||||||
define Package/fftw3
|
define Package/fftw3
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
DEPENDS:=@!avr32 +libpthread
|
DEPENDS:=+libpthread
|
||||||
VARIANT:=double
|
VARIANT:=double
|
||||||
TITLE:=Fast Fourier transform library
|
TITLE:=Fast Fourier transform library
|
||||||
URL:=http://www.fftw.org/
|
URL:=http://www.fftw.org/
|
||||||
|
|
|
@ -1,20 +0,0 @@
|
||||||
--- a/config/config.sub
|
|
||||||
+++ b/config/config.sub
|
|
||||||
@@ -228,7 +228,7 @@ case $basic_machine in
|
|
||||||
| a29k \
|
|
||||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
|
||||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
|
||||||
- | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
|
|
||||||
+ | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
|
||||||
| c4x | clipper \
|
|
||||||
| d10v | d30v | dlx | dsp16xx \
|
|
||||||
| fr30 | frv \
|
|
||||||
@@ -290,7 +290,7 @@ case $basic_machine in
|
|
||||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
|
||||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
|
||||||
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
|
|
||||||
- | avr-* \
|
|
||||||
+ | avr-* | avr32-* \
|
|
||||||
| bs2000-* \
|
|
||||||
| c[123]* | c30-* | [cjt]90-* | c54x-* \
|
|
||||||
| clipper-* | cydra-* \
|
|
|
@ -29,7 +29,6 @@ define Package/libsndfile
|
||||||
TITLE:=Library for reading/writing audio files
|
TITLE:=Library for reading/writing audio files
|
||||||
URL:=http://www.mega-nerd.com/libsndfile/
|
URL:=http://www.mega-nerd.com/libsndfile/
|
||||||
MAINTAINER:=Peter Wagner <tripolar@gmx.at>
|
MAINTAINER:=Peter Wagner <tripolar@gmx.at>
|
||||||
DEPENDS:=@!avr32
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libsndfile/description
|
define Package/libsndfile/description
|
||||||
|
|
|
@ -100,11 +100,7 @@ ifeq ($(CONFIG_TARGET_x86),y)
|
||||||
ENABLE_REGPARM:=y
|
ENABLE_REGPARM:=y
|
||||||
endif
|
endif
|
||||||
|
|
||||||
ifeq ($(CONFIG_avr32),y)
|
LINUX_TARGET:=linux2628
|
||||||
LINUX_TARGET:=linux26
|
|
||||||
else
|
|
||||||
LINUX_TARGET:=linux2628
|
|
||||||
endif
|
|
||||||
|
|
||||||
ifeq ($(BUILD_VARIANT),ssl)
|
ifeq ($(BUILD_VARIANT),ssl)
|
||||||
ADDON+=USE_OPENSSL=1
|
ADDON+=USE_OPENSSL=1
|
||||||
|
|
|
@ -213,10 +213,6 @@ define Package/collectd/config
|
||||||
select PACKAGE_collectd-mod-network
|
select PACKAGE_collectd-mod-network
|
||||||
endef
|
endef
|
||||||
|
|
||||||
ifneq ($(CONFIG_avr32),)
|
|
||||||
TARGET_CFLAGS += -fsigned-char
|
|
||||||
endif
|
|
||||||
|
|
||||||
# common configure args
|
# common configure args
|
||||||
CONFIGURE_ARGS+= \
|
CONFIGURE_ARGS+= \
|
||||||
--disable-werror \
|
--disable-werror \
|
||||||
|
@ -393,7 +389,7 @@ $(eval $(call BuildPlugin,tail,tail input,tail,))
|
||||||
$(eval $(call BuildPlugin,tail-csv,tail CSV input,tail_csv,))
|
$(eval $(call BuildPlugin,tail-csv,tail CSV input,tail_csv,))
|
||||||
$(eval $(call BuildPlugin,table,table-like structured file input,table,))
|
$(eval $(call BuildPlugin,table,table-like structured file input,table,))
|
||||||
$(eval $(call BuildPlugin,teamspeak2,TeamSpeak2 input,teamspeak2,))
|
$(eval $(call BuildPlugin,teamspeak2,TeamSpeak2 input,teamspeak2,))
|
||||||
$(eval $(call BuildPlugin,ted,The Energy Detective input,ted,@((!TARGET_avr32)||BROKEN))) # fails on avr32 because of warnings treated as errors
|
$(eval $(call BuildPlugin,ted,The Energy Detective input,ted,))
|
||||||
$(eval $(call BuildPlugin,tcpconns,TCP connection tracking input,tcpconns,))
|
$(eval $(call BuildPlugin,tcpconns,TCP connection tracking input,tcpconns,))
|
||||||
$(eval $(call BuildPlugin,thermal,system temperatures input,thermal,))
|
$(eval $(call BuildPlugin,thermal,system temperatures input,thermal,))
|
||||||
$(eval $(call BuildPlugin,unixsock,unix socket output,unixsock,))
|
$(eval $(call BuildPlugin,unixsock,unix socket output,unixsock,))
|
||||||
|
|
Loading…
Reference in a new issue