pixman: initial version 0.34.0
This will be required by qemu 2.11. The two patches are copied from packaging of current qemu 2.6 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
This commit is contained in:
parent
b273818c34
commit
e35e2bf91b
3 changed files with 77 additions and 0 deletions
50
libs/pixman/Makefile
Normal file
50
libs/pixman/Makefile
Normal file
|
@ -0,0 +1,50 @@
|
|||
#
|
||||
# Copyright (C) 2018 Yousong Zhou <yszhou4tech@gmail.com>
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=pixman
|
||||
PKG_VERSION:=0.34.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=21b6b249b51c6800dc9553b65106e1e37d0e25df942c90531d4c3997aa20a88e
|
||||
PKG_SOURCE_URL:=https://www.cairographics.org/releases
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
||||
define Package/pixman
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=a low-level software library for pixel manipulation
|
||||
URL:=http://www.pixman.org/
|
||||
endef
|
||||
|
||||
define Package/pixman/description
|
||||
Pixman is a low-level software library for pixel manipulation, providing
|
||||
features such as image compositing and trapezoid rasterization. Important
|
||||
users of pixman are the cairo graphics library and the X server.
|
||||
endef
|
||||
|
||||
define Package/pixman/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpixman*.so* $(1)/usr/lib
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,pixman))
|
|
@ -0,0 +1,10 @@
|
|||
--- a/configure.ac.orig 2016-11-22 20:44:21.205150763 +0800
|
||||
+++ b/configure.ac 2016-11-22 20:44:55.505161500 +0800
|
||||
@@ -720,7 +720,6 @@ dnl Check if assembler is gas compatible
|
||||
have_mips_dspr2=no
|
||||
AC_MSG_CHECKING(whether to use MIPS DSPr2 assembler)
|
||||
xserver_save_CFLAGS=$CFLAGS
|
||||
-CFLAGS="-mdspr2 $CFLAGS"
|
||||
|
||||
AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
|
||||
#if !(defined(__mips__) && __mips_isa_rev >= 2)
|
17
libs/pixman/patches/0005-pixman-arm-neon-assembler-fix.patch
Normal file
17
libs/pixman/patches/0005-pixman-arm-neon-assembler-fix.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- a/pixman/pixman-private.h.orig 2016-11-22 22:10:33.574769654 +0800
|
||||
+++ b/pixman/pixman-private.h 2016-11-22 22:10:47.638774056 +0800
|
||||
@@ -1,5 +1,3 @@
|
||||
-#include <float.h>
|
||||
-
|
||||
#ifndef PIXMAN_PRIVATE_H
|
||||
#define PIXMAN_PRIVATE_H
|
||||
|
||||
@@ -17,6 +15,8 @@
|
||||
|
||||
#ifndef __ASSEMBLER__
|
||||
|
||||
+#include <float.h>
|
||||
+
|
||||
#ifndef PACKAGE
|
||||
# error config.h must be included before pixman-private.h
|
||||
#endif
|
Loading…
Reference in a new issue