python: Update to 2.7.18, refresh patches
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
0d795d2028
commit
e34d0baee9
4 changed files with 6 additions and 20 deletions
|
@ -6,7 +6,7 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PYTHON_VERSION:=2.7
|
PYTHON_VERSION:=2.7
|
||||||
PYTHON_VERSION_MICRO:=17
|
PYTHON_VERSION_MICRO:=18
|
||||||
|
|
||||||
PYTHON_SETUPTOOLS_PKG_RELEASE:=1
|
PYTHON_SETUPTOOLS_PKG_RELEASE:=1
|
||||||
PYTHON_PIP_PKG_RELEASE:=2
|
PYTHON_PIP_PKG_RELEASE:=2
|
||||||
|
|
|
@ -12,11 +12,11 @@ include ../python-version.mk
|
||||||
|
|
||||||
PKG_NAME:=python
|
PKG_NAME:=python
|
||||||
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
|
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
|
||||||
PKG_HASH:=4d43f033cdbd0aa7b7023c81b0e986fd11e653b5248dac9144d508f11812ba41
|
PKG_HASH:=b62c0e7937551d0cc02b8fd5cb0f544f9405bafc9a54d3808ed4594812edef43
|
||||||
|
|
||||||
PKG_LICENSE:=Python/2.0
|
PKG_LICENSE:=Python/2.0
|
||||||
PKG_LICENSE_FILES:=LICENSE Doc/copyright.rst Doc/license.rst Modules/_ctypes/darwin/LICENSE Modules/_ctypes/libffi/LICENSE Modules/_ctypes/libffi_osx/LICENSE Modules/expat/COPYING
|
PKG_LICENSE_FILES:=LICENSE Doc/copyright.rst Doc/license.rst Modules/_ctypes/darwin/LICENSE Modules/_ctypes/libffi/LICENSE Modules/_ctypes/libffi_osx/LICENSE Modules/expat/COPYING
|
||||||
|
|
|
@ -17,20 +17,15 @@ RFC because this doesn't yet handle the weird ancient ARMv4 OABI 'mixed-endian'
|
||||||
create mode 100644 Misc/NEWS.d/next/Build/2018-09-18-16-28-31.bpo-34585.CGMu0h.rst
|
create mode 100644 Misc/NEWS.d/next/Build/2018-09-18-16-28-31.bpo-34585.CGMu0h.rst
|
||||||
create mode 100644 m4/ax_c_float_words_bigendian.m4
|
create mode 100644 m4/ax_c_float_words_bigendian.m4
|
||||||
|
|
||||||
diff --git a/Misc/NEWS.d/next/Build/2018-09-18-16-28-31.bpo-34585.CGMu0h.rst b/Misc/NEWS.d/next/Build/2018-09-18-16-28-31.bpo-34585.CGMu0h.rst
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000000000..01318e6e46a32
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/Misc/NEWS.d/next/Build/2018-09-18-16-28-31.bpo-34585.CGMu0h.rst
|
+++ b/Misc/NEWS.d/next/Build/2018-09-18-16-28-31.bpo-34585.CGMu0h.rst
|
||||||
@@ -0,0 +1,3 @@
|
@@ -0,0 +1,3 @@
|
||||||
+Check for floating-point byte order in configure.ac using compilation tests
|
+Check for floating-point byte order in configure.ac using compilation tests
|
||||||
+instead of executing code, so that these checks work in cross-compiled
|
+instead of executing code, so that these checks work in cross-compiled
|
||||||
+builds.
|
+builds.
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 03638f8ae9bc7..96331ec221be2 100644
|
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -4206,74 +4206,24 @@ fi
|
@@ -3862,74 +3862,24 @@ fi],
|
||||||
# * Check for various properties of floating point *
|
# * Check for various properties of floating point *
|
||||||
# **************************************************
|
# **************************************************
|
||||||
|
|
||||||
|
@ -118,9 +113,6 @@ index 03638f8ae9bc7..96331ec221be2 100644
|
||||||
AC_DEFINE(DOUBLE_IS_ARM_MIXED_ENDIAN_IEEE754, 1,
|
AC_DEFINE(DOUBLE_IS_ARM_MIXED_ENDIAN_IEEE754, 1,
|
||||||
[Define if C doubles are 64-bit IEEE 754 binary format, stored
|
[Define if C doubles are 64-bit IEEE 754 binary format, stored
|
||||||
in ARM mixed-endian order (byte order 45670123)])
|
in ARM mixed-endian order (byte order 45670123)])
|
||||||
diff --git a/m4/ax_c_float_words_bigendian.m4 b/m4/ax_c_float_words_bigendian.m4
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000000000..216b90d803187
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/m4/ax_c_float_words_bigendian.m4
|
+++ b/m4/ax_c_float_words_bigendian.m4
|
||||||
@@ -0,0 +1,83 @@
|
@@ -0,0 +1,83 @@
|
||||||
|
|
|
@ -10,8 +10,6 @@ Follow up to 2a9c3805ddedf282881ef7811a561c70b74f80b1 (bpo-34585).
|
||||||
pyconfig.h.in | 4 ++
|
pyconfig.h.in | 4 ++
|
||||||
3 files changed, 51 insertions(+), 100 deletions(-)
|
3 files changed, 51 insertions(+), 100 deletions(-)
|
||||||
|
|
||||||
diff --git a/aclocal.m4 b/aclocal.m4
|
|
||||||
index 6a24d8e6b9c00..030e6877de9f7 100644
|
|
||||||
--- a/aclocal.m4
|
--- a/aclocal.m4
|
||||||
+++ b/aclocal.m4
|
+++ b/aclocal.m4
|
||||||
@@ -288,3 +288,4 @@ AS_VAR_COPY([$1], [pkg_cv_][$1])
|
@@ -288,3 +288,4 @@ AS_VAR_COPY([$1], [pkg_cv_][$1])
|
||||||
|
@ -19,11 +17,9 @@ index 6a24d8e6b9c00..030e6877de9f7 100644
|
||||||
])dnl PKG_CHECK_VAR
|
])dnl PKG_CHECK_VAR
|
||||||
|
|
||||||
+m4_include([m4/ax_c_float_words_bigendian.m4])
|
+m4_include([m4/ax_c_float_words_bigendian.m4])
|
||||||
diff --git a/configure b/configure
|
|
||||||
index 7b0c734b5e25e..38546d6ca7b40 100755
|
|
||||||
--- a/configure
|
--- a/configure
|
||||||
+++ b/configure
|
+++ b/configure
|
||||||
@@ -13853,131 +13853,77 @@ fi
|
@@ -13022,131 +13022,77 @@ fi
|
||||||
# * Check for various properties of floating point *
|
# * Check for various properties of floating point *
|
||||||
# **************************************************
|
# **************************************************
|
||||||
|
|
||||||
|
@ -201,11 +197,9 @@ index 7b0c734b5e25e..38546d6ca7b40 100755
|
||||||
|
|
||||||
$as_echo "#define DOUBLE_IS_ARM_MIXED_ENDIAN_IEEE754 1" >>confdefs.h
|
$as_echo "#define DOUBLE_IS_ARM_MIXED_ENDIAN_IEEE754 1" >>confdefs.h
|
||||||
|
|
||||||
diff --git a/pyconfig.h.in b/pyconfig.h.in
|
|
||||||
index 360f79994fafe..41e0479cad2e3 100644
|
|
||||||
--- a/pyconfig.h.in
|
--- a/pyconfig.h.in
|
||||||
+++ b/pyconfig.h.in
|
+++ b/pyconfig.h.in
|
||||||
@@ -30,6 +30,10 @@
|
@@ -36,6 +36,10 @@
|
||||||
/* Define if --enable-ipv6 is specified */
|
/* Define if --enable-ipv6 is specified */
|
||||||
#undef ENABLE_IPV6
|
#undef ENABLE_IPV6
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue