From e2af11adeb15df8972c91e120a7d66e8eb2f5d07 Mon Sep 17 00:00:00 2001
From: Dirk Brenken <dev@brenken.org>
Date: Thu, 29 Jun 2017 12:57:15 +0200
Subject: [PATCH] adblock: update 2.8.1

* revert 'wan6' interface trigger in default config
  due to current procd limitation (see: #4521)

Signed-off-by: Dirk Brenken <dev@brenken.org>
---
 net/adblock/Makefile           | 4 ++--
 net/adblock/files/adblock.conf | 2 +-
 net/adblock/files/adblock.sh   | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index 40e8987d0..5141a7607 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -6,8 +6,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
-PKG_VERSION:=2.8.0
-PKG_RELEASE:=2
+PKG_VERSION:=2.8.1
+PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
 
diff --git a/net/adblock/files/adblock.conf b/net/adblock/files/adblock.conf
index 6386f40b6..c26fb9e27 100644
--- a/net/adblock/files/adblock.conf
+++ b/net/adblock/files/adblock.conf
@@ -6,7 +6,7 @@ config adblock 'global'
 	option adb_debug '0'
 	option adb_forcesrt '0'
 	option adb_forcedns '0'
-	option adb_iface 'wan wan6'
+	option adb_iface 'wan'
 	option adb_triggerdelay '2'
 	option adb_whitelist '/etc/adblock/adblock.whitelist'
 	option adb_whitelist_rset '\$1 ~/^([A-Za-z0-9_-]+\.){1,}[A-Za-z]+/{print tolower(\"^\"\$1\"\\\|[.]\"\$1)}'
diff --git a/net/adblock/files/adblock.sh b/net/adblock/files/adblock.sh
index 29ac6d2ef..04c19066b 100755
--- a/net/adblock/files/adblock.sh
+++ b/net/adblock/files/adblock.sh
@@ -10,7 +10,7 @@
 #
 LC_ALL=C
 PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-adb_ver="2.8.0-2"
+adb_ver="2.8.1"
 adb_sysver="$(ubus -S call system board | jsonfilter -e '@.release.description')"
 adb_enabled=1
 adb_debug=0