netifyd: fix compilation with libcxx

Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
Rosen Penev 2020-03-17 16:23:27 -07:00
parent cc8901117d
commit e26b81d184
No known key found for this signature in database
GPG key ID: 36D31CFA845F0E3B
2 changed files with 12 additions and 1 deletions

View file

@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifyd
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_MAINTAINER:=Darryl Sokoloski <darryl@egloo.ca>
PKG_LICENSE:=GPL-3.0-or-later

View file

@ -0,0 +1,11 @@
--- a/src/nd-netlink.cpp
+++ b/src/nd-netlink.cpp
@@ -144,7 +144,7 @@ ndNetlink::ndNetlink(const nd_ifaces &ifaces)
throw ndNetlinkException(strerror(rc));
}
- if (bind(nd,
+ if (::bind(nd,
(struct sockaddr *)&sa, sizeof(struct sockaddr_nl)) < 0) {
rc = errno;
nd_printf("Error binding netlink socket: %s\n", strerror(rc));