commit
e25be7ff2e
2 changed files with 41 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=gpsd
|
||||
PKG_VERSION:=3.17
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
|
||||
|
|
40
utils/gpsd/patches/010-musl.patch
Normal file
40
utils/gpsd/patches/010-musl.patch
Normal file
|
@ -0,0 +1,40 @@
|
|||
--- a/driver_ais.c
|
||||
+++ b/driver_ais.c
|
||||
@@ -24,6 +24,7 @@
|
||||
|
||||
/* strlcpy() needs _DARWIN_C_SOURCE */
|
||||
#define _DARWIN_C_SOURCE
|
||||
+#define _BSD_SOURCE
|
||||
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
--- a/gpsctl.c
|
||||
+++ b/gpsctl.c
|
||||
@@ -15,6 +15,7 @@
|
||||
|
||||
/* strlcpy() needs _DARWIN_C_SOURCE */
|
||||
#define _DARWIN_C_SOURCE
|
||||
+#define _BSD_SOURCE
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
--- a/gpsd_json.c
|
||||
+++ b/gpsd_json.c
|
||||
@@ -24,6 +24,7 @@ PERMISSIONS
|
||||
#define __DARWIN_C_LEVEL 200112L
|
||||
/* strlcpy() needs _DARWIN_C_SOURCE */
|
||||
#define _DARWIN_C_SOURCE
|
||||
+#define _BSD_SOURCE
|
||||
|
||||
#include <stdio.h>
|
||||
#include <math.h>
|
||||
--- a/libgpsd_core.c
|
||||
+++ b/libgpsd_core.c
|
||||
@@ -20,6 +20,7 @@
|
||||
|
||||
/* strlcpy() needs _DARWIN_C_SOURCE */
|
||||
#define _DARWIN_C_SOURCE
|
||||
+#define _BSD_SOURCE
|
||||
|
||||
#include <time.h>
|
||||
#include <stdio.h>
|
Loading…
Reference in a new issue