knxd: new upstream version 0.14.50
Signed-off-by: Othmar Truniger <github@truniger.ch>
This commit is contained in:
parent
b559ce3f4e
commit
e236ffb2ce
3 changed files with 7 additions and 31 deletions
|
@ -11,12 +11,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=knxd
|
PKG_NAME:=knxd
|
||||||
PKG_VERSION:=0.14.39
|
PKG_VERSION:=0.14.50
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/knxd/knxd/tar.gz/$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/knxd/knxd/tar.gz/$(PKG_VERSION)?
|
||||||
PKG_HASH:=9ed920fa3c4f12ededd4d413f27f149c91ce0846c561a7d19478502c06ac95f1
|
PKG_HASH:=c9189dc0b05b208b06be311d2792ce11092aee8d51d04083568ae49bd10b7cd8
|
||||||
|
|
||||||
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
|
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
|
||||||
PKG_LICENSE:=GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
|
|
|
@ -1,8 +1,9 @@
|
||||||
--- a/tools/version.sh
|
--- a/tools/version.sh
|
||||||
+++ b/tools/version.sh
|
+++ b/tools/version.sh
|
||||||
@@ -1,4 +1,3 @@
|
@@ -1,5 +1,3 @@
|
||||||
#!/bin/sh
|
#!/bin/sh
|
||||||
|
|
||||||
-test -d .git || exit
|
-test -d .git || exit
|
||||||
-git describe --tags
|
-# git describe --tags
|
||||||
+echo -n "0.14.39"
|
-git log --format=format:%D | perl -ne 'next unless s#.*tag: ##; s#,.*##; next if m#/#; print; exit;'
|
||||||
|
+echo -n "0.14.50"
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
--- a/src/include/eibclient.h
|
|
||||||
+++ b/src/include/eibclient.h
|
|
||||||
@@ -27,10 +27,11 @@
|
|
||||||
#ifndef EIBCLIENT_H
|
|
||||||
#define EIBCLIENT_H
|
|
||||||
|
|
||||||
-#include <sys/cdefs.h>
|
|
||||||
#include <stdint.h>
|
|
||||||
|
|
||||||
-__BEGIN_DECLS;
|
|
||||||
+#ifdef __cplusplus
|
|
||||||
+extern "C" {
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#include "eibloadresult.h"
|
|
||||||
|
|
||||||
@@ -935,5 +936,7 @@ int EIB_Cache_LastUpdates2_async (EIBCon
|
|
||||||
uint32_t * end);
|
|
||||||
|
|
||||||
|
|
||||||
-__END_DECLS
|
|
||||||
+#ifdef __cplusplus
|
|
||||||
+}
|
|
||||||
+#endif
|
|
||||||
#endif
|
|
Loading…
Reference in a new issue