lm-sensors: update to 3.5.0
Also switch to GitHub tarball Removed upstreamed patch Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
This commit is contained in:
parent
1f0a005722
commit
e23379746f
2 changed files with 9 additions and 53 deletions
|
@ -8,15 +8,15 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lm-sensors
|
||||
PKG_VERSION:=3.3.5
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=3.5.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_VERSION_SUBST=$(subst .,-,$(PKG_VERSION))
|
||||
PKG_SOURCE_URL:=https://github.com/lm-sensors/lm-sensors/archive/V$(PKG_VERSION_SUBST)/lm-sensors
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=f671c1d63a4cd8581b3a4a775fd7864a740b15ad046fe92038bcff5c5134d7e0
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION_SUBST)
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/groeck/lm-sensors.git
|
||||
PKG_SOURCE_VERSION:=f8cdcc35bff0785aecf49d9a8484a71ce3ebee4f
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_MIRROR_HASH:=892e9e2eed78e27fb7a08e8ce78b1164a3d101ba79a9e04f1c1273940d48cf17
|
||||
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
|
||||
PKG_LICENSE:=GPL-2.0+ LGPL-2.1+
|
||||
|
||||
|
@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
|
|||
|
||||
define Package/lm-sensors/Default
|
||||
DEPENDS:=+sysfsutils
|
||||
URL:=http://www.lm-sensors.org/
|
||||
URL:=https://hwmon.wiki.kernel.org/lm_sensors
|
||||
endef
|
||||
|
||||
define Package/lm-sensors
|
||||
|
|
|
@ -1,44 +0,0 @@
|
|||
--- a/prog/dump/isadump.c
|
||||
+++ b/prog/dump/isadump.c
|
||||
@@ -38,7 +38,7 @@
|
||||
|
||||
|
||||
/* To keep glibc2 happy */
|
||||
-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
|
||||
+#if !defined(__UCLIBC__)
|
||||
#include <sys/io.h>
|
||||
#else
|
||||
#include <asm/io.h>
|
||||
--- a/prog/dump/isaset.c
|
||||
+++ b/prog/dump/isaset.c
|
||||
@@ -34,7 +34,7 @@
|
||||
|
||||
|
||||
/* To keep glibc2 happy */
|
||||
-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
|
||||
+#if !defined(__UCLIBC__)
|
||||
#include <sys/io.h>
|
||||
#else
|
||||
#include <asm/io.h>
|
||||
--- a/prog/dump/superio.c
|
||||
+++ b/prog/dump/superio.c
|
||||
@@ -21,7 +21,7 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
|
||||
-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
|
||||
+#if !defined(__UCLIBC__)
|
||||
#include <sys/io.h>
|
||||
#else
|
||||
#include <asm/io.h>
|
||||
--- a/prog/dump/util.c
|
||||
+++ b/prog/dump/util.c
|
||||
@@ -12,7 +12,7 @@
|
||||
#include "util.h"
|
||||
|
||||
/* To keep glibc2 happy */
|
||||
-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
|
||||
+#if !defined(__UCLIBC__)
|
||||
#include <sys/io.h>
|
||||
#else
|
||||
#include <asm/io.h>
|
Loading…
Reference in a new issue