libcanfestival: fix build on LEDE buildbots using ccache
The previous attempt to fix the build error was not successfull and introduced needlessly a new patch. However, the configure already provide the required functionality, use it instead. This should now really solve the build. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
parent
6695e1be7e
commit
e1c004dcaa
2 changed files with 2 additions and 32 deletions
|
@ -8,7 +8,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libcanfestival
|
PKG_NAME:=libcanfestival
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=hg
|
PKG_SOURCE_PROTO:=hg
|
||||||
PKG_SOURCE_URL:=http://dev.automforge.net/CanFestival-3
|
PKG_SOURCE_URL:=http://dev.automforge.net/CanFestival-3
|
||||||
|
@ -44,6 +44,7 @@ CONFIGURE_ARGS := \
|
||||||
--cxx=$(TARGET_CXX) \
|
--cxx=$(TARGET_CXX) \
|
||||||
--ld=$(TARGET_CC) \
|
--ld=$(TARGET_CC) \
|
||||||
--arch=$(ARCH) \
|
--arch=$(ARCH) \
|
||||||
|
--binutils=$(TARGET_CROSS) \
|
||||||
--os=Linux \
|
--os=Linux \
|
||||||
--kerneldir=$(LINUX_DIR) \
|
--kerneldir=$(LINUX_DIR) \
|
||||||
--prefix=/usr \
|
--prefix=/usr \
|
||||||
|
|
|
@ -1,31 +0,0 @@
|
||||||
--- a/src/Makefile.in
|
|
||||||
+++ b/src/Makefile.in
|
|
||||||
@@ -38,6 +38,9 @@ TARGET = SUB_TARGET
|
|
||||||
CAN_DRIVER = SUB_CAN_DRIVER
|
|
||||||
TIMERS_DRIVER = SUB_TIMERS_DRIVER
|
|
||||||
ENABLE_LSS = SUB_ENABLE_LSS
|
|
||||||
+AR ?= $(BINUTILS_PREFIX)ar
|
|
||||||
+RANLIB ?= $(BINUTILS_PREFIX)ranlib
|
|
||||||
+LD ?= $(BINUTILS_PREFIX)ld
|
|
||||||
|
|
||||||
INCLUDES = -I../include -I../include/$(TARGET) -I../include/$(TIMERS_DRIVER) -I../drivers/$(TARGET)
|
|
||||||
|
|
||||||
@@ -114,15 +117,15 @@ libcanfestival.a: $(OBJS)
|
|
||||||
@echo "*********************************************"
|
|
||||||
@echo "**Building [libcanfestival.a]"
|
|
||||||
@echo "*********************************************"
|
|
||||||
- $(BINUTILS_PREFIX)ar rc $@ $(OBJS)
|
|
||||||
- $(BINUTILS_PREFIX)ranlib $@
|
|
||||||
+ $(AR) rc $@ $(OBJS)
|
|
||||||
+ $(RANLIB) $@
|
|
||||||
|
|
||||||
libcanfestival.o: $(OBJS)
|
|
||||||
@echo " "
|
|
||||||
@echo "*********************************************"
|
|
||||||
@echo "**Prelink [libcanfestival.o]"
|
|
||||||
@echo "*********************************************"
|
|
||||||
- $(BINUTILS_PREFIX)ld -r $(OBJS) -o $@
|
|
||||||
+ $(LD) -r $(OBJS) -o $@
|
|
||||||
|
|
||||||
$(TARGET)_%.o: %.c
|
|
||||||
@echo " "
|
|
Loading…
Reference in a new issue