php7: update to 7.2.15
Also refresh patch which does not apply cleanly anymore. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
parent
fb209cf568
commit
e148924a4c
2 changed files with 8 additions and 25 deletions
|
@ -6,7 +6,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=php
|
PKG_NAME:=php
|
||||||
PKG_VERSION:=7.2.14
|
PKG_VERSION:=7.2.15
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
||||||
|
@ -16,7 +16,7 @@ PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
||||||
PKG_HASH:=ee3f1cc102b073578a3c53ba4420a76da3d9f0c981c02b1664ae741ca65af84f
|
PKG_HASH:=75e90012faef700dffb29311f3d24fa25f1a5e0f70254a9b8d5c794e25e938ce
|
||||||
|
|
||||||
PKG_FIXUP:=libtool autoreconf
|
PKG_FIXUP:=libtool autoreconf
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -453,7 +453,10 @@ PHP_CHECK_FUNC(gethostname, nsl)
|
@@ -422,7 +422,10 @@ PHP_CHECK_FUNC(gethostname, nsl)
|
||||||
PHP_CHECK_FUNC(gethostbyaddr, nsl)
|
PHP_CHECK_FUNC(gethostbyaddr, nsl)
|
||||||
PHP_CHECK_FUNC(yp_get_default_domain, nsl)
|
PHP_CHECK_FUNC(yp_get_default_domain, nsl)
|
||||||
|
|
||||||
|
@ -27,33 +27,16 @@
|
||||||
PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)
|
PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)
|
||||||
--- a/ext/opcache/config.m4
|
--- a/ext/opcache/config.m4
|
||||||
+++ b/ext/opcache/config.m4
|
+++ b/ext/opcache/config.m4
|
||||||
@@ -227,7 +227,14 @@ AC_TRY_RUN([
|
@@ -261,7 +261,11 @@ AC_TRY_RUN([
|
||||||
|
], [
|
||||||
flock_type=linux
|
flock_type=linux
|
||||||
AC_DEFINE([HAVE_FLOCK_LINUX], [], [Struct flock is Linux-type])
|
AC_DEFINE([HAVE_FLOCK_LINUX], [], [Struct flock is Linux-type])
|
||||||
AC_MSG_RESULT("yes")
|
-], [])
|
||||||
-], AC_MSG_RESULT("no") )
|
|
||||||
+], [
|
|
||||||
+ AC_MSG_RESULT("no")
|
|
||||||
+], [
|
+], [
|
||||||
+ dnl cross-compiling; assume Linux
|
+ dnl cross-compiling; assume Linux
|
||||||
+ flock_type=linux
|
+ flock_type=linux
|
||||||
+ AC_DEFINE([HAVE_FLOCK_LINUX], [], [Struct flock is Linux-type])
|
+ AC_DEFINE([HAVE_FLOCK_LINUX], [], [Struct flock is Linux-type])
|
||||||
+ AC_MSG_RESULT("yes")
|
|
||||||
+])
|
+])
|
||||||
|
fi
|
||||||
|
|
||||||
AC_MSG_CHECKING("whether flock struct is BSD ordered")
|
if test "$flock_type" = "unknown"; then
|
||||||
AC_TRY_RUN([
|
|
||||||
@@ -243,7 +250,12 @@ AC_TRY_RUN([
|
|
||||||
flock_type=bsd
|
|
||||||
AC_DEFINE([HAVE_FLOCK_BSD], [], [Struct flock is BSD-type])
|
|
||||||
AC_MSG_RESULT("yes")
|
|
||||||
-], AC_MSG_RESULT("no") )
|
|
||||||
+], [
|
|
||||||
+ AC_MSG_RESULT("no")
|
|
||||||
+], [
|
|
||||||
+ dnl cross-compiling; assume Linux
|
|
||||||
+ AC_MSG_RESULT("no")
|
|
||||||
+])
|
|
||||||
|
|
||||||
if test "$flock_type" == "unknown"; then
|
|
||||||
AC_MSG_ERROR([Don't know how to define struct flock on this system[,] set --enable-opcache=no])
|
|
||||||
|
|
Loading…
Reference in a new issue