Merge pull request #16097 from neheb/telldus
telldus-core: fix compilation with GCC11
This commit is contained in:
commit
e11af80719
2 changed files with 34 additions and 1 deletions
|
@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=telldus-core
|
PKG_NAME:=telldus-core
|
||||||
PKG_VERSION:=2.1.2
|
PKG_VERSION:=2.1.2
|
||||||
PKG_RELEASE:=6
|
PKG_RELEASE:=7
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://download.telldus.com/TellStick/Software/telldus-core/
|
PKG_SOURCE_URL:=http://download.telldus.com/TellStick/Software/telldus-core/
|
||||||
|
|
33
utils/telldus-core/patches/970-gcc11.patch
Normal file
33
utils/telldus-core/patches/970-gcc11.patch
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
--- a/service/SettingsConfuse.cpp
|
||||||
|
+++ b/service/SettingsConfuse.cpp
|
||||||
|
@@ -42,10 +42,10 @@ Settings::Settings(void) {
|
||||||
|
*/
|
||||||
|
Settings::~Settings(void) {
|
||||||
|
TelldusCore::MutexLocker locker(&mutex);
|
||||||
|
- if (d->cfg > 0) {
|
||||||
|
+ if (d->cfg) {
|
||||||
|
cfg_free(d->cfg);
|
||||||
|
}
|
||||||
|
- if (d->var_cfg > 0) {
|
||||||
|
+ if (d->var_cfg) {
|
||||||
|
cfg_free(d->var_cfg);
|
||||||
|
}
|
||||||
|
delete d;
|
||||||
|
@@ -56,7 +56,7 @@ Settings::~Settings(void) {
|
||||||
|
*/
|
||||||
|
std::wstring Settings::getSetting(const std::wstring &strName) const {
|
||||||
|
TelldusCore::MutexLocker locker(&mutex);
|
||||||
|
- if (d->cfg > 0) {
|
||||||
|
+ if (d->cfg) {
|
||||||
|
std::string setting(cfg_getstr(d->cfg, TelldusCore::wideToString(strName).c_str()));
|
||||||
|
return TelldusCore::charToWstring(setting.c_str());
|
||||||
|
}
|
||||||
|
@@ -68,7 +68,7 @@ std::wstring Settings::getSetting(const
|
||||||
|
*/
|
||||||
|
int Settings::getNumberOfNodes(Node node) const {
|
||||||
|
TelldusCore::MutexLocker locker(&mutex);
|
||||||
|
- if (d->cfg > 0) {
|
||||||
|
+ if (d->cfg) {
|
||||||
|
if (node == Device) {
|
||||||
|
return cfg_size(d->cfg, "device");
|
||||||
|
} else if (node == Controller) {
|
Loading…
Reference in a new issue