Merge pull request #14217 from ClaymorePT/boost_1.75.0
boost: Updates package to version 1.75
This commit is contained in:
commit
e0fa06547c
2 changed files with 8 additions and 74 deletions
|
@ -11,13 +11,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=boost
|
||||
PKG_VERSION:=1.74.0
|
||||
PKG_SOURCE_VERSION:=1_74_0
|
||||
PKG_RELEASE:=6
|
||||
PKG_VERSION:=1.75.0
|
||||
PKG_SOURCE_VERSION:=1_75_0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
|
||||
PKG_HASH:=83bfc1507731a0906e387fc28b7ef5417d591429e51e788417fe9ff025e116b1
|
||||
PKG_HASH:=953db31e016db7bb207f11432bef7df100516eeb746843fa0486a222e3fd49cb
|
||||
|
||||
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
|
||||
PKG_LICENSE:=BSL-1.0
|
||||
|
@ -42,7 +42,7 @@ define Package/boost/Default
|
|||
endef
|
||||
|
||||
define Package/boost/description
|
||||
This package provides the Boost v1.74.0 libraries.
|
||||
This package provides the Boost v1.75.0 libraries.
|
||||
Boost is a set of free, peer-reviewed, portable C++ source libraries.
|
||||
|
||||
This package provides the following run-time libraries:
|
||||
|
@ -59,6 +59,7 @@ This package provides the following run-time libraries:
|
|||
- graph
|
||||
- - graph-parallel
|
||||
- iostreams
|
||||
- json
|
||||
- locale
|
||||
- log
|
||||
- math
|
||||
|
@ -76,7 +77,7 @@ This package provides the following run-time libraries:
|
|||
- wave
|
||||
|
||||
There are many more header-only libraries supported by Boost.
|
||||
See more at http://www.boost.org/doc/libs/1_74_0/
|
||||
See more at http://www.boost.org/doc/libs/1_75_0/
|
||||
endef
|
||||
|
||||
PKG_BUILD_DEPENDS:=boost/host
|
||||
|
@ -344,6 +345,7 @@ $(eval $(call DefineBoostLibrary,fiber,coroutine filesystem,,!boost-fiber-exclud
|
|||
$(eval $(call DefineBoostLibrary,filesystem,system))
|
||||
$(eval $(call DefineBoostLibrary,graph,regex))
|
||||
$(eval $(call DefineBoostLibrary,iostreams,,,,zlib liblzma libbz2 libzstd))
|
||||
$(eval $(call DefineBoostLibrary,json,container))
|
||||
$(eval $(call DefineBoostLibrary,locale,system chrono thread,,,icu))
|
||||
$(eval $(call DefineBoostLibrary,log,system chrono date_time thread filesystem regex))
|
||||
$(eval $(call DefineBoostLibrary,math))
|
||||
|
|
|
@ -1,68 +0,0 @@
|
|||
From 95d82acc57bb7d8bae431f7a6ce0707aac3ef33f Mon Sep 17 00:00:00 2001
|
||||
From: Rosen Penev <rosenp@gmail.com>
|
||||
Date: Thu, 5 Sep 2019 19:41:13 -0700
|
||||
Subject: [PATCH] Use eventfd() function with uClibc
|
||||
|
||||
The Boost eventfd code either directly makes the eventfd system call
|
||||
using __NR_eventfd (when __GLIBC_MINOR is less than 8), or otherwise
|
||||
uses the eventfd() function provided by the C library.
|
||||
|
||||
However, since uClibc pretends to be glibc 2.2, the Boost eventfd code
|
||||
directly uses the system call. While it works fine on most
|
||||
architectures, it doesn't on ARC since __NR_eventfd is not defined on
|
||||
this architecture. However, eventfd() is properly implemented.
|
||||
|
||||
So, this patch adjusts the logic used by Boost to consider uClibc as a
|
||||
C library providing the eventfd() function.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
||||
---
|
||||
a/boost/asio/detail/impl/eventfd_select_interrupter.ipp | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/boost/asio/detail/impl/eventfd_select_interrupter.ipp b/boost/asio/detail/impl/eventfd_select_interrupter.ipp
|
||||
index 38d4b2a61..e16cc8b00 100644
|
||||
--- a/boost/asio/detail/impl/eventfd_select_interrupter.ipp
|
||||
+++ b/boost/asio/detail/impl/eventfd_select_interrupter.ipp
|
||||
@@ -23,11 +23,11 @@
|
||||
#include <sys/stat.h>
|
||||
#include <sys/types.h>
|
||||
#include <fcntl.h>
|
||||
-#if __GLIBC__ == 2 && __GLIBC_MINOR__ < 8
|
||||
+#if __GLIBC__ == 2 && __GLIBC_MINOR__ < 2
|
||||
# include <asm/unistd.h>
|
||||
-#else // __GLIBC__ == 2 && __GLIBC_MINOR__ < 8
|
||||
+#else // __GLIBC__ == 2 && __GLIBC_MINOR__ < 2
|
||||
# include <sys/eventfd.h>
|
||||
-#endif // __GLIBC__ == 2 && __GLIBC_MINOR__ < 8
|
||||
+#endif // __GLIBC__ == 2 && __GLIBC_MINOR__ < 2
|
||||
#include <boost/asio/detail/cstdint.hpp>
|
||||
#include <boost/asio/detail/eventfd_select_interrupter.hpp>
|
||||
#include <boost/asio/detail/throw_error.hpp>
|
||||
@@ -46,14 +46,14 @@ eventfd_select_interrupter::eventfd_select_interrupter()
|
||||
|
||||
void eventfd_select_interrupter::open_descriptors()
|
||||
{
|
||||
-#if __GLIBC__ == 2 && __GLIBC_MINOR__ < 8
|
||||
+#if __GLIBC__ == 2 && __GLIBC_MINOR__ < 2
|
||||
write_descriptor_ = read_descriptor_ = syscall(__NR_eventfd, 0);
|
||||
if (read_descriptor_ != -1)
|
||||
{
|
||||
::fcntl(read_descriptor_, F_SETFL, O_NONBLOCK);
|
||||
::fcntl(read_descriptor_, F_SETFD, FD_CLOEXEC);
|
||||
}
|
||||
-#else // __GLIBC__ == 2 && __GLIBC_MINOR__ < 8
|
||||
+#else // __GLIBC__ == 2 && __GLIBC_MINOR__ < 2
|
||||
# if defined(EFD_CLOEXEC) && defined(EFD_NONBLOCK)
|
||||
write_descriptor_ = read_descriptor_ =
|
||||
::eventfd(0, EFD_CLOEXEC | EFD_NONBLOCK);
|
||||
@@ -70,7 +70,7 @@ void eventfd_select_interrupter::open_descriptors()
|
||||
::fcntl(read_descriptor_, F_SETFD, FD_CLOEXEC);
|
||||
}
|
||||
}
|
||||
-#endif // __GLIBC__ == 2 && __GLIBC_MINOR__ < 8
|
||||
+#endif // __GLIBC__ == 2 && __GLIBC_MINOR__ < 2
|
||||
|
||||
if (read_descriptor_ == -1)
|
||||
{
|
Loading…
Reference in a new issue