commit
e0e997350f
5 changed files with 10 additions and 44 deletions
|
@ -8,14 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libaio
|
PKG_NAME:=libaio
|
||||||
PKG_VERSION:=0.3.111
|
PKG_VERSION:=0.3.112
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://releases.pagure.org/libaio
|
PKG_SOURCE_URL:=https://releases.pagure.org/libaio
|
||||||
PKG_HASH:=62cf871ad8fd09eb3418f00aca7a7d449299b8e1de31c65f28bf6a2ef1fa502a
|
PKG_HASH:=ab0462f2c9d546683e5147b1ce9c195fe95d07fac5bf362f6c01637955c3b492
|
||||||
|
|
||||||
PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
|
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
|
||||||
PKG_LICENSE:=LGPL-2.1-only
|
PKG_LICENSE:=LGPL-2.1-only
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
|
|
|
@ -96,7 +96,7 @@ Last-Update: 2014-10-09
|
||||||
+#endif /* _MIPS_SIM == _MIPS_SIM_NABI32 */
|
+#endif /* _MIPS_SIM == _MIPS_SIM_NABI32 */
|
||||||
--- a/src/libaio.h
|
--- a/src/libaio.h
|
||||||
+++ b/src/libaio.h
|
+++ b/src/libaio.h
|
||||||
@@ -71,6 +71,7 @@ typedef enum io_iocb_cmd {
|
@@ -72,6 +72,7 @@ typedef enum io_iocb_cmd {
|
||||||
|
|
||||||
/* big endian, 64 bits */
|
/* big endian, 64 bits */
|
||||||
#elif defined(__powerpc64__) || defined(__s390x__) || \
|
#elif defined(__powerpc64__) || defined(__s390x__) || \
|
||||||
|
|
|
@ -26,7 +26,7 @@ Description: Add SH supprt
|
||||||
#define KERNEL_RW_POINTER ((void *)0x10100000)
|
#define KERNEL_RW_POINTER ((void *)0x10100000)
|
||||||
--- a/src/libaio.h
|
--- a/src/libaio.h
|
||||||
+++ b/src/libaio.h
|
+++ b/src/libaio.h
|
||||||
@@ -51,7 +51,8 @@ typedef enum io_iocb_cmd {
|
@@ -52,7 +52,8 @@ typedef enum io_iocb_cmd {
|
||||||
|
|
||||||
/* little endian, 32 bits */
|
/* little endian, 32 bits */
|
||||||
#if defined(__i386__) || (defined(__arm__) && !defined(__ARMEB__)) || \
|
#if defined(__i386__) || (defined(__arm__) && !defined(__ARMEB__)) || \
|
||||||
|
@ -36,7 +36,7 @@ Description: Add SH supprt
|
||||||
defined(__cris__) || (defined(__riscv) && __riscv_xlen == 32) || \
|
defined(__cris__) || (defined(__riscv) && __riscv_xlen == 32) || \
|
||||||
(defined(__GNUC__) && defined(__BYTE_ORDER__) && \
|
(defined(__GNUC__) && defined(__BYTE_ORDER__) && \
|
||||||
__BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__ && __SIZEOF_LONG__ == 4)
|
__BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__ && __SIZEOF_LONG__ == 4)
|
||||||
@@ -83,6 +84,7 @@ typedef enum io_iocb_cmd {
|
@@ -84,6 +85,7 @@ typedef enum io_iocb_cmd {
|
||||||
/* big endian, 32 bits */
|
/* big endian, 32 bits */
|
||||||
#elif defined(__PPC__) || defined(__s390__) || \
|
#elif defined(__PPC__) || defined(__s390__) || \
|
||||||
(defined(__arm__) && defined(__ARMEB__)) || \
|
(defined(__arm__) && defined(__ARMEB__)) || \
|
||||||
|
|
|
@ -10,7 +10,7 @@ Last-Update: 2014-07-23
|
||||||
|
|
||||||
--- a/src/libaio.h
|
--- a/src/libaio.h
|
||||||
+++ b/src/libaio.h
|
+++ b/src/libaio.h
|
||||||
@@ -52,7 +52,8 @@ typedef enum io_iocb_cmd {
|
@@ -53,7 +53,8 @@ typedef enum io_iocb_cmd {
|
||||||
/* little endian, 32 bits */
|
/* little endian, 32 bits */
|
||||||
#if defined(__i386__) || (defined(__arm__) && !defined(__ARMEB__)) || \
|
#if defined(__i386__) || (defined(__arm__) && !defined(__ARMEB__)) || \
|
||||||
(defined(__sh__) && defined(__LITTLE_ENDIAN__)) || \
|
(defined(__sh__) && defined(__LITTLE_ENDIAN__)) || \
|
||||||
|
@ -20,7 +20,7 @@ Last-Update: 2014-07-23
|
||||||
defined(__cris__) || (defined(__riscv) && __riscv_xlen == 32) || \
|
defined(__cris__) || (defined(__riscv) && __riscv_xlen == 32) || \
|
||||||
(defined(__GNUC__) && defined(__BYTE_ORDER__) && \
|
(defined(__GNUC__) && defined(__BYTE_ORDER__) && \
|
||||||
__BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__ && __SIZEOF_LONG__ == 4)
|
__BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__ && __SIZEOF_LONG__ == 4)
|
||||||
@@ -62,6 +63,7 @@ typedef enum io_iocb_cmd {
|
@@ -63,6 +64,7 @@ typedef enum io_iocb_cmd {
|
||||||
|
|
||||||
/* little endian, 64 bits */
|
/* little endian, 64 bits */
|
||||||
#elif defined(__ia64__) || defined(__x86_64__) || defined(__alpha__) || \
|
#elif defined(__ia64__) || defined(__x86_64__) || defined(__alpha__) || \
|
||||||
|
@ -28,7 +28,7 @@ Last-Update: 2014-07-23
|
||||||
(defined(__aarch64__) && defined(__AARCH64EL__)) || \
|
(defined(__aarch64__) && defined(__AARCH64EL__)) || \
|
||||||
(defined(__riscv) && __riscv_xlen == 64) || \
|
(defined(__riscv) && __riscv_xlen == 64) || \
|
||||||
(defined(__GNUC__) && defined(__BYTE_ORDER__) && \
|
(defined(__GNUC__) && defined(__BYTE_ORDER__) && \
|
||||||
@@ -74,6 +76,7 @@ typedef enum io_iocb_cmd {
|
@@ -75,6 +77,7 @@ typedef enum io_iocb_cmd {
|
||||||
#elif defined(__powerpc64__) || defined(__s390x__) || \
|
#elif defined(__powerpc64__) || defined(__s390x__) || \
|
||||||
(defined(__hppa__) && defined(__arch64__)) || \
|
(defined(__hppa__) && defined(__arch64__)) || \
|
||||||
(defined(__sparc__) && defined(__arch64__)) || \
|
(defined(__sparc__) && defined(__arch64__)) || \
|
||||||
|
|
|
@ -1,34 +0,0 @@
|
||||||
From 4059161333a14a0c705efecc5765b6cb2a29ae02 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
||||||
Date: Oct 22 2018 18:43:14 +0000
|
|
||||||
Subject: Makefile: add missing DESTDIR variable use
|
|
||||||
|
|
||||||
|
|
||||||
Patch borrowed from OpenEmbedded, available at
|
|
||||||
recipes/libaio/libaio-0.3.106/destdir.patch in their source tree.
|
|
||||||
|
|
||||||
It just adds support for the traditional DESTDIR variable to install
|
|
||||||
the library in a different sysroot than the normal /.
|
|
||||||
|
|
||||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
||||||
[JEM: I couldn't verify the initial author of this change, but it's
|
|
||||||
trivial. For information on the DESTDIR convention, see:
|
|
||||||
https://www.gnu.org/prep/standards/html_node/DESTDIR.html]
|
|
||||||
Signed-off-by: Jeff Moyer <jmoyer@redhat.com>
|
|
||||||
|
|
||||||
---
|
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index e9dbdb0..c1fb831 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -14,7 +14,7 @@ all:
|
|
||||||
@$(MAKE) -C src
|
|
||||||
|
|
||||||
install:
|
|
||||||
- @$(MAKE) -C src install prefix=$(prefix) includedir=$(includedir) libdir=$(libdir)
|
|
||||||
+ @$(MAKE) -C src install prefix=$(DESTDIR)$(prefix) includedir=$(DESTDIR)$(includedir) libdir=$(DESTDIR)$(libdir)
|
|
||||||
|
|
||||||
check:
|
|
||||||
@$(MAKE) -C harness check
|
|
||||||
|
|
Loading…
Reference in a new issue