libinput: fix and optimize build
Buildbots are reporting the following build failure: -snip- CCLD test-build-linker ../src/.libs/libinput.so: undefined reference to `static_assert' -snap- Since this is the only call to static_assert within the library, removing this assertion seems to be reasonable. While at, speed up the build by not building tests and documentation. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
parent
80f02cd1ed
commit
e0aad338b7
2 changed files with 15 additions and 1 deletions
|
@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
|
|||
|
||||
TARGET_CFLAGS+= -std=gnu99
|
||||
|
||||
CONFIGURE_ARGS += --disable-libwacom
|
||||
CONFIGURE_ARGS += --disable-libwacom --disable-tests --disable-documentation
|
||||
|
||||
define Package/libinput
|
||||
SECTION:=libs
|
||||
|
|
14
libs/libinput/patches/002-static_assert.patch
Normal file
14
libs/libinput/patches/002-static_assert.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- a/src/evdev-tablet.c
|
||||
+++ b/src/evdev-tablet.c
|
||||
@@ -1155,9 +1155,11 @@ static void
|
||||
tablet_mark_all_axes_changed(struct tablet_dispatch *tablet,
|
||||
struct libinput_tablet_tool *tool)
|
||||
{
|
||||
+#if 0
|
||||
static_assert(sizeof(tablet->changed_axes) ==
|
||||
sizeof(tool->axis_caps),
|
||||
"Mismatching array sizes");
|
||||
+#endif
|
||||
|
||||
memcpy(tablet->changed_axes,
|
||||
tool->axis_caps,
|
Loading…
Reference in a new issue