commit
e020ead085
2 changed files with 3 additions and 50 deletions
|
@ -8,15 +8,15 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=p11-kit
|
||||
PKG_VERSION:=0.23.12
|
||||
PKG_VERSION:=0.23.13
|
||||
PKG_RELEASE:=1
|
||||
PKG_MAINTAINER:=Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=58bae22f19db1de1a1103e7ca4149eed6e303e727878c2cd5ea9e6fe445fd403
|
||||
PKG_HASH:=aa65403e3ac7c3aba17ca60f28db17b9c76d988b66b91789b8e8c145ae9922f1
|
||||
PKG_SOURCE_URL:=https://github.com/p11-glue/$(PKG_NAME)/releases/download/$(PKG_VERSION)
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
|
|
@ -1,47 +0,0 @@
|
|||
From dec5f888a457e36d81065ebc69f7d8d966be527d Mon Sep 17 00:00:00 2001
|
||||
From: Daiki Ueno <dueno@redhat.com>
|
||||
Date: Thu, 31 May 2018 11:02:51 +0200
|
||||
Subject: [PATCH] build: Ease issetugid() check when cross-compiling
|
||||
|
||||
When cross-compiling, the configure check for issetugid() aborts,
|
||||
because of the pessimistic default of AC_RUN_IFELSE. This patch
|
||||
provides the non-pessimistic default to AC_RUN_IFELSE and wrap the
|
||||
macro invocation with AC_CACHE_CHECK so that the user can override the
|
||||
check by setting ac_cv_issetugid_openbsd=yes, as suggested in:
|
||||
https://www.gnu.org/savannah-checkouts/gnu/autoconf/manual/autoconf-2.69/html_node/Runtime.html#Runtime
|
||||
---
|
||||
configure.ac | 16 +++++++++-------
|
||||
1 file changed, 9 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index e99a3c7..bd6ece0 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -115,15 +115,17 @@ if test "$os_unix" = "yes"; then
|
||||
|
||||
# Check if issetugid() is available and has compatible behavior with OpenBSD
|
||||
AC_CHECK_FUNCS([issetugid], [
|
||||
- AC_MSG_CHECKING([whether issetugid() can detect setuid/setgid])
|
||||
- issetugid_openbsd=no
|
||||
- AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <unistd.h>]],
|
||||
- [[return issetugid ();]])],
|
||||
- [chmod 02777 ./conftest$EXEEXT; ./conftest$EXEEXT || issetugid_openbsd=yes])
|
||||
- if test "$issetugid_openbsd" = yes; then
|
||||
+ AC_CACHE_CHECK([whether issetugid() can detect setuid/setgid],
|
||||
+ [ac_cv_issetugid_openbsd],
|
||||
+ [ac_cv_issetugid_openbsd=no
|
||||
+ AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <unistd.h>]],
|
||||
+ [[return issetugid ();]])],
|
||||
+ [chmod 02777 ./conftest$EXEEXT; ./conftest$EXEEXT || ac_cv_issetugid_openbsd=yes],
|
||||
+ [ac_cv_issetugid_openbsd=no],
|
||||
+ [ac_cv_issetugid_openbsd="guessing no"])])
|
||||
+ if test "$ac_cv_issetugid_openbsd" = yes; then
|
||||
AC_DEFINE([HAVE_ISSETUGID_OPENBSD], [1], [Whether issetugid() has compatible behavior with OpenBSD])
|
||||
fi
|
||||
- AC_MSG_RESULT([$issetugid_openbsd])
|
||||
])
|
||||
|
||||
# Required functions
|
||||
--
|
||||
2.17.1
|
||||
|
Loading…
Reference in a new issue