apinger: Update to latest git revision
This project seems abandoned. Updated to latest version. Also cleaned up the Makefile quite a bit. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
7fb0a94fb5
commit
dff6d2639e
5 changed files with 37 additions and 32 deletions
|
@ -8,23 +8,22 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=apinger
|
||||
PKG_VERSION:=0.6.1
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
||||
PKG_SOURCE_DATE:=2015-04-09
|
||||
PKG_SOURCE_VERSION:=78eb328721ba1a10571c19df95acd
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/Jajcus/apinger.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=c7da72f7ec26eedd7fd8d224c0e10787b204f94e
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
PKG_MIRROR_HASH:=c6739bef32568877ad63dbfa8e34b617a287e225a0344d4c41ba891e1f25d487
|
||||
PKG_SOURCE_URL:=https://github.com/Jajcus/apinger
|
||||
PKG_MIRROR_HASH:=4ada1330fc5d0adc0216d141f5e3b494df7a4c6500bbffce1efeab3d58684f7e
|
||||
|
||||
PKG_MAINTAINER:=Alex Samorukov <samm@os2.kiev.ua>
|
||||
PKG_LICENSE:= GPL-2.0
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
||||
PKG_REMOVE_FILES:=autogen.sh
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -33,7 +32,6 @@ define Package/apinger
|
|||
CATEGORY:=Network
|
||||
TITLE:=Tool which monitors various IP devices by simple ICMP echo requests
|
||||
URL:=https://github.com/Jajcus/apinger
|
||||
PKG_MAINTAINER:=Alex Samorukov <samm@os2.kiev.ua>
|
||||
endef
|
||||
|
||||
define Package/apinger/description
|
||||
|
@ -51,10 +49,6 @@ define Package/apinger/conffiles
|
|||
/etc/apinger.conf
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default)
|
||||
endef
|
||||
|
||||
define Package/apinger/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/apinger $(1)/usr/sbin/
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- apinger-0.6.1/acinclude.m4 2003-10-21 12:44:48.000000000 +0000
|
||||
+++ apinger-0.6.1/acinclude.m4 2015-04-08 15:27:37.451903960 +0000
|
||||
@@ -39,9 +39,7 @@
|
||||
[$jk_inet_includes
|
||||
$jk_icmp_includes])
|
||||
|
||||
-AC_CHECK_MEMBERS([struct icmp.icmp_type, struct icmp.icmp_code,\
|
||||
-struct icmp.icmp_cksum, struct icmp.icmp_seq,\
|
||||
-struct icmp.icmp_id],[],
|
||||
+AC_CHECK_MEMBERS([struct icmp.icmp_type, struct icmp.icmp_code,struct icmp.icmp_cksum, struct icmp.icmp_seq,struct icmp.icmp_id],[],
|
||||
AC_MSG_ERROR(struct icmp not defined or not compatible),
|
||||
[$jk_inet_includes
|
||||
$jk_icmp_includes])
|
|
@ -1,6 +1,6 @@
|
|||
--- apinger-0.6.1/src/apinger.conf.orig 2015-04-08 16:05:24.558919722 +0000
|
||||
+++ apinger-0.6.1/src/apinger.conf 2015-04-08 16:07:47.089170236 +0000
|
||||
@@ -9,7 +9,7 @@
|
||||
--- a/src/apinger.conf
|
||||
+++ b/src/apinger.conf
|
||||
@@ -8,7 +8,7 @@
|
||||
|
||||
## User and group the pinger should run as
|
||||
user "nobody"
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- apinger-0.6.1/Makefile.am.orig 2015-04-08 16:47:40.999990050 +0000
|
||||
+++ apinger-0.6.1/Makefile.am 2015-04-08 16:48:07.565220137 +0000
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -1,7 +1,7 @@
|
||||
|
||||
EXTRA_DIST = autogen.sh TODO BUGS
|
||||
|
|
24
net/apinger/patches/010-poll.patch
Normal file
24
net/apinger/patches/010-poll.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -23,7 +23,7 @@ AC_HEADER_SYS_WAIT
|
||||
AC_CHECK_HEADERS([arpa/inet.h errno.h malloc.h \
|
||||
stddef.h stdlib.h string.h sys/socket.h \
|
||||
sys/time.h syslog.h unistd.h time.h \
|
||||
- assert.h sys/poll.h signal.h pwd.h grp.h stdarg.h\
|
||||
+ assert.h poll.h signal.h pwd.h grp.h stdarg.h\
|
||||
limits.h sys/wait.h sched.h sys/ioctl.h sys/uio.h])
|
||||
AC_HEADER_TIME
|
||||
|
||||
--- a/src/apinger.c
|
||||
+++ b/src/apinger.c
|
||||
@@ -33,8 +33,8 @@
|
||||
#ifdef HAVE_SYS_WAIT_H
|
||||
# include <sys/wait.h>
|
||||
#endif
|
||||
-#ifdef HAVE_SYS_POLL_H
|
||||
-# include <sys/poll.h>
|
||||
+#ifdef HAVE_POLL_H
|
||||
+# include <poll.h>
|
||||
#endif
|
||||
#ifdef HAVE_ARPA_INET_H
|
||||
# include <arpa/inet.h>
|
Loading…
Reference in a new issue