lvm2: update to 2.03.15
Version 2.03.15 - 07th February 2022 ==================================== Remove service based autoactivation. global/event_activation = 0 is NOOP. Improve support for metadata profiles for --type writecache. Use cache or active DM device when available with new kernels. Introduce function to utilize UUIDs from DM_DEVICE_LIST. Increase some hash table size to better support large device sets. Version 2.03.16 - 18th May 2022 =============================== Fix segfault when handling selection with historical LVs. Add support --vdosettings with lvcreate, lvconvert, lvchange. Filtering multipath devices respects blacklist setting from multipath configuration. lvmdevices support for removing by device id using --deviceidtype and --deldev. Display writecache block size with lvs -o writecache_block_size. Improve cachesettings description in man lvmcache. Fix lossing of delete message on thin-pool extension. Mostly bug fixes and minor improvements. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit63408123df
) (cherry picked from commit4e70f5caef
)
This commit is contained in:
parent
8046d36f33
commit
dfd9236250
2 changed files with 8 additions and 8 deletions
|
@ -9,12 +9,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=LVM2
|
||||
PKG_VERSION:=2.03.14
|
||||
PKG_VERSION:=2.03.16
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=https://sourceware.org/pub/lvm2
|
||||
PKG_HASH:=4a63bc8a084a8ae3c7bc5e6530cac264139d218575c64416c8b99e3fe039a05c
|
||||
PKG_HASH:=e661ece15b5d88d8abe39a4c1e1db2f43e1896f019948bb98b0e15d777680786
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/lvm2-$(BUILD_VARIANT)/$(PKG_NAME).$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/commands/toolcontext.c
|
||||
+++ b/lib/commands/toolcontext.c
|
||||
@@ -1677,7 +1677,7 @@ struct cmd_context *create_toolcontext(u
|
||||
@@ -1673,7 +1673,7 @@ struct cmd_context *create_toolcontext(u
|
||||
/* FIXME Make this configurable? */
|
||||
reset_lvm_errno(1);
|
||||
|
||||
|
@ -9,10 +9,10 @@
|
|||
/* Set in/out stream buffering before glibc */
|
||||
if (set_buffering
|
||||
#ifdef SYS_gettid
|
||||
@@ -2064,7 +2064,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||
@@ -2053,7 +2053,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||
dm_hash_destroy(cmd->cft_def_hash);
|
||||
|
||||
if (cmd->pending_delete_mem)
|
||||
dm_pool_destroy(cmd->pending_delete_mem);
|
||||
dm_device_list_destroy(&cmd->cache_dm_devs);
|
||||
-#ifndef VALGRIND_POOL
|
||||
+#if defined(__GLIBC__) && !defined(VALGRIND_POOL)
|
||||
if (cmd->linebuffer) {
|
||||
|
@ -20,7 +20,7 @@
|
|||
if (is_valid_fd(STDIN_FILENO) &&
|
||||
--- a/tools/lvmcmdline.c
|
||||
+++ b/tools/lvmcmdline.c
|
||||
@@ -3381,6 +3381,7 @@ int lvm_split(char *str, int *argc, char
|
||||
@@ -3398,6 +3398,7 @@ int lvm_split(char *str, int *argc, char
|
||||
/* Make sure we have always valid filedescriptors 0,1,2 */
|
||||
static int _check_standard_fds(void)
|
||||
{
|
||||
|
@ -28,7 +28,7 @@
|
|||
int err = is_valid_fd(STDERR_FILENO);
|
||||
|
||||
if (!is_valid_fd(STDIN_FILENO) &&
|
||||
@@ -3407,6 +3408,12 @@ static int _check_standard_fds(void)
|
||||
@@ -3424,6 +3425,12 @@ static int _check_standard_fds(void)
|
||||
strerror(errno));
|
||||
return 0;
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue