Merge pull request #13072 from neheb/alpi
alpine: fix compilation without sys/cdefs
This commit is contained in:
commit
dfd0ca4295
2 changed files with 39 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=alpine
|
||||
PKG_VERSION:=2.23
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://alpine.x10host.com/alpine/release/src
|
||||
|
|
38
mail/alpine/patches/010-cdefs.patch
Normal file
38
mail/alpine/patches/010-cdefs.patch
Normal file
|
@ -0,0 +1,38 @@
|
|||
--- a/regex/regex.h
|
||||
+++ b/regex/regex.h
|
||||
@@ -42,16 +42,12 @@
|
||||
#ifndef _REGEX_H_
|
||||
#define _REGEX_H_
|
||||
|
||||
-#ifdef WIN32
|
||||
#include <sys/types.h>
|
||||
#define __const
|
||||
#define __BEGIN_DECLS
|
||||
#define __END_DECLS
|
||||
#define __P(_X) _X
|
||||
-#else
|
||||
-#include <sys/cdefs.h>
|
||||
#define __stdcall
|
||||
-#endif
|
||||
|
||||
/* types */
|
||||
typedef off_t regoff_t;
|
||||
@@ -106,12 +102,16 @@ typedef struct {
|
||||
#define REG_LARGE 01000 /* force large representation */
|
||||
#define REG_BACKR 02000 /* force use of backref code */
|
||||
|
||||
-__BEGIN_DECLS
|
||||
+#ifdef __cplusplus
|
||||
+extern "C" {
|
||||
+#endif
|
||||
int __stdcall regcomp __P((regex_t *, const char *, int));
|
||||
size_t __stdcall regerror __P((int, const regex_t *, char *, size_t));
|
||||
int __stdcall regexec __P((const regex_t *,
|
||||
const char *, size_t, regmatch_t [], int));
|
||||
void __stdcall regfree __P((regex_t *));
|
||||
-__END_DECLS
|
||||
+#ifdef __cplusplus
|
||||
+}
|
||||
+#endif
|
||||
|
||||
#endif /* !_REGEX_H_ */
|
Loading…
Reference in a new issue